aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-12-05 18:31:13 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-12-05 18:31:13 +0000
commit61eeb92bf84968dcd580845fca97ce9d8bcf8275 (patch)
treeb3c69e2fab1ea33ce0c0db17e114c5fd24f83f38 /games
parent0adb3d60c6b6ab64da6e21563b5cdab953474185 (diff)
downloadports-61eeb92bf84968dcd580845fca97ce9d8bcf8275.tar.gz
ports-61eeb92bf84968dcd580845fca97ce9d8bcf8275.zip
Fix build on amd64/ia64
PR: ports/74729 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=123251
Diffstat (limited to 'games')
-rw-r--r--games/easysok/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/easysok/Makefile b/games/easysok/Makefile
index ee7fb514c8bd..a7533c8797d8 100644
--- a/games/easysok/Makefile
+++ b/games/easysok/Makefile
@@ -19,6 +19,12 @@ USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fPIC
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g ; \
s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/${CONFIGURE_SCRIPT}
@@ -26,4 +32,4 @@ post-patch:
's|-lkdeprint|$$(LIB_KDEPRINT) $$(LIBPTHREAD)|g' \
${WRKSRC}/src/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>