aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-03-08 01:01:31 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-03-08 01:01:31 +0000
commit672c044e2eee3598f19a0f5e618e0c2fe8aea68d (patch)
tree771bbdda8fc0a17d5351cfa925732955ccc44706 /games
parent86240c80e62c10278c8b2c49d61a2198db15e6ed (diff)
downloadports-672c044e2eee3598f19a0f5e618e0c2fe8aea68d.tar.gz
ports-672c044e2eee3598f19a0f5e618e0c2fe8aea68d.zip
Properly use SDL everywhere:
USE_SDL=yes -> USE_SDL=sdl (good examles everywhere) WANT_SDL/HAVE_SDL instead of exists(localbase/lib/lib...) See http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/using-sdl.html for more information on how to use USE_SDL, WANT_SDL and HAVE_SDL. PR: follow-ups of ports/55494, ports/61877 Submitted by: Edwin Groothuis <edwin@mavetju.org>
Notes
Notes: svn path=/head/; revision=103247
Diffstat (limited to 'games')
-rw-r--r--games/abuse_sdl/Makefile2
-rw-r--r--games/adgali/Makefile2
-rw-r--r--games/amphetamine/Makefile2
-rw-r--r--games/columns/Makefile2
-rw-r--r--games/egoboo/Makefile2
-rw-r--r--games/exult/Makefile2
-rw-r--r--games/falconseye/Makefile2
-rw-r--r--games/freesci/Makefile5
-rw-r--r--games/gltron/Makefile7
-rw-r--r--games/lbreakout/Makefile2
-rw-r--r--games/lgeneral/Makefile2
-rw-r--r--games/lmarbles/Makefile2
-rw-r--r--games/maelstrom/Makefile6
-rw-r--r--games/marbles/Makefile2
-rw-r--r--games/newvox/Makefile2
-rw-r--r--games/quake2forge/Makefile3
-rw-r--r--games/quake2lnx/Makefile11
-rw-r--r--games/quakeforge/Makefile5
-rw-r--r--games/scummvm/Makefile2
-rw-r--r--games/tileworld/Makefile2
-rw-r--r--games/tuxpuck/Makefile2
-rw-r--r--games/wolf3d/Makefile2
-rw-r--r--games/xrick/Makefile2
23 files changed, 35 insertions, 36 deletions
diff --git a/games/abuse_sdl/Makefile b/games/abuse_sdl/Makefile
index 6fe9e62da2c4..86f0a6476210 100644
--- a/games/abuse_sdl/Makefile
+++ b/games/abuse_sdl/Makefile
@@ -16,7 +16,7 @@ COMMENT= An SDL port of the Abuse game engine
USE_BZIP2= yes
USE_MESA= yes
-USE_SDL= yes
+USE_SDL= sdl
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/games/adgali/Makefile b/games/adgali/Makefile
index 2a3bcc1457ae..571f97b6627b 100644
--- a/games/adgali/Makefile
+++ b/games/adgali/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
freetype.9:${PORTSDIR}/print/freetype2
-USE_SDL= yes
+USE_SDL= sdl
USE_GNOME= gnometarget
USE_REINPLACE= yes
USE_GMAKE= yes
diff --git a/games/amphetamine/Makefile b/games/amphetamine/Makefile
index 76411bf975cd..f21c74c6cbb1 100644
--- a/games/amphetamine/Makefile
+++ b/games/amphetamine/Makefile
@@ -19,7 +19,7 @@ COMMENT= A 2D - Jump'n'run shooter
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_XPM= yes
-USE_SDL= yes
+USE_SDL= sdl
USE_GMAKE= yes
DATAVERSION= 0.8.6
diff --git a/games/columns/Makefile b/games/columns/Makefile
index e178bfbe2861..dd0f474f23aa 100644
--- a/games/columns/Makefile
+++ b/games/columns/Makefile
@@ -15,7 +15,7 @@ DISTNAME= Columns-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Nice little implementation of columns game for X Window System
-USE_SDL= yes
+USE_SDL= sdl
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
diff --git a/games/egoboo/Makefile b/games/egoboo/Makefile
index 34642705f36e..b652b20ff22b 100644
--- a/games/egoboo/Makefile
+++ b/games/egoboo/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= Jan.Stocker@t-online.de
COMMENT= A 3d dungeon crawling adventure in the spirit of NetHack
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_SDL= yes
+USE_SDL= sdl
USE_MESA= yes
USE_GMAKE= yes
USE_REINPLACE= yes
diff --git a/games/exult/Makefile b/games/exult/Makefile
index bb459dd008c7..ccefd109b344 100644
--- a/games/exult/Makefile
+++ b/games/exult/Makefile
@@ -18,7 +18,7 @@ COMMENT= Ultima VII engine
RUN_DEPENDS= timidity:${PORTSDIR}/audio/timidity
USE_XLIB= yes
-USE_SDL= yes
+USE_SDL= sdl
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/games/falconseye/Makefile b/games/falconseye/Makefile
index a4c6170c3b67..a63f5c16633e 100644
--- a/games/falconseye/Makefile
+++ b/games/falconseye/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= timidity:${PORTSDIR}/audio/timidity
NHDIR= "${PREFIX}/share/falconseyedir"
MAKE_ENV= NHDIR="${NHDIR}" NETHACKCONFIG="${NETHACKCONFIG}"
NETHACKCONFIG= ${FILESDIR}/x-config
-USE_SDL= yes
+USE_SDL= sdl
USE_PERL5_BUILD=yes
USE_X_PREFIX= Yes
USE_ZIP= yes
diff --git a/games/freesci/Makefile b/games/freesci/Makefile
index 9bef9d963364..4c5fd823c636 100644
--- a/games/freesci/Makefile
+++ b/games/freesci/Makefile
@@ -20,6 +20,7 @@ USE_BZIP2= yes
USE_REINPLACE= yes
USE_XLIB= yes
GNU_CONFIGURE= yes
+WANT_SDL= yes
CONFIGURE_TARGET=
CONFIGURE_ENV= CFLAGS=${PTHREAD_CFLAGS}
@@ -28,7 +29,7 @@ MAN6= freesci-tools.6 freesci.6
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libSDL-1.1.so.5)
+.if ${HAVE_SDL:Msdl}!=""
WITH_SDL= yes
.endif
.if exists(${LOCALBASE}/lib/libdirectfb-0.9.so.16)
@@ -43,7 +44,7 @@ CONFIGURE_ARGS+= --with-console
.endif
.if defined(WITH_SDL) && !defined(WITHOUT_SDL)
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
+USE_SDL= yes
CONFIGURE_ARGS= --with-sdl-prefix=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-sdl
diff --git a/games/gltron/Makefile b/games/gltron/Makefile
index 2feef46aae4d..6a10e3847ab8 100644
--- a/games/gltron/Makefile
+++ b/games/gltron/Makefile
@@ -16,12 +16,11 @@ EXTRACT_SUFX= -source.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= A 3D worm game for two players for X Window System
-LIB_DEPENDS= SDL_sound-1.0.1:${PORTSDIR}/audio/sdl_sound \
- png.5:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_X_PREFIX= yes
USE_GL= yes
-USE_SDL= yes
+USE_SDL= sdl sound
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -33,7 +32,7 @@ CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
.if defined(WITH_SDL_NET)
-LIB_DEPENDS+= SDL_net:${PORTSDIR}/net/sdl_net
+USE_SDL+= net
CONFIGURE_ARGS+= --enable-network
.endif
diff --git a/games/lbreakout/Makefile b/games/lbreakout/Makefile
index 6826c553ae76..bec91705ebae 100644
--- a/games/lbreakout/Makefile
+++ b/games/lbreakout/Makefile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= lgames
MAINTAINER= ports@FreeBSD.org
COMMENT= A nice clone of classical Breakout game
-USE_SDL= yes
+USE_SDL= sdl
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/games/lgeneral/Makefile b/games/lgeneral/Makefile
index e17a87371616..6cbfcced4086 100644
--- a/games/lgeneral/Makefile
+++ b/games/lgeneral/Makefile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= lgeneral
MAINTAINER= filippo@widestore.net
COMMENT= A turn-based strategy engine inspired by Panzer General
-USE_SDL= yes
+USE_SDL= sdl
.ifndef (WITHOUT_SOUND)
USE_SDL= mixer
diff --git a/games/lmarbles/Makefile b/games/lmarbles/Makefile
index 78587c3b2bd6..614bdb155c3f 100644
--- a/games/lmarbles/Makefile
+++ b/games/lmarbles/Makefile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= lgames
MAINTAINER= verm@drunkmonk.net
COMMENT= A challenging puzzle game similar to Atomix
-USE_SDL= yes
+USE_SDL= sdl
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-profile-path=/var/games
diff --git a/games/maelstrom/Makefile b/games/maelstrom/Makefile
index db9ca8d307f3..4bccaede64da 100644
--- a/games/maelstrom/Makefile
+++ b/games/maelstrom/Makefile
@@ -14,14 +14,10 @@ DISTNAME= Maelstrom-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Asteroids-style game for X Window System
-LIB_DEPENDS= SDL_net.0:${PORTSDIR}/net/sdl_net
-
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
-
+USE_SDL= sdl net
USE_X_PREFIX= yes
USE_XPM= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
CONFIGURE_ARGS+=--program-transform-name=\'\'
.if !defined(NOPORTDOCS)
diff --git a/games/marbles/Makefile b/games/marbles/Makefile
index 78587c3b2bd6..614bdb155c3f 100644
--- a/games/marbles/Makefile
+++ b/games/marbles/Makefile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= lgames
MAINTAINER= verm@drunkmonk.net
COMMENT= A challenging puzzle game similar to Atomix
-USE_SDL= yes
+USE_SDL= sdl
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-profile-path=/var/games
diff --git a/games/newvox/Makefile b/games/newvox/Makefile
index 617247bfca17..cf3d71bdad8f 100644
--- a/games/newvox/Makefile
+++ b/games/newvox/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://www.libsdl.org/projects/newvox/src/
MAINTAINER= ports@FreeBSD.org
COMMENT= Voxel-style landscape rendering fly-by
-USE_SDL= yes
+USE_SDL= sdl
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
diff --git a/games/quake2forge/Makefile b/games/quake2forge/Makefile
index 715642a8f459..03881b1f801c 100644
--- a/games/quake2forge/Makefile
+++ b/games/quake2forge/Makefile
@@ -21,6 +21,7 @@ USE_GMAKE= yes
USE_LIBTOOL= yes
USE_XLIB= yes
INSTALLS_SHLIB= yes
+WANT_SDL= yes
LDCONFIG_DIRS= ${PREFIX}/lib/quake2 ${PREFIX}/lib/quake2/baseq2 ${PREFIX}/lib/quake2/ctf
.include <bsd.port.pre.mk>
@@ -28,7 +29,7 @@ LDCONFIG_DIRS= ${PREFIX}/lib/quake2 ${PREFIX}/lib/quake2/baseq2 ${PREFIX}/lib/qu
CONFIGURE_ARGS= --enable-static=no --program-transform-name='s/^quake2$$/q2f/'
CONFIGURE_TARGET=
-.if exists(${LOCALBASE}/lib/libSDL-1.1.so.5)
+.if ${HAVE_SDL:Msdl}!=""
WITH_SDL= yes
.endif
diff --git a/games/quake2lnx/Makefile b/games/quake2lnx/Makefile
index 91044d01b52d..4982b94019a3 100644
--- a/games/quake2lnx/Makefile
+++ b/games/quake2lnx/Makefile
@@ -27,6 +27,7 @@ COMMENT= Cleaned up copy of the original Quake II source code
USE_GMAKE= yes
USE_REINPLACE= yes
+WANT_SDL= yes
.include <bsd.port.pre.mk>
@@ -45,10 +46,10 @@ PLIST_SUB+= SVGA="@comment "
.endif
.if defined(WITH_SDLCLIENT) || defined(WITH_SDL) || defined(WITH_SDLGL) \
- || exists(${LOCALBASE}/lib/libSDL-1.1.so.5)
+ || ${HAVE_SDL:Msdl}!=""
. if !(defined(WITHOUT_SDLCLIENT) && defined(WITHOUT_SDL) \
&& defined(WITHOUT_SDLGL))
-USE_SDL= yes
+USE_SDL= sdl
. endif
. if !defined(WITHOUT_SDLCLIENT)
MAKE_ARGS+= BUILD_SDLQUAKE2=YES
@@ -188,13 +189,13 @@ pre-everything::
.if ${ARCH} == "i386" && !(defined(WITH_SVGA) || exists(${LOCALBASE}/lib/libvga.so.1))
@${ECHO_MSG} "Define WITH_SVGA to build SVGA driver"
.endif
-.if !(defined(WITH_SDL) || exists(${LOCALBASE}/lib/libSDL-1.1.so.5))
+.if !(defined(WITH_SDL) || ${HAVE_SDL:Msdl}!="")
@${ECHO_MSG} "Define WITH_SDL to build SDL software driver"
.endif
-.if !(defined(WITH_SDLGL) || exists(${LOCALBASE}/lib/libSDL-1.1.so.5))
+.if !(defined(WITH_SDLGL) || ${HAVE_SDL:Msdl}!="")
@${ECHO_MSG} "Define WITH_SDLGL to build SDL OpenGL driver"
.endif
-.if !(defined(WITH_SDLCLIENT) || exists(${LOCALBASE}/lib/libSDL-1.1.so.5))
+.if !(defined(WITH_SDLCLIENT) || ${HAVE_SDL:Msdl}!="")
@${ECHO_MSG} "Define WITH_SDLCLIENT to build executable that uses SDL for cdrom and sound"
.endif
.if !(defined(WITH_AA) || exists(${LOCALBASE}/lib/libaa.so.1))
diff --git a/games/quakeforge/Makefile b/games/quakeforge/Makefile
index 3d5f44b6fbfc..dfe1356f48bf 100644
--- a/games/quakeforge/Makefile
+++ b/games/quakeforge/Makefile
@@ -36,6 +36,7 @@ USE_GMAKE= yes
USE_XLIB= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
+WANT_SDL= yes
.include <bsd.port.pre.mk>
@@ -56,7 +57,7 @@ CFLAGS+= -ffast-math
.endif
.endif
-.if exists(${LOCALBASE}/lib/libSDL-1.1.so.5)
+.if ${HAVE_SDL:Msdl}!=""
WITH_SDL= yes
.endif
@@ -127,7 +128,7 @@ PLIST_SUB+= XMMS:="@comment "
.endif
.if !defined(WITHOUT_SDL) && defined(WITH_SDL)
-USE_SDL= yes
+USE_SDL= sdl
CONFIGURE_ARGS+=--with-sdl=${LOCALBASE}
PLIST_SUB+= SDL:=""
.else
diff --git a/games/scummvm/Makefile b/games/scummvm/Makefile
index 37ff0db945d0..da4b3db45391 100644
--- a/games/scummvm/Makefile
+++ b/games/scummvm/Makefile
@@ -22,7 +22,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_PERL5_BUILD=yes
USE_REINPLACE= yes
-USE_SDL= yes
+USE_SDL= sdl
MAN6= scummvm.6
diff --git a/games/tileworld/Makefile b/games/tileworld/Makefile
index 08bbce39ef4e..81f85289cf97 100644
--- a/games/tileworld/Makefile
+++ b/games/tileworld/Makefile
@@ -15,7 +15,7 @@ DISTNAME= tworld-${PORTVERSION}
MAINTAINER= sec@42.org
COMMENT= An emulation of the game "Chip's Challenge"
-USE_SDL= yes
+USE_SDL= sdl
GNU_CONFIGURE= YES
USE_GMAKE= YES
USE_REINPLACE= YES
diff --git a/games/tuxpuck/Makefile b/games/tuxpuck/Makefile
index e6ac96e69b67..3809b506b450 100644
--- a/games/tuxpuck/Makefile
+++ b/games/tuxpuck/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
vorbis.3:${PORTSDIR}/audio/libvorbis
-USE_SDL= yes
+USE_SDL= sdl
USE_GMAKE= yes
ALL_TARGET= tuxpuck
diff --git a/games/wolf3d/Makefile b/games/wolf3d/Makefile
index 51129c4b4548..edb2552e22c4 100644
--- a/games/wolf3d/Makefile
+++ b/games/wolf3d/Makefile
@@ -16,7 +16,7 @@ DISTFILES= wolf3d-20011028.tar.gz:wolf wolfdata.tar.gz:wolfdata
MAINTAINER= tlp@liquidx.org
COMMENT= "Wolfenstein 3D Linux" by Steven Fuller (1992)
-USE_SDL= yes
+USE_SDL= sdl
USE_GZIP= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
diff --git a/games/xrick/Makefile b/games/xrick/Makefile
index 14f036fc03c0..eb27c6e2d4d0 100644
--- a/games/xrick/Makefile
+++ b/games/xrick/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
RESTRICTED= Copyright status of the graphics and sounds is uncertain
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_SDL= yes
+USE_SDL= sdl
MAN6= xrick.6
MANCOMPRESSED= yes