aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-06-28 00:19:36 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-06-28 00:19:36 +0000
commit09a0dd14445a1ce9795f55adbb346694f84365c1 (patch)
tree960609fd4e01ec29a9fcb0b7c1800f44247d89b7 /games
parentbb73514511ac60fb4937eddfefcbe2df0d49e4aa (diff)
downloadports-09a0dd14445a1ce9795f55adbb346694f84365c1.tar.gz
ports-09a0dd14445a1ce9795f55adbb346694f84365c1.zip
Red Eclipse is a single-player and multi-player first-person ego-shooter,
built as a total conversion of Cube Engine 2, which lends itself toward a balanced gameplay, with a general theme of agility in a variety of environments. WWW: http://www.redeclipse.net/ PR: 155682, 156010, 158308 (taken some bits from) Submitted by: Sender Ghost <lightside@safebox.ru>
Notes
Notes: svn path=/head/; revision=276537
Diffstat (limited to 'games')
-rw-r--r--games/redeclipse/Makefile53
-rw-r--r--games/redeclipse/distinfo5
-rw-r--r--games/redeclipse/files/bfclient.in3
-rw-r--r--games/redeclipse/files/bfserver.in3
-rw-r--r--games/redeclipse/files/patch-src_Makefile10
-rw-r--r--games/redeclipse/files/reclient.in3
-rw-r--r--games/redeclipse/files/reserver.in3
-rw-r--r--games/redeclipse/pkg-descr10
8 files changed, 55 insertions, 35 deletions
diff --git a/games/redeclipse/Makefile b/games/redeclipse/Makefile
index 12bd4f92adde..803434f8ff0d 100644
--- a/games/redeclipse/Makefile
+++ b/games/redeclipse/Makefile
@@ -5,27 +5,36 @@
# $FreeBSD$
#
-PORTNAME= bloodfrontier
-DISTVERSION= B2
-PORTREVISION= 4
+PORTNAME= redeclipse
+PORTVERSION= 1.0
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/Blood%20Frontier%20Beta%202
-DISTNAME= ${PORTNAME}-${DISTVERSION}-linux
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}_${PORTVERSION}
+DISTNAME= ${PORTNAME}_${PORTVERSION}_linux
MAINTAINER= amdmi3@FreeBSD.org
-COMMENT= Single- and multi-player first-person shooter based on Cube 2
+COMMENT= A single-player and multi-player first-person ego-shooter
+
+LICENSE_COMB= multi
+LICENSE= MIT ZLIB
+LICENSE_NAME_ZLIB= zlib license
+LICENSE_FILE_ZLIB= ${WRKSRC}/license.txt
+LICENSE_PERMS_ZLIB= ${_LICENSE_PERMS_DEFAULT}
+LICENSE_GROUPS_ZLIB= FSF GPL OSI
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_BZIP2= yes
CONFIGURE_WRKSRC= ${WRKSRC}/src/enet
+CONFIGURE_ARGS= --enable-shared=no --enable-static=yes
BUILD_WRKSRC= ${WRKSRC}/src
WRKSRC= ${WRKDIR}/${PORTNAME}
ALL_TARGET= libenet ${BINARIES}
MAKE_JOBS_SAFE= yes
-SUB_FILES= bfclient bfserver
+SUB_FILES= reclient reserver
+
+PORTDATA= *
OPTIONS= CLIENT "Build client" on \
DEDICATED "Build dedicated server" on \
@@ -44,12 +53,19 @@ IGNORE= needs at least one executable (CLIENT or DEDICATED)
.if !defined(WITHOUT_CLIENT)
USE_GL= yes
USE_SDL= image mixer sdl
-PLIST_FILES+= bin/bfclient libexec/bfclient
+PLIST_FILES+= bin/reclient libexec/reclient share/pixmaps/redeclipse.ico
BINARIES+= client
+
+DESKTOP_ENTRIES="Red Eclipse" \
+ "${COMMENT}" \
+ "${PREFIX}/share/pixmaps/redeclipse.ico" \
+ "reclient" \
+ "Application;Game;" \
+ ${FALSE}
.endif
.if !defined(WITHOUT_DEDICATED)
-PLIST_FILES+= bin/bfserver libexec/bfserver
+PLIST_FILES+= bin/reserver libexec/reserver
BINARIES+= server
.endif
@@ -60,16 +76,21 @@ CXXFLAGS+= -O3 -fomit-frame-pointer
do-install:
.for f in ${BINARIES}
- ${INSTALL_SCRIPT} ${WRKDIR}/bf${f} ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/bf${f} ${PREFIX}/libexec
+ ${INSTALL_SCRIPT} ${WRKDIR}/re${f} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/re${f} ${PREFIX}/libexec
.endfor
+.if !defined(NOPORTDATA)
${MKDIR} ${DATADIR}
cd ${WRKSRC}/data && ${COPYTREE_SHARE} "." ${DATADIR}/
+.endif
+.if !defined(WITHOUT_CLIENT)
+ ${INSTALL_DATA} ${WRKSRC}/src/redeclipse.ico ${PREFIX}/share/pixmaps/
+.endif
-post-install:
- @${FIND} ${DATADIR} -type f | \
- ${SED} -e 's|^${PREFIX}/||' >> ${TMPPLIST}
- @${FIND} ${DATADIR} -type d | ${SORT} -r | \
- ${SED} -e 's|^${PREFIX}/|@dirrm |' >> ${TMPPLIST}
+#post-install:
+# @${FIND} ${DATADIR} -type f | \
+# ${SED} -e 's|^${PREFIX}/||' >> ${TMPPLIST}
+# @${FIND} ${DATADIR} -type d | ${SORT} -r | \
+# ${SED} -e 's|^${PREFIX}/|@dirrm |' >> ${TMPPLIST}
.include <bsd.port.mk>
diff --git a/games/redeclipse/distinfo b/games/redeclipse/distinfo
index 69b647527760..31ca690dc975 100644
--- a/games/redeclipse/distinfo
+++ b/games/redeclipse/distinfo
@@ -1,3 +1,2 @@
-MD5 (bloodfrontier-B2-linux.tar.bz2) = 814df812d14714687f44085c83d5b91b
-SHA256 (bloodfrontier-B2-linux.tar.bz2) = e05e7e18661d906fc0685c72704493fe8a8bbd0b803747ceaf4038527f957b58
-SIZE (bloodfrontier-B2-linux.tar.bz2) = 417998023
+SHA256 (redeclipse_1.0_linux.tar.bz2) = 19f80ca14c3898ff166c6708885a6afee7aeb7acbc1133fc25a53faf12a0b874
+SIZE (redeclipse_1.0_linux.tar.bz2) = 443072620
diff --git a/games/redeclipse/files/bfclient.in b/games/redeclipse/files/bfclient.in
deleted file mode 100644
index 070440a1a1ca..000000000000
--- a/games/redeclipse/files/bfclient.in
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-cd %%DATADIR%% && exec %%PREFIX%%/libexec/bfclient "$@"
diff --git a/games/redeclipse/files/bfserver.in b/games/redeclipse/files/bfserver.in
deleted file mode 100644
index ae98bc0bdd9a..000000000000
--- a/games/redeclipse/files/bfserver.in
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-cd %%DATADIR%% && exec %%PREFIX%%/libexec/bfserver "$@"
diff --git a/games/redeclipse/files/patch-src_Makefile b/games/redeclipse/files/patch-src_Makefile
index c7f5e89d57ac..909d9bb3a52a 100644
--- a/games/redeclipse/files/patch-src_Makefile
+++ b/games/redeclipse/files/patch-src_Makefile
@@ -1,5 +1,5 @@
---- src/Makefile.orig 2009-11-25 14:52:58.000000000 +0300
-+++ src/Makefile 2009-12-17 00:09:47.000000000 +0300
+--- src/Makefile.orig 2011-02-27 23:30:20.000000000 +0300
++++ src/Makefile 2011-06-12 11:41:48.000000000 +0400
@@ -1,5 +1,4 @@
#CXXFLAGS= -ggdb3
-CXXFLAGS= -O3 -fomit-frame-pointer
@@ -8,12 +8,12 @@
PLATFORM= $(shell uname -s)
@@ -21,8 +20,8 @@
CLIENT_INCLUDES= -DINTERFACE -DIRC $(INCLUDES) -Iinclude
- CLIENT_LIBS= -mwindows -lmingw32 -Llib -lSDLmain -lSDL -lSDL_image -lSDL_mixer -lzdll -lopengl32 -lenet -lws2_32 -lwinmm
+ CLIENT_LIBS= -mwindows -Llib -lSDL -lSDL_image -lSDL_mixer -lzdll -lopengl32 -lenet -lws2_32 -lwinmm
else
-CLIENT_INCLUDES= -DINTERFACE -DIRC $(INCLUDES) -I/usr/X11R6/include `sdl-config --cflags`
--CLIENT_LIBS= -Lenet -lenet -L/usr/X11R6/lib `sdl-config --libs` -lSDL_image -lSDL_mixer -lz -lGL
+-CLIENT_LIBS= -Lenet/.libs -lenet -L/usr/X11R6/lib -lX11 `sdl-config --libs` -lSDL_image -lSDL_mixer -lz -lGL
+CLIENT_INCLUDES= -DINTERFACE -DIRC $(INCLUDES) -I${LOCALBASE}/include `${SDL_CONFIG} --cflags`
-+CLIENT_LIBS= -Lenet -lenet -L${LOCALBASE}/lib `${SDL_CONFIG} --libs` -lSDL_image -lSDL_mixer -lz -lGL
++CLIENT_LIBS= -Lenet/.libs -lenet -L${LOCALBASE}/lib -lX11 `${SDL_CONFIG} --libs` -lSDL_image -lSDL_mixer -lz -lGL
endif
ifeq ($(PLATFORM),Linux)
CLIENT_LIBS+= -lrt
diff --git a/games/redeclipse/files/reclient.in b/games/redeclipse/files/reclient.in
new file mode 100644
index 000000000000..9f2c486c229d
--- /dev/null
+++ b/games/redeclipse/files/reclient.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+cd %%DATADIR%% && exec %%PREFIX%%/libexec/reclient "$@"
diff --git a/games/redeclipse/files/reserver.in b/games/redeclipse/files/reserver.in
new file mode 100644
index 000000000000..2ea2528cf46b
--- /dev/null
+++ b/games/redeclipse/files/reserver.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+cd %%DATADIR%% && exec %%PREFIX%%/libexec/reserver "$@"
diff --git a/games/redeclipse/pkg-descr b/games/redeclipse/pkg-descr
index 5a1891fcb570..28bb02afbbd2 100644
--- a/games/redeclipse/pkg-descr
+++ b/games/redeclipse/pkg-descr
@@ -1,6 +1,6 @@
-Single-player and multi-player first-person shooter, built as a
-total conversion of Cube Engine 2, which lends itself toward a
-balanced gameplay, completely at the control of map makers, while
-maintaining a general theme of tactics and low gravity.
+Red Eclipse is a single-player and multi-player first-person ego-shooter,
+built as a total conversion of Cube Engine 2, which lends itself toward
+a balanced gameplay, with a general theme of agility in a variety of
+environments.
-WWW: http://www.bloodfrontier.com/
+WWW: http://www.redeclipse.net/