aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2011-06-28 19:44:03 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2011-06-28 19:44:03 +0000
commit263f887bfbcc3870432d0f2cc39b86ecc049acc2 (patch)
tree253b844e94ea313bfa2e217ae6fb707d1add6583 /games
parentf70fe48c3538565874bd6798d7de7798fe383034 (diff)
downloadports-263f887bfbcc3870432d0f2cc39b86ecc049acc2.tar.gz
ports-263f887bfbcc3870432d0f2cc39b86ecc049acc2.zip
Update to 20110627
PR: ports/156932 Submitted by: Olivier Smedts (maintainer)
Notes
Notes: svn path=/head/; revision=276606
Diffstat (limited to 'games')
-rw-r--r--games/eduke32/Makefile56
-rw-r--r--games/eduke32/distinfo8
-rw-r--r--games/eduke32/files/patch-build-src-mmulti_unstable.c14
-rw-r--r--games/eduke32/files/patch-source-jaudiolib-dsl.c10
-rw-r--r--games/eduke32/pkg-plist9
5 files changed, 43 insertions, 54 deletions
diff --git a/games/eduke32/Makefile b/games/eduke32/Makefile
index cfb6a7d284be..d3363cdd6b7d 100644
--- a/games/eduke32/Makefile
+++ b/games/eduke32/Makefile
@@ -5,25 +5,27 @@
# $FreeBSD$
PORTNAME= eduke32
-PORTVERSION= 20090313
-PORTREVISION= 3
-DISTVERSION= 20090131
+PORTVERSION= 20110627
CATEGORIES= games
-MASTER_SITES= http://dukeworld.duke4.net/eduke32/source_code/
-DISTFILES= ${PORTNAME}_src_${DISTVERSION}${EXTRACT_SUFX}
-PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= ${PORTNAME}_src_${PORTVERSION}.diff
+MASTER_SITES= http://dukeworld.duke4.net/eduke32/synthesis/${PORTVERSION}-${SVNREVISION}/ \
+ http://dukeworld.duke4.net/eduke32/synthesis/old/${PORTVERSION}-${SVNREVISION}/
+DISTNAME= ${PORTNAME}_src_${PORTVERSION}-${SVNREVISION}
MAINTAINER= olivier@gid0.org
COMMENT= Duke Nukem 3D Port based on JFDuke and EDuke
-USE_ZIP= yes
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/GNU.TXT
+
+LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
+
+USE_BZIP2= yes
USE_GMAKE= yes
USE_GL= gl
USE_GNOME= gtk20
USE_SDL= mixer sdl
-WRKSRC= ${WRKDIR}/${PORTNAME}_src_${DISTVERSION}
-PATCH_ARGS= -d ${PATCH_WRKSRC} --forward --quiet -E ${PATCH_STRIP} -l
+WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}-${SVNREVISION}
+SVNREVISION= 1923
OPTIONS= MIDI "Enable original MIDI music support" On \
TIMIDITYPLUS "Use Timidity++ instead of Timidity" Off \
@@ -55,32 +57,38 @@ LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
post-patch:
.if defined(WITHOUT_VORBIS)
- @${REINPLACE_CMD} -e '/LIBS+= -lvorbis/d' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} '/+= -lvorbis/d' ${WRKSRC}/Makefile
.endif
.if ${ARCH} != "i386"
- @${REINPLACE_CMD} -Ee 's|^(NOASM =).*|\1 1|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} '/^NOASM =/s/0/1/' ${WRKSRC}/Makefile.common
.endif
- @${REINPLACE_CMD} -Ee \
- 's|^(CC=).*|\1${CC}|; \
- s|^(CXX=).*|\1${CXX}|; \
- /debug=/d; \
- s|/usr/X11R6|${LOCALBASE}|; \
- s|sdl-config|${SDL_CONFIG}|' \
- ${WRKSRC}/Makefile \
- ${WRKSRC}/build/Makefile \
+ @${REINPLACE_CMD} -e '/^CC=/s/gcc/${CC}/' -e '/^CXX=/s/g++/${CXX}/' \
+ ${WRKSRC}/Makefile.common
+ @${REINPLACE_CMD} 's/ \$$(ARCH)//' ${WRKSRC}/Makefile \
+ ${WRKSRC}/build/Makefile
+ @${REINPLACE_CMD} -Ee '/^ifeq/s/LINUX/BSD/' \
+ -e 's/(\+= -lvorbisfile)/\1 -lexecinfo/' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|' -e 's/ -ldl//' \
+ ${WRKSRC}/build/Makefile
+ @${REINPLACE_CMD} -E 's|(SDLCONFIG[[:space:]]*=).*|\1${SDL_CONFIG}|' \
${WRKSRC}/build/Makefile.shared
- @${REINPLACE_CMD} -e 's|LINUX|BSD|' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|/usr/share/games/eduke32|${DN3DDIR}|' \
+ @${REINPLACE_CMD} 's|/usr/share/games/eduke32|${DN3DDIR}|' \
${WRKSRC}/source/game.c ${WRKSRC}/source/astub.c
+ @${REINPLACE_CMD} -E 's|(-DHAVE_VORBIS)|-I${LOCALBASE}/include \1|' \
+ ${WRKSRC}/source/jaudiolib/Makefile
do-install:
.for f in eduke32 mapster32
${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
.endfor
.if !defined(NOPORTDOCS)
-. for f in ChangeLog *.sample
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${WRKSRC}/samples/*.sample ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+. for f in cfg map m32 txt
+ ${INSTALL_DATA} ${WRKSRC}/samples/*.${f} ${EXAMPLESDIR}
. endfor
.endif
diff --git a/games/eduke32/distinfo b/games/eduke32/distinfo
index 083979c3fb03..f0943c782d0d 100644
--- a/games/eduke32/distinfo
+++ b/games/eduke32/distinfo
@@ -1,6 +1,2 @@
-MD5 (eduke32_src_20090131.zip) = cf5eb51de024f28e8b24aae2702d459e
-SHA256 (eduke32_src_20090131.zip) = e6b8cc2c7e0c32a6aa5a64359be8b8c494dcae08dda87e1de718c030426ef74d
-SIZE (eduke32_src_20090131.zip) = 1694234
-MD5 (eduke32_src_20090313.diff) = fd9fa13146c9a31b2eb709aff93a4afa
-SHA256 (eduke32_src_20090313.diff) = de13b9600868b98195c18a138fe6dd27fd29f054035ec966d03d28a220b472be
-SIZE (eduke32_src_20090313.diff) = 113568
+SHA256 (eduke32_src_20110627-1923.tar.bz2) = 6ad33f7acf9cdd26ca49f7813fbe23b888b95fd2f587851c971f860b59185e4a
+SIZE (eduke32_src_20110627-1923.tar.bz2) = 2817419
diff --git a/games/eduke32/files/patch-build-src-mmulti_unstable.c b/games/eduke32/files/patch-build-src-mmulti_unstable.c
deleted file mode 100644
index e73eb20ea6b7..000000000000
--- a/games/eduke32/files/patch-build-src-mmulti_unstable.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- build/src/mmulti_unstable.c.orig 2009-02-02 23:21:58.000000000 +0100
-+++ build/src/mmulti_unstable.c 2009-02-02 23:27:30.000000000 +0100
-@@ -971,7 +971,11 @@
- {
- /* !!! FIXME: Might be Linux (not Unix, not BSD, not WinSock) specific. */
- int32_t flags = 1;
-- setsockopt(udpsocket, SOL_IP, IP_RECVERR, &flags, sizeof(flags));
-+ int sol_ip;
-+ struct protoent *pent;
-+ pent = getprotobyname ("ip");
-+ sol_ip = (pent != NULL) ? pent->p_proto : 0;
-+ setsockopt(udpsocket, sol_ip, SO_ERROR, &flags, sizeof(flags));
- }
- #endif
diff --git a/games/eduke32/files/patch-source-jaudiolib-dsl.c b/games/eduke32/files/patch-source-jaudiolib-dsl.c
deleted file mode 100644
index e999c131f17c..000000000000
--- a/games/eduke32/files/patch-source-jaudiolib-dsl.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- source/jaudiolib/dsl.c.orig 2009-02-02 23:13:40.000000000 +0100
-+++ source/jaudiolib/dsl.c 2009-02-02 23:13:53.000000000 +0100
-@@ -22,6 +22,7 @@
- */
- #include <stdlib.h>
- #include <string.h>
-+#include <sys/types.h>
-
- #include "dsl.h"
- #include "compat.h"
diff --git a/games/eduke32/pkg-plist b/games/eduke32/pkg-plist
index 999b44cc729d..1332d4356ab3 100644
--- a/games/eduke32/pkg-plist
+++ b/games/eduke32/pkg-plist
@@ -3,4 +3,13 @@ bin/mapster32
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/duke3d.def.sample
%%PORTDOCS%%%%DOCSDIR%%/enhance.con.sample
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/_clipshape0.map
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/a.m32
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/m32script_ex.map
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ror.map
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/spriteclip.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests.m32
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tiles.cfg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/trueror1.map
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%