aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-06-25 07:48:30 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-06-25 07:48:30 +0000
commitca03e96275edbaacaad9cfeb3655445fcce2197c (patch)
tree14a74a1d28c1108049a959cb6206ea958ae12895 /games
parent00899d7b5fcd9eb2848bd5114f6ac1f47e49c8d8 (diff)
downloadports-ca03e96275edbaacaad9cfeb3655445fcce2197c.tar.gz
ports-ca03e96275edbaacaad9cfeb3655445fcce2197c.zip
- Fix build with CLANG
PR: 158103 Submitted by: Guido Falsi <mad@madpilot.net>
Notes
Notes: svn path=/head/; revision=276332
Diffstat (limited to 'games')
-rw-r--r--games/acm/distinfo1
-rw-r--r--games/acm/files/patch-dis-test-disscope.c11
2 files changed, 11 insertions, 1 deletions
diff --git a/games/acm/distinfo b/games/acm/distinfo
index 87e65818c058..c4c478d2b6d3 100644
--- a/games/acm/distinfo
+++ b/games/acm/distinfo
@@ -1,3 +1,2 @@
-MD5 (acm-5.0.tar.gz) = 8d27051a3aa0d85b90f66a86f746e827
SHA256 (acm-5.0.tar.gz) = d5c567681b88a1012548f2a98aa88199e83789518b5303ce8053bb4e38dd5b2b
SIZE (acm-5.0.tar.gz) = 1218154
diff --git a/games/acm/files/patch-dis-test-disscope.c b/games/acm/files/patch-dis-test-disscope.c
new file mode 100644
index 000000000000..52eec9d0df8a
--- /dev/null
+++ b/games/acm/files/patch-dis-test-disscope.c
@@ -0,0 +1,11 @@
+--- dis/test/disscope.c.orig 1998-12-10 23:58:01.000000000 +0100
++++ dis/test/disscope.c 2011-06-21 13:01:46.689444826 +0200
+@@ -172,7 +172,7 @@
+ #endif
+ ++ count;
+ }
+- return;
++ return 0;
+ }
+
+ char *