aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-12-14 20:32:52 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-12-14 20:32:52 +0000
commitb1823ce4c08f949c61d0241bb58c2eaeff967d75 (patch)
treef78305d6f732c0c228f016cf8554f95755c79525 /games
parent4a1924155e2b81848d61f959b46ccad6eb7f19e8 (diff)
downloadports-b1823ce4c08f949c61d0241bb58c2eaeff967d75.tar.gz
ports-b1823ce4c08f949c61d0241bb58c2eaeff967d75.zip
- Update to 102.2.1
- Support NOPORTDOCS - Add desktop entry - New pkg-descr - Add empty directories to package PR: ports/141461 Submitted by: Tijl Coosemans <tijl@coosemans.org> (maintainer)
Notes
Notes: svn path=/head/; revision=245796
Diffstat (limited to 'games')
-rw-r--r--games/simutrans/Makefile37
-rw-r--r--games/simutrans/Makefile.plist89
-rw-r--r--games/simutrans/distinfo21
-rw-r--r--games/simutrans/files/simutrans.desktop7
-rw-r--r--games/simutrans/pkg-descr15
-rw-r--r--games/simutrans/pkg-plist13
6 files changed, 152 insertions, 30 deletions
diff --git a/games/simutrans/Makefile b/games/simutrans/Makefile
index d6fafa5e544a..8c2e9fd2d666 100644
--- a/games/simutrans/Makefile
+++ b/games/simutrans/Makefile
@@ -6,15 +6,19 @@
#
PORTNAME= simutrans
-PORTVERSION= 102.0
+PORTVERSION= 102.2.1
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/102-0
-DISTFILES= simutrans-src-102-0.zip \
- simulinux-102-0.zip \
- pak64-102-0.zip
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${SIMUTRANS_VERSION} \
+ SF/${PORTNAME}/pak64/${SIMUTRANS_VERSION}:pak64
+DISTFILES= simutrans-src-${SIMUTRANS_VERSION}.zip \
+ simulinux-${SIMUTRANS_VERSION}.zip \
+ simupak64-${SIMUTRANS_VERSION}.zip:pak64 \
+ simupak64-addon-food-${SIMUTRANS_VERSION}.zip:pak64
MAINTAINER= tijl@coosemans.org
-COMMENT= Transport business simulation game
+COMMENT= Transportation simulation game
+
+SIMUTRANS_VERSION= ${PORTVERSION:S,.,-,g}
MAKE_ARGS= BACKEND=mixer_sdl \
COLOUR_DEPTH=16 \
@@ -28,19 +32,30 @@ USE_ZIP= yes
.include "${.CURDIR}/Makefile.plist"
-PLIST_DIRS= ${SIMUTRANS_DIRS:S/^/%%DATADIR%%\//} %%DATADIR%%
-PLIST_FILES= bin/simutrans \
- bin/simutrans-bin \
- ${SIMUTRANS_DATA:S/^/%%DATADIR%%\//}
+PLIST_DIRS= ${SIMUTRANS_DIRS:S,^,%%DATADIR%%/,} %%DATADIR%%
+PLIST_FILES= ${SIMUTRANS_DATA:S,^,%%DATADIR%%/,} \
+ ${SIMUTRANS_DOCS:S,^,%%PORTDOCS%%%%DATADIR%%/,}
+
+post-patch:
+ @${REINPLACE_CMD} 's/simutrans/.simutrans/' ${WRKSRC}/simsys_s.cc
do-install:
-.for _D in ${SIMUTRANS_DIRS}
+ ${MKDIR} ${DATADIR}
+.for _D in ${SIMUTRANS_DIRS:O}
${MKDIR} ${DATADIR}/${_D}
.endfor
.for _D in ${SIMUTRANS_DATA}
${INSTALL_DATA} ${WRKSRC}/simutrans/${_D} ${DATADIR}/${_D}
.endfor
+.ifndef NOPORTDOCS
+.for _D in ${SIMUTRANS_DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/simutrans/${_D} ${DATADIR}/${_D}
+.endfor
+.endif
${INSTALL_PROGRAM} ${WRKSRC}/sim ${PREFIX}/bin/simutrans-bin
${INSTALL_SCRIPT} ${FILESDIR}/simutrans ${PREFIX}/bin/simutrans
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${FILESDIR}/simutrans.desktop \
+ ${PREFIX}/share/applications/simutrans.desktop
.include <bsd.port.mk>
diff --git a/games/simutrans/Makefile.plist b/games/simutrans/Makefile.plist
index c4ea303cc7a3..6a70823a2a46 100644
--- a/games/simutrans/Makefile.plist
+++ b/games/simutrans/Makefile.plist
@@ -1,21 +1,34 @@
SIMUTRANS_DIRS= \
text/zh \
+text/tr \
+text/sv \
text/sk \
text/ru \
text/ro \
text/pt \
text/pl \
+text/no \
text/nl \
+text/lt \
text/ja \
text/it \
+text/id \
text/hu \
+text/hr \
+text/gr \
text/fr \
+text/fi \
+text/et \
text/es \
text/en \
text/dk \
text/de \
text/cz \
+text/cn \
+text/ca \
+text/be \
text \
+skin \
pak/text \
pak/sound \
pak/scenario \
@@ -34,7 +47,6 @@ font/m+10r.bdf \
font/prop-latin2.fnt \
font/prop.fnt \
font/ro_font.fnt \
-licence.txt \
music/01-Simutrans-Main-Theme.mid \
music/02-Gotta-catch-that-train.mid \
music/03-Sunday-drivers.mid \
@@ -360,8 +372,10 @@ pak/factory.ChemicalPlant.pak \
pak/factory.Concretefactory.pak \
pak/factory.Druckerei.pak \
pak/factory.Erzbergwerk.pak \
+pak/factory.Geokraftwerk.pak \
pak/factory.Kohlegrube.pak \
pak/factory.Kohlekraftwerk.pak \
+pak/factory.Marketplace.pak \
pak/factory.Materialswholesale.pak \
pak/factory.Moebelfabrik.pak \
pak/factory.Moebelhaus.pak \
@@ -382,7 +396,21 @@ pak/factory.Stonequarry.pak \
pak/factory.TANKE.pak \
pak/factory.Turmkraftwerk.pak \
pak/factory.Windkraftwerk.pak \
+pak/factory.bakery.pak \
+pak/factory.brewery.pak \
+pak/factory.cannery.pak \
+pak/factory.cow_farm.pak \
+pak/factory.dairy.pak \
+pak/factory.fish_pond.pak \
+pak/factory.fish_swarm.pak \
+pak/factory.food_processing_plant.pak \
+pak/factory.grain_farm.pak \
+pak/factory.grain_mill.pak \
+pak/factory.grain_windmill.pak \
+pak/factory.old_farm.pak \
+pak/factory.supermarket.pak \
pak/factory.thermisches_Solarkraftwerk.pak \
+pak/field.wheat_fields.pak \
pak/good.Autos.pak \
pak/good.Bretter.pak \
pak/good.Buecher.pak \
@@ -405,6 +433,14 @@ pak/good.PrintersInk.pak \
pak/good.Sand.pak \
pak/good.Stahl.pak \
pak/good.Stone.pak \
+pak/good.beer.pak \
+pak/good.canned_food.pak \
+pak/good.fish.pak \
+pak/good.flour.pak \
+pak/good.food.pak \
+pak/good.grain.pak \
+pak/good.meat.pak \
+pak/good.milk.pak \
pak/ground.Basement.pak \
pak/ground.Borders.pak \
pak/ground.ClimateTexture.pak \
@@ -423,6 +459,8 @@ pak/ground_obj.See2.pak \
pak/ground_obj.See3.pak \
pak/ground_obj.See4.pak \
pak/ground_obj.bushes.pak \
+pak/ground_obj.deco_rock.pak \
+pak/ground_obj.deco_rock_2.pak \
pak/ground_obj.flowers.pak \
pak/ground_obj.gemsen.pak \
pak/ground_obj.gooses.pak \
@@ -433,7 +471,6 @@ pak/menu.BarTools.pak \
pak/menu.DialogeTools.pak \
pak/menu.GeneralTools.pak \
pak/menu.SimpleTools.pak \
-pak/menu.WindowSkin.pak \
pak/misc.Construction.pak \
pak/misc.PowerDest.pak \
pak/misc.PowerSource.pak \
@@ -470,21 +507,27 @@ pak/smoke.Diesel.pak \
pak/smoke.Industry_Fire.pak \
pak/smoke.Industry_Smoke.pak \
pak/smoke.Steam.pak \
+pak/sound/Water.wav \
+pak/sound/arctic.wav \
pak/sound/boat-horn.wav \
pak/sound/boing.wav \
pak/sound/bus.wav \
pak/sound/cash.wav \
pak/sound/click.wav \
pak/sound/comet-jet.wav \
+pak/sound/crossing.wav \
+pak/sound/desert.wav \
pak/sound/diesel.wav \
pak/sound/dock.wav \
pak/sound/explosion.wav \
+pak/sound/forest.wav \
pak/sound/gavel.wav \
pak/sound/horse.wav \
pak/sound/jackhammer.wav \
pak/sound/planelow.wav \
pak/sound/sound.tab \
pak/sound/steam.wav \
+pak/sound/tropic.wav \
pak/sound/truck.wav \
pak/symbol.AirStop.pak \
pak/symbol.BigLogo.pak \
@@ -509,7 +552,6 @@ pak/symbol.TramStop.pak \
pak/symbol.Waren.pak \
pak/text/be.tab \
pak/text/ca.tab \
-pak/text/ce.tab \
pak/text/citylist_cz.txt \
pak/text/citylist_de.txt \
pak/text/citylist_de_at.txt \
@@ -541,10 +583,13 @@ pak/text/es.tab \
pak/text/et.tab \
pak/text/fi.tab \
pak/text/fr.tab \
+pak/text/gr.tab \
+pak/text/hr.tab \
pak/text/hu.tab \
pak/text/id.tab \
pak/text/it.tab \
pak/text/ja.tab \
+pak/text/lt.tab \
pak/text/nl.tab \
pak/text/no.tab \
pak/text/pl.tab \
@@ -679,6 +724,9 @@ pak/vehicle.Concept2Mail.pak \
pak/vehicle.Concept2Pass.pak \
pak/vehicle.Concept2Rear.pak \
pak/vehicle.Concorde.pak \
+pak/vehicle.Cooling_Container.pak \
+pak/vehicle.Cooling_Truck.pak \
+pak/vehicle.Cooling_Waggon.pak \
pak/vehicle.DC-3.pak \
pak/vehicle.DaimlerStoll.pak \
pak/vehicle.DoubleDecker.pak \
@@ -701,6 +749,8 @@ pak/vehicle.Erztransporter.pak \
pak/vehicle.Erzwagen.pak \
pak/vehicle.F7back.pak \
pak/vehicle.FastFerry.pak \
+pak/vehicle.Fishing_Boat.pak \
+pak/vehicle.Fishing_Boat_DanMacK.pak \
pak/vehicle.Flachwagen.pak \
pak/vehicle.Fokker_F27.pak \
pak/vehicle.FordZugmaschine.pak \
@@ -756,6 +806,8 @@ pak/vehicle.Mack_Truck_01.pak \
pak/vehicle.MailExpress.pak \
pak/vehicle.Mailcontainerwagon.pak \
pak/vehicle.Mailwagon.pak \
+pak/vehicle.Milk_Truck.pak \
+pak/vehicle.Milk_Waggon.pak \
pak/vehicle.Moebelschiff.pak \
pak/vehicle.Moebelwagen.pak \
pak/vehicle.NS1000.pak \
@@ -785,6 +837,8 @@ pak/vehicle.SD40-2-front.pak \
pak/vehicle.SMPoiltruck.pak \
pak/vehicle.Sandanhaenger.pak \
pak/vehicle.Sandtransporter.pak \
+pak/vehicle.Schooner_Bark.pak \
+pak/vehicle.Serj-Mini.pak \
pak/vehicle.SlowFerry.pak \
pak/vehicle.Stahlanhaenger.pak \
pak/vehicle.Stahltransporter.pak \
@@ -843,13 +897,15 @@ pak/way.elevated_monorail.pak \
pak/way.gavel_road.pak \
pak/way.mip_cobblestone_road.pak \
pak/way.monorail.pak \
+pak/way.river.pak \
+pak/way.river2.pak \
pak/way.runway_grass.pak \
pak/way.runway_modern.pak \
pak/way.sand_track.pak \
pak/way.steel_sleeper_track.pak \
pak/way.taxiway.pak \
pak/way.wooden_sleeper_track.pak \
-readme.txt \
+skin/menu.WindowSkin.pak \
text/be.tab \
text/ca.tab \
text/cn.tab \
@@ -925,6 +981,7 @@ text/de/roadtools.txt \
text/de/save.txt \
text/de/scenario.txt \
text/de/schedule.txt \
+text/de/settings.txt \
text/de/shiptools.txt \
text/de/simutrans.txt \
text/de/slopetools.txt \
@@ -933,6 +990,7 @@ text/de/special.txt \
text/de/station.txt \
text/de/station_details.txt \
text/de/tramtools.txt \
+text/de/underground.txt \
text/de/use.txt \
text/dk.tab \
text/dk/bridges.txt \
@@ -967,6 +1025,8 @@ text/dk/station.txt \
text/dk/vehicle.txt \
text/en.tab \
text/en/airtools.txt \
+text/en/baum_build.txt \
+text/en/citybuilding_build.txt \
text/en/citylist_filter.txt \
text/en/citywindow.txt \
text/en/climates.txt \
@@ -1091,6 +1151,8 @@ text/fr/schedule2.txt \
text/fr/shiptools.txt \
text/fr/sound.txt \
text/fr/station.txt \
+text/gr.tab \
+text/gr/airtools.txt \
text/hr.tab \
text/hu.tab \
text/hu/citylist_filter.txt \
@@ -1151,6 +1213,8 @@ text/it/shiptools.txt \
text/it/sound.txt \
text/it/station.txt \
text/ja.tab \
+text/ja/citylist_filter.txt \
+text/ja/citywindow.txt \
text/ja/color.txt \
text/ja/depot.txt \
text/ja/display.txt \
@@ -1159,6 +1223,7 @@ text/ja/general.txt \
text/ja/keys.txt \
text/ja/language.txt \
text/ja/load.txt \
+text/ja/mailbox.txt \
text/ja/map.txt \
text/ja/new_world.txt \
text/ja/options.txt \
@@ -1167,7 +1232,9 @@ text/ja/railtools.txt \
text/ja/roadtools.txt \
text/ja/save.txt \
text/ja/schedule.txt \
+text/ja/settings.txt \
text/ja/shiptools.txt \
+text/ja/slopetools.txt \
text/ja/sound.txt \
text/ja/station.txt \
text/ja/station_details.txt \
@@ -1215,6 +1282,8 @@ text/pl/sound.txt \
text/pl/station.txt \
text/pt.tab \
text/pt/airtools.txt \
+text/pt/baum_build.txt \
+text/pt/citybuilding_build.txt \
text/pt/citylist_filter.txt \
text/pt/citywindow.txt \
text/pt/climates.txt \
@@ -1261,6 +1330,7 @@ text/pt/special.txt \
text/pt/station.txt \
text/pt/station_details.txt \
text/pt/tramtools.txt \
+text/pt/window.txt \
text/readme_citylist.txt \
text/ro.tab \
text/ro/color.txt \
@@ -1313,5 +1383,16 @@ text/sk/shiptools.txt \
text/sk/sound.txt \
text/sk/station.txt \
text/sv.tab \
+text/sv/airtools.txt \
+text/sv/baum_build.txt \
+text/sv/citybuilding_build.txt \
+text/sv/depot.txt \
+text/sv/underground.txt \
+text/tr.tab \
+text/tr/airtools.txt \
text/zh.tab \
text/zh/keys.txt
+
+SIMUTRANS_DOCS= \
+licence.txt \
+readme.txt
diff --git a/games/simutrans/distinfo b/games/simutrans/distinfo
index 104d4b96a61e..7cf65bf6767c 100644
--- a/games/simutrans/distinfo
+++ b/games/simutrans/distinfo
@@ -1,9 +1,12 @@
-MD5 (simutrans-src-102-0.zip) = bbfcab46ff00d259c5983c08a717b3e4
-SHA256 (simutrans-src-102-0.zip) = a21f695e148f5d24415ab9e66ede1c3c723645e1a80a654ac3c91203707ceb59
-SIZE (simutrans-src-102-0.zip) = 2319247
-MD5 (simulinux-102-0.zip) = 9fdd5fd98bf4a3dcc9e82e711c9b4094
-SHA256 (simulinux-102-0.zip) = 8d1ead94caf7c1fd33a41192ac163bb99c8d2849ec2f41ca7c123aae1cbdce2f
-SIZE (simulinux-102-0.zip) = 2228009
-MD5 (pak64-102-0.zip) = 3c284a0f6f26990e2bd7da0e7f090221
-SHA256 (pak64-102-0.zip) = c61d95203422685f76a261a70e69b6d197d67b6486d591f1cc679314d0ee8a36
-SIZE (pak64-102-0.zip) = 3261762
+MD5 (simutrans-src-102-2-1.zip) = 77b40825b5b1327f93ee0fe63cca0f80
+SHA256 (simutrans-src-102-2-1.zip) = 1c11ef05e96d3e63e375f1d27e56816388de930b0104627df2c4b9755398ef51
+SIZE (simutrans-src-102-2-1.zip) = 2432920
+MD5 (simulinux-102-2-1.zip) = 03bb2d9caafc05f41ffb428c0ea6a9b2
+SHA256 (simulinux-102-2-1.zip) = 45893136229d21334e47b1dc9685020a0ff1ad579a278cdbfa7e6eadf527cfb2
+SIZE (simulinux-102-2-1.zip) = 2225723
+MD5 (simupak64-102-2-1.zip) = e981828d77b62924173ee3a1d0b93321
+SHA256 (simupak64-102-2-1.zip) = 7373fd04cac93a146c2087c6f8812493be034190702db15c26127656d4f3d735
+SIZE (simupak64-102-2-1.zip) = 3464702
+MD5 (simupak64-addon-food-102-2-1.zip) = 2d75cb31e2012154ef60f9e4633ddb8a
+SHA256 (simupak64-addon-food-102-2-1.zip) = 7add9c3e3dc3959c6a39776043a16beb92f6f59190fcae25b29e367c17e24607
+SIZE (simupak64-addon-food-102-2-1.zip) = 113454
diff --git a/games/simutrans/files/simutrans.desktop b/games/simutrans/files/simutrans.desktop
new file mode 100644
index 000000000000..f22a58256038
--- /dev/null
+++ b/games/simutrans/files/simutrans.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=Simutrans
+GenericName=Transportation Simulation Game
+Exec=simutrans
+Categories=Game;Simulation;
+StartupNotify=false
diff --git a/games/simutrans/pkg-descr b/games/simutrans/pkg-descr
index da69cfae28d8..0810f8e1b2bd 100644
--- a/games/simutrans/pkg-descr
+++ b/games/simutrans/pkg-descr
@@ -1,7 +1,10 @@
-Choose one, out of the many thousands, of Simutrans lands. Then, put
-yourself in the shoes of a young entrepeneur with some money from your
-grandparents: eager to make them proud, with ambitions of establishing
-a successful transport company, your challenge now is to build a
-prospering enterprise.
+Your goal is to establish a successful transport company. Transport
+passengers, mail and goods by rail, road, ship and air. Interconnect
+cities, districts, public buildings, industries and tourist attractions
+by buiding a transport network you always dreamed of.
-WWW: http://simutrans.sourceforge.net/
+Control and watch your finances and the traffic of your vehicles and
+goods. Start in 1880 and finish in 2050. There will be new vehicles and
+buildings throughout this time.
+
+WWW: http://www.simutrans.com/
diff --git a/games/simutrans/pkg-plist b/games/simutrans/pkg-plist
new file mode 100644
index 000000000000..cfdf0a0f7a4f
--- /dev/null
+++ b/games/simutrans/pkg-plist
@@ -0,0 +1,13 @@
+bin/simutrans
+bin/simutrans-bin
+share/applications/simutrans.desktop
+@exec mkdir -p %D/%%DATADIR%%/text/be
+@exec mkdir -p %D/%%DATADIR%%/text/ca
+@exec mkdir -p %D/%%DATADIR%%/text/cn
+@exec mkdir -p %D/%%DATADIR%%/text/et
+@exec mkdir -p %D/%%DATADIR%%/text/fi
+@exec mkdir -p %D/%%DATADIR%%/text/hr
+@exec mkdir -p %D/%%DATADIR%%/text/id
+@exec mkdir -p %D/%%DATADIR%%/text/lt
+@exec mkdir -p %D/%%DATADIR%%/text/no
+@dirrmtry share/applications