aboutsummaryrefslogtreecommitdiff
path: root/german
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
commit23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d (patch)
treefa03305e656151ebe33c7e94eacc947b13d1c273 /german
parentb347391f9ad81dd1ebc74b80d713888404b304bd (diff)
downloadports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.tar.gz
ports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.zip
Mega-patch to cleanup the ports infrastructure regarding our linux bits:
- USE_LINUX now implies NO_FILTER_SHLIBS=yes. It also doesn't use FreeBSD tools to strip binaries anymore, so it's not neccesary anymore to override STRIP and STRIP_CMD. - USE_LINUX_PREFIX implies NO_MTREE now. - In the USE_LINUX case, USE_XLIB now depends upon the linux X11 libraries instead upon the native FreeBSD libraries. - The variable LINUX_BASE_PORT contains a string which is suitable as an item in *_DEPENDS, so if a port BATCH_DEPENDS or FETCH_DEPENDS upon the default (or overriden) linux base, ${LINUX_BASE_PORT} should be used instead of a hardcoded reference. - Change all ports to comply to the "new world order". - The Ports Collection now allows to override the default linux_base port. Specify e.g. OVERRIDE_LINUX_BASE_PORT=rh-9 in /etc/make.conf to use ${PORTSDIR}/emulators/linux_base-rh-9 (the logic is to use ${PORTSDIR}/emulators/linux_base-${OVERRIDE_LINUX_BASE_PORT}). - If USE_LINUX or OVERRIDE_LINUX_BASE doesn't point to an existing linux_base port and if USE_LINUX isn't set to "yes" (case insensitive), the port will be marked as IGNORE. [1] - Readd USE_LINUX knobs into several ports and make several uses of a conditional dependency ("USE_LINUX?=") into an unconditional one ("USE_LINUX=") which where removed/changed by Trevor to allow the use of alternative linux_base ports. While this is a nice goal, the implementation resulted in missing dependencies. The OVERRIDE_LINUX_BASE_PORT knob in this commit is supposed to fix the problem while keeping the feature. Basicaly this includes a backout of Trevor's commit, to prevent confusion I mention it here explicitely. - Use the correct prefix (X11- instead of LOCAL- or LINUX-) for some ports. Chase dependencies for this. - Changes to make linux_devtools installable on amd64, remove some stray device nodes (they don't work on recent OS versions and aren't really needed). - Make linux_base-8 PREFIX clean and remove some stray device nodes. Additionally tell a little bit more about how to setup NIS/YP [2]. - Update the PGSQL dependency in the linux-opengroupware port to a recent version (the old one isn't available anymore), I don't know if this works (at least it isn't more broken than before). - Use PREFIX/usr/share/doc instead of PREFIX/usr/doc in the divx4linux ports, the former path exists already and gets populated by other packages too (PREFIX=LINUXPREFIX!). - Fix some obvious (non-linuxolator) bugs in some linux ports while being there. - Bump PORTREVISION where neccesary. Requested by: portmgr (linimon) [1] Submittted by: Gerrit Kuehn <gerrit_huehn@gruft.fido.de [2] Approved by: portmgr (kris, linimon), maintainers (or maintainer timeout) Tested on: ports cluster (kris) Reviewed by: silence on emulation@ Superseedes PR: 69997 Maintainer approval from: chris@chrisburkert.de cracauer@cons.org des girgen jamie@bishopston.net mezz mi nivit@users.sf.net pat simond@irrelevant.org riggs@rrr.de Udo.Schweigert@Siemens.com
Notes
Notes: svn path=/head/; revision=137660
Diffstat (limited to 'german')
-rw-r--r--german/citrix_ica/Makefile9
-rw-r--r--german/citrix_xenapp/Makefile9
-rw-r--r--german/staroffice5/Makefile6
-rw-r--r--german/staroffice52/Makefile8
-rw-r--r--german/staroffice70/Makefile7
5 files changed, 23 insertions, 16 deletions
diff --git a/german/citrix_ica/Makefile b/german/citrix_ica/Makefile
index bbad60918208..145787289d26 100644
--- a/german/citrix_ica/Makefile
+++ b/german/citrix_ica/Makefile
@@ -7,7 +7,7 @@
PORTNAME= citrix_ica
PORTVERSION= 6.30.1054
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= german net comms linux
MASTER_SITES=
DISTNAME= ${PORTNAME}-linuxx86-de
@@ -15,14 +15,14 @@ DISTNAME= ${PORTNAME}-linuxx86-de
MAINTAINER= mbr@FreeBSD.org
COMMENT= Citrix(R) client for the Microsoft Windows Terminal Server
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXaw.so.6:${PORTSDIR}/x11/linux-XFree86-libs
-
ONLY_FOR_ARCHS= i386
RESTRICTED= "License prohibits redistribution"
IS_INTERACTIVE= "Noisy license agreement ignores stdin"
NO_WRKSUBDIR= Yes
-NO_BUILD= Yes
+NO_BUILD= Yes
+USE_LINUX= Yes
+USE_X_PREFIX= Yes
CDIR= ${PREFIX}/ICAClient
BINDIR= ${PREFIX}/bin
@@ -85,5 +85,6 @@ do-install:
cd ${WRKSRC} && ${LINUXBASE}/bin/sh -c './setupwfc < response'
${INSTALL_SCRIPT} ${WRKSRC}/wfcmgr.x ${PREFIX}/bin/wfcmgr
${INSTALL_SCRIPT} ${WRKSRC}/wfica.x ${PREFIX}/bin/wfica
+# XXX: This is missing a "${BRANDELF} -t Linux <executables>".
.include <bsd.port.post.mk>
diff --git a/german/citrix_xenapp/Makefile b/german/citrix_xenapp/Makefile
index bbad60918208..145787289d26 100644
--- a/german/citrix_xenapp/Makefile
+++ b/german/citrix_xenapp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= citrix_ica
PORTVERSION= 6.30.1054
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= german net comms linux
MASTER_SITES=
DISTNAME= ${PORTNAME}-linuxx86-de
@@ -15,14 +15,14 @@ DISTNAME= ${PORTNAME}-linuxx86-de
MAINTAINER= mbr@FreeBSD.org
COMMENT= Citrix(R) client for the Microsoft Windows Terminal Server
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXaw.so.6:${PORTSDIR}/x11/linux-XFree86-libs
-
ONLY_FOR_ARCHS= i386
RESTRICTED= "License prohibits redistribution"
IS_INTERACTIVE= "Noisy license agreement ignores stdin"
NO_WRKSUBDIR= Yes
-NO_BUILD= Yes
+NO_BUILD= Yes
+USE_LINUX= Yes
+USE_X_PREFIX= Yes
CDIR= ${PREFIX}/ICAClient
BINDIR= ${PREFIX}/bin
@@ -85,5 +85,6 @@ do-install:
cd ${WRKSRC} && ${LINUXBASE}/bin/sh -c './setupwfc < response'
${INSTALL_SCRIPT} ${WRKSRC}/wfcmgr.x ${PREFIX}/bin/wfcmgr
${INSTALL_SCRIPT} ${WRKSRC}/wfica.x ${PREFIX}/bin/wfica
+# XXX: This is missing a "${BRANDELF} -t Linux <executables>".
.include <bsd.port.post.mk>
diff --git a/german/staroffice5/Makefile b/german/staroffice5/Makefile
index 0acf731749fa..3dd4737b1ecd 100644
--- a/german/staroffice5/Makefile
+++ b/german/staroffice5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= staroffice
PORTVERSION= 5.1a
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= german editors linux
MASTER_SITES= ftp://ftp.hagenhomes.com/pub/ \
ftp://ftp.stat.duke.edu/pub/Users/sto/StarOffice51a/ \
@@ -21,10 +21,11 @@ MAINTAINER= mb@imp.ch
COMMENT= Integrated wordprocessor/dbase/spreadheet/drawing/chart/browser
BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
NO_LATEST_LINK= yes
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_X_PREFIX= yes
NO_CDROM= 'Sie muessen StarOffice manuell via WWW-Interface herunterladen.'
IS_INTERACTIVE= yes
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -98,6 +99,7 @@ post-install:
@${CHMOD} 100755 ${PREFIX}/Office51/lib/libsdb517li.so
@${PERL} -pi -e 's|DefaultDestPath = "${PREFIX}/Office51";|DefaultDestPath = "~/Office51";|' ${PREFIX}/Office51/instdb.ins
@${INSTALL_DATA} ${FILESDIR}/dot.sversionrc /root/.sversionrc
+# XXX: This is missing a "${BRANDELF} -t Linux <executables>".
install-user:
${PREFIX}/Office51/bin/setup
diff --git a/german/staroffice52/Makefile b/german/staroffice52/Makefile
index 8695f32ca341..733b7740ee31 100644
--- a/german/staroffice52/Makefile
+++ b/german/staroffice52/Makefile
@@ -7,7 +7,7 @@
PORTNAME= staroffice
PORTVERSION= 5.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= german editors linux
MASTER_SITES= ftp://ftp.hu-berlin.de/pub/linux/staroffice/german/ \
ftp://sunsite.cnlab-switch.ch/mirror/staroffice/deutsch/ \
@@ -30,11 +30,12 @@ EXTRACT_ONLY= 109939-03.tar.Z
MAINTAINER= mbr@FreeBSD.org
COMMENT= Integrated wordprocessor/dbase/spreadheet/drawing/chart/browser
-FETCH_DEPENDS= ${LINUXBASE}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base-8
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
+FETCH_DEPENDS= ${LINUX_BASE_PORT}
NO_LATEST_LINK= yes
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_X_PREFIX= yes
NO_CDROM= 'Sie muessen StarOffice manuell via WWW-Interface herunterladen.'
CD_MOUNTPT= '/cdrom'
IS_INTERACTIVE= yes
@@ -192,5 +193,6 @@ post-install:
install-user:
@-SAL_IGNOREXERRORS=1 PATH="/bin:${PATH}" ${LINUXBASE}/bin/sh -c \
${PREFIX}/office52/program/setup
+# XXX: This is missing a "${BRANDELF} -t Linux <executables>".
.include <bsd.port.post.mk>
diff --git a/german/staroffice70/Makefile b/german/staroffice70/Makefile
index f450b48ce3be..79aaa6d698f4 100644
--- a/german/staroffice70/Makefile
+++ b/german/staroffice70/Makefile
@@ -7,7 +7,7 @@
PORTNAME= staroffice
PORTVERSION= 7.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= german editors linux
MASTER_SITES= ftp://patches.sun.com/patchroot/all_unsigned/:patch \
ftp://ftp.sun.co.uk/pub/patches/:patch \
@@ -30,13 +30,13 @@ EXTRACT_ONLY= 116518-06.tar
MAINTAINER= mbr@FreeBSD.org
COMMENT= Wordprocessor/dbase/spreadheet/drawing/chart
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
-
ONLY_FOR_ARCHS= i386
NO_CDROM= 'Must be bought and downloaded direct from Sun via www interface'
IS_INTERACTIVE= yes
NO_BUILD= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
SOVERSION= ${PORTNAME}${PORTVERSION}
WRKSRC= ${WRKDIR}/${SOVERSION}
TMPDIR= ${WRKDIR}/tmp
@@ -246,6 +246,7 @@ post-install:
@${ECHO} StarOffice7.0 has been installed successfully. In order to use
@${ECHO} it, execute ${PREFIX}/bin/staroffice7.
@${ECHO}
+# XXX: This is missing a "${BRANDELF} -t Linux <executables>".
install-patch:
@${CP} ${FILESDIR}/patchsetup.resp ${WRKSRC}