aboutsummaryrefslogtreecommitdiff
path: root/graphics/GraphicsMagick13/Makefile
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2008-11-20 22:41:04 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2008-11-20 22:41:04 +0000
commit1ccec4d15186f880a334c3a37453c675a87b0110 (patch)
tree64f058e34726e59ce62a075e9f25e7bda71ea4cc /graphics/GraphicsMagick13/Makefile
parente2c8bdc47276e21257917faaa535e43f1a00d859 (diff)
downloadports-1ccec4d15186f880a334c3a37453c675a87b0110.tar.gz
ports-1ccec4d15186f880a334c3a37453c675a87b0110.zip
- Initial release of version 1.3.1
- Turned on OpenMP by default
Notes
Notes: svn path=/head/; revision=223096
Diffstat (limited to 'graphics/GraphicsMagick13/Makefile')
-rw-r--r--graphics/GraphicsMagick13/Makefile71
1 files changed, 47 insertions, 24 deletions
diff --git a/graphics/GraphicsMagick13/Makefile b/graphics/GraphicsMagick13/Makefile
index 5223e57e3d4c..e62a7fdabd5f 100644
--- a/graphics/GraphicsMagick13/Makefile
+++ b/graphics/GraphicsMagick13/Makefile
@@ -6,27 +6,29 @@
#
PORTNAME= GraphicsMagick
-PORTVERSION= 1.2.5
+PORTVERSION= 1.3.1
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+MASTER_SITES= SF \
ftp://ftp.graphicsmagick.org/pub/GraphicsMagick/
MASTER_SITE_SUBDIR= ${PORTNAME:L}
MAINTAINER= glarkin@FreeBSD.org
COMMENT= Fast image processing tools based on ImageMagick
-CONFLICTS= GraphicsMagick-1.1.*
+CONFLICTS= GraphicsMagick-1.[12].*
LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
- fpx.[2-9]:${PORTSDIR}/graphics/libfpx \
jbig:${PORTSDIR}/graphics/jbigkit \
wmflite:${PORTSDIR}/graphics/libwmf \
xml2:${PORTSDIR}/textproc/libxml2 \
ltdl:${PORTSDIR}/devel/libltdl15
OTHERGRAPHICS= jasper jpeg lcms png tiff
LIB_DEPENDS+= ${OTHERGRAPHICS:C|(.+)|\1:${PORTSDIR}/graphics/\1|}
+
OPTIONS= Q8BIT "Use 8-bit pixels (speed) instead of 16 (quality)" off \
- OPENMP "Enable OpenMP support (requires GCC 4.2+)" off \
+ FPX "Enable FlashPIX support" on \
+ DPS "Enable Display Ghostscript support" on \
+ OPENMP "Enable OpenMP support" on \
SSE "Enable SSE opcodes on supported CPUs" off \
TESTS "Run bundled self-tests after build" on
@@ -35,7 +37,7 @@ USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GHOSTSCRIPT=yes
GNU_CONFIGURE= yes
-LATEST_LINK= GraphicsMagick12
+LATEST_LINK= GraphicsMagick13
MAN1= GraphicsMagick++-config.1 \
GraphicsMagick-config.1 \
@@ -44,6 +46,27 @@ MAN1= GraphicsMagick++-config.1 \
MAN4= miff.4
MAN5= quantize.5
+CONFIGURE_ARGS= --without-perl --enable-shared --enable-static \
+ --with-ltdl-include=${LOCALBASE}/include \
+ --with-ltdl-lib=${LOCALBASE}/lib
+USE_LDCONFIG= yes
+
+ALL_TARGET= -j`${SYSCTL} -n hw.ncpu`
+
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+test check:
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
+
+.include <bsd.port.pre.mk>
+
+.if defined(NOPORTDOCS)
+# Get rid of the Makefile targets that install the documentation
+# and HTML files into DOCSDIR
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-Makefile.in
+.endif
+
.if defined(WITH_SSE)
.if ${MACHINE_CPU:Msse}
CFLAGS+= -msse
@@ -56,14 +79,29 @@ CFLAGS+= -msse3
.endif
.endif
+.if defined(WITH_FPX)
+LIB_DEPENDS+= fpx.[2-9]:${PORTSDIR}/graphics/libfpx
+CONFIGURE_ARGS+= --with-fpx
+.else
+CONFIGURE_ARGS+= --without-fpx
+.endif
+
+.if defined(WITH_DPS)
+LIB_DEPENDS+= dps:${PORTSDIR}/x11/dgs
+CONFIGURE_ARGS+= --with-dps
+.else
+CONFIGURE_ARGS+= --without-dps
+.endif
+
.if defined(WITH_OPENMP)
-# Later versions of FreeBSD 7.0 already have GCC 4.2
.if ${OSVERSION} < 700042
-USE_GCC= 4.2+
+IGNORE= does not support OpenMP on FreeBSD version ${OSVERSION}
.endif
CONFIGURE_ENV+= LDFLAGS=${PTHREAD_LIBS}
-CONFIGURE_ARGS+= --enable-openmp
+CONFIGURE_ARGS+= --with-threads --enable-openmp --disable-openmp-slow
+.else
+CONFIGURE_ARGS+= --without-threads --disable-openmp
.endif
.ifndef WINDOWS_FONT_DIR
@@ -71,21 +109,6 @@ CONFIGURE_ARGS+= --enable-openmp
WINDOWS_FONT_DIR=${LOCALBASE}/lib/X11/fonts/webfonts
.endif
-CONFIGURE_ARGS= --without-perl --enable-shared --enable-static \
- --without-threads --with-ltdl-include=${LOCALBASE}/include \
- --with-ltdl-lib=${LOCALBASE}/lib
-USE_LDCONFIG= yes
-
-ALL_TARGET= -j`${SYSCTL} -n hw.ncpu`
-
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-
-test check:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
-
-.include <bsd.port.pre.mk>
-
.if defined(WITH_WINDOWS_FONT_DIR)
CONFIGURE_ARGS+= --with-windows-font-dir="${WINDOWS_FONT_DIR}"
.endif