aboutsummaryrefslogtreecommitdiff
path: root/graphics/GraphicsMagick
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2005-07-27 02:09:05 +0000
committerMikhail Teterin <mi@FreeBSD.org>2005-07-27 02:09:05 +0000
commitb3c0bec1c71db1adee030f241441075598894498 (patch)
tree141f31668e8b6d897019c066374d4dd9e97ecfd7 /graphics/GraphicsMagick
parent4efba361e649a33052f3704a63a93b5d12dfbc0a (diff)
downloadports-b3c0bec1c71db1adee030f241441075598894498.tar.gz
ports-b3c0bec1c71db1adee030f241441075598894498.zip
A fork of a better-known ImageMagick emphasizing user convenience
and API stability. The port does not build nor install the Perl and Tcl APIs -- these will be added by separate ports. PR: ports/83932 Submitted by: Ron van Daal (maintainer to be)
Notes
Notes: svn path=/head/; revision=140203
Diffstat (limited to 'graphics/GraphicsMagick')
-rw-r--r--graphics/GraphicsMagick/.Makefile.swpbin0 -> 12288 bytes
-rw-r--r--graphics/GraphicsMagick/Makefile83
-rw-r--r--graphics/GraphicsMagick/distinfo2
-rw-r--r--graphics/GraphicsMagick/files/patch-Makefile.in117
-rw-r--r--graphics/GraphicsMagick/files/patch-freebsd70
-rw-r--r--graphics/GraphicsMagick/files/patch-utility21
-rw-r--r--graphics/GraphicsMagick/files/patch-warnings25
-rw-r--r--graphics/GraphicsMagick/pkg-descr13
-rw-r--r--graphics/GraphicsMagick/pkg-plist246
9 files changed, 577 insertions, 0 deletions
diff --git a/graphics/GraphicsMagick/.Makefile.swp b/graphics/GraphicsMagick/.Makefile.swp
new file mode 100644
index 000000000000..93dfd306c5bc
--- /dev/null
+++ b/graphics/GraphicsMagick/.Makefile.swp
Binary files differ
diff --git a/graphics/GraphicsMagick/Makefile b/graphics/GraphicsMagick/Makefile
new file mode 100644
index 000000000000..84ab6e28a0c4
--- /dev/null
+++ b/graphics/GraphicsMagick/Makefile
@@ -0,0 +1,83 @@
+# New ports collection makefile for: GraphicsMagick
+# Date created: 25 july 2005
+# Whom: Ron van Daal
+#
+# $FreeBSD$
+#
+
+PORTNAME= GraphicsMagick
+PORTVERSION= 1.1.6
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ ftp://ftp.graphicsmagick.org/pub/GraphicsMagick/
+MASTER_SITE_SUBDIR= ${PORTNAME:L}
+
+MAINTAINER= ronvdaal@n1x.nl
+COMMENT= Fast image processing tools based on ImageMagick
+
+LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
+ jbig:${PORTSDIR}/graphics/jbigkit \
+ wmf:${PORTSDIR}/graphics/libwmf \
+ xml2:${PORTSDIR}/textproc/libxml2
+OTHERGRAPHICS= jasper jpeg lcms png tiff
+LIB_DEPENDS+= ${OTHERGRAPHICS:C|(.+)|\1:${PORTSDIR}/graphics/\1|}
+OPTIONS= Q8BIT "Use 8-bit pixels (speed) instead of 16 (quality)" off
+
+# Use libfpx only on i386. On other systems it does not seem to work :-(
+OPTIONS+= FPX "Build FPX backend -- broken on non-i386 systems" \
+ ${ARCH:S,i386,on,:C,^[^o].*,off,}
+
+USE_BZIP2= yes
+USE_LIBTOOL_VER=15
+
+MAN1= GraphicsMagick++-config.1 \
+ GraphicsMagick-config.1 \
+ GraphicsMagickWand-config.1 \
+ gm.1
+MAN4= miff.4
+MAN5= quantize.5
+
+.ifndef WINDOWS_FONT_DIR
+# Use fonts installed by x11-fonts/webfonts by default
+WINDOWS_FONT_DIR=${X11BASE}/lib/X11/webfonts
+.endif
+
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --without-perl --with-windows-font-dir=${WINDOWS_FONT_DIR} \
+ --enable-shared --enable-static --without-threads
+INSTALLS_SHLIB= yes
+
+.if !defined(NOPORTDOCS)
+INSTALL_TARGET= install install-data-html
+.endif
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.pre.mk>
+
+# Perl and Tcl APIs will be installed by separate ports
+PLIST_SUB+= WITH_PERL="@comment "
+
+.if defined(WITHOUT_X11)
+PKGNAMESUFFIX+= -nox11
+CONFIGURE_ARGS+=--without-x
+.endif
+
+.if defined(WITH_FPX)
+LIB_DEPENDS+= fpx:${PORTSDIR}/graphics/libfpx
+.else
+CONFIGURE_ARGS+=--without-fpx
+.endif
+
+.if defined(WITH_Q8BIT) || defined(WITHOUT_GRAPHICSMAGICK_16BIT_PIXEL)
+CONFIGURE_ARGS+= --with-quantum-depth=8
+PLIST_SUB+= Q=8
+.else
+CONFIGURE_ARGS+= --with-quantum-depth=16
+PLIST_SUB+= Q=16
+.endif
+
+post-build test:
+ cd ${WRKSRC}/tests && ${MAKE} check
+
+.include <bsd.port.post.mk>
diff --git a/graphics/GraphicsMagick/distinfo b/graphics/GraphicsMagick/distinfo
new file mode 100644
index 000000000000..5ca71f1b9fe6
--- /dev/null
+++ b/graphics/GraphicsMagick/distinfo
@@ -0,0 +1,2 @@
+MD5 (GraphicsMagick-1.1.6.tar.bz2) = ee85aef3cde13432a3f2e5604b758f9c
+SIZE (GraphicsMagick-1.1.6.tar.bz2) = 4959704
diff --git a/graphics/GraphicsMagick/files/patch-Makefile.in b/graphics/GraphicsMagick/files/patch-Makefile.in
new file mode 100644
index 000000000000..356c937c6998
--- /dev/null
+++ b/graphics/GraphicsMagick/files/patch-Makefile.in
@@ -0,0 +1,117 @@
+--- Makefile.in Fri Mar 18 19:36:21 2005
++++ Makefile.in Sun Jul 24 18:21:35 2005
+@@ -100,5 +100,5 @@
+
+ # Architecture independent data files installed in the package's data directory
+-pkgdatadir = @MagickSharePath@
++pkgdatadir = ${DATA_DIR}/GraphicsMagick
+ ACLOCAL = @ACLOCAL@
+ AMDEP_FALSE = @AMDEP_FALSE@
+@@ -301,6 +301,6 @@
+ MagickLibConfigPath = @MagickLibConfigPath@
+ MagickLibPath = @MagickLibPath@
+-MagickShareConfigPath = @MagickShareConfigPath@
+-MagickSharePath = @MagickSharePath@
++MagickShareConfigPath = ${DATADIR}/share/GraphicsMagick/config
++MagickSharePath = ${DATADIR}/share/GraphicsMagick
+ MogrifyDelegate = @MogrifyDelegate@
+ NM = @NM@
+@@ -466,5 +466,5 @@
+
+ # Install HTML files
+-pkgdocdir = @MagickSharePath@
++pkgdocdir = ${DATA_DIR}/doc/GraphicsMagick
+ DOCDIRS = images www www/api www/Magick++
+ @WITH_PERL_TRUE@PERLMAGICK = PerlMagick
+@@ -1079,5 +1079,5 @@
+
+ # Install arch-independent package data
+-install-data-local: install-data-html
++install-data-local:
+
+ # Uninstall arch-independent package data
+--- coders/Makefile.in Fri Mar 18 19:36:16 2005
++++ coders/Makefile.in Sun Jul 24 19:22:21 2005
+@@ -1479,5 +1479,5 @@
+ install-pkgLTLIBRARIES: $(pkg_LTLIBRARIES)
+ @$(NORMAL_INSTALL)
+- test -z "$(pkgdir)" || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
++ test -z "$(pkgdir)" -o -z "$(pkg_LTLIBRARIES)" || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
+ @list='$(pkg_LTLIBRARIES)'; for p in $$list; do \
+ if test -f $$p; then \
+@@ -1825,5 +1825,5 @@
+ install-pkgDATA: $(pkg_DATA)
+ @$(NORMAL_INSTALL)
+- test -z "$(pkgdir)" || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
++ test -z "$(pkgdir)" -o -z '$(pkg_DATA)' || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
+ @list='$(pkg_DATA)'; for p in $$list; do \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+@@ -1842,5 +1842,5 @@
+ install-pkgdataDATA: $(pkgdata_DATA)
+ @$(NORMAL_INSTALL)
+- test -z "$(pkgdatadir)" || $(mkdir_p) "$(DESTDIR)$(pkgdatadir)"
++ test -z "$(pkgdatadir)" -o -z '$(pkgdata_DATA)' || $(mkdir_p) "$(DESTDIR)$(pkgdatadir)"
+ @list='$(pkgdata_DATA)'; for p in $$list; do \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+--- filters/Makefile.in Fri Mar 18 19:36:17 2005
++++ filters/Makefile.in Sun Jul 24 19:23:33 2005
+@@ -522,5 +522,5 @@
+ install-pkgLTLIBRARIES: $(pkg_LTLIBRARIES)
+ @$(NORMAL_INSTALL)
+- test -z "$(pkgdir)" || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
++ test -z "$(pkgdir)" -o -z '$(pkg_LTLIBRARIES)' || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
+ @list='$(pkg_LTLIBRARIES)'; for p in $$list; do \
+ if test -f $$p; then \
+@@ -592,5 +592,5 @@
+ install-pkgDATA: $(pkg_DATA)
+ @$(NORMAL_INSTALL)
+- test -z "$(pkgdir)" || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
++ test -z "$(pkgdir)" -o -z '$(pkg_DATA)' || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
+ @list='$(pkg_DATA)'; for p in $$list; do \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+--- config/Makefile.in Fri Mar 18 19:36:16 2005
++++ config/Makefile.in Sun Jul 24 19:25:34 2005
+@@ -274,7 +274,7 @@
+ MagickCoderModulesPath = @MagickCoderModulesPath@
+ MagickFilterModulesPath = @MagickFilterModulesPath@
+-MagickLibConfigPath = @MagickLibConfigPath@
++MagickLibConfigPath = ${DATA_DIR}/GraphicsMagick/config
+ MagickLibPath = @MagickLibPath@
+-MagickShareConfigPath = @MagickShareConfigPath@
++MagickShareConfigPath = ${MagickLibConfigPath}
+ MagickSharePath = @MagickSharePath@
+ MogrifyDelegate = @MogrifyDelegate@
+--- magick/Makefile.in Fri Mar 18 19:36:18 2005
++++ magick/Makefile.in Tue Jul 26 21:05:48 2005
+@@ -664,5 +664,5 @@
+
+ # Pkgconfig directory
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+
+ # Files to install in Pkgconfig directory
+@@ -930,5 +930,5 @@
+ install-pkgDATA: $(pkg_DATA)
+ @$(NORMAL_INSTALL)
+- test -z "$(pkgdir)" || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
++ test -z "$(pkgdir)" -o -z '$(pkg_DATA)' || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
+ @list='$(pkg_DATA)'; for p in $$list; do \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+--- Magick++/lib/Makefile.in Fri Mar 18 19:36:13 2005
++++ Magick++/lib/Makefile.in Tue Jul 26 21:37:39 2005
+@@ -453,5 +453,5 @@
+
+ # Pkgconfig directory
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+
+ # Files to install in Pkgconfig directory
+--- wand/Makefile.in Fri Mar 18 19:36:20 2005
++++ wand/Makefile.in Tue Jul 26 21:38:43 2005
+@@ -478,5 +478,5 @@
+
+ # Pkgconfig directory
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+
+ # Files to install in Pkgconfig directory
diff --git a/graphics/GraphicsMagick/files/patch-freebsd b/graphics/GraphicsMagick/files/patch-freebsd
new file mode 100644
index 000000000000..4f5c664fbbd5
--- /dev/null
+++ b/graphics/GraphicsMagick/files/patch-freebsd
@@ -0,0 +1,70 @@
+Index: magick/command.c
+===================================================================
+RCS file: /GraphicsMagick/GraphicsMagick/magick/command.c,v
+retrieving revision 1.147.2.8
+retrieving revision 1.147.2.9
+diff -u -r1.147.2.8 -r1.147.2.9
+--- magick/command.c 28 Apr 2005 22:57:28 -0000 1.147.2.8
++++ magick/command.c 16 Jul 2005 01:42:22 -0000 1.147.2.9
+@@ -6525,7 +6525,7 @@
+ }
+ if (resource_database != (XrmDatabase) NULL)
+ {
+- XrmDestroyDatabase(resource_database);
++ /* XrmDestroyDatabase(resource_database); */
+ resource_database=(XrmDatabase) NULL;
+ }
+
+Index: magick/image.c
+===================================================================
+RCS file: /GraphicsMagick/GraphicsMagick/magick/image.c,v
+retrieving revision 1.1207.2.5
+retrieving revision 1.1207.2.6
+diff -u -r1.1207.2.5 -r1.1207.2.6
+--- magick/image.c 1 May 2005 18:43:29 -0000 1.1207.2.5
++++ magick/image.c 16 Jul 2005 01:42:23 -0000 1.1207.2.6
+@@ -2527,7 +2527,7 @@
+ }
+ if (resource_database != (XrmDatabase) NULL)
+ {
+- XrmDestroyDatabase(resource_database);
++ /* XrmDestroyDatabase(resource_database); */
+ resource_database=(XrmDatabase) NULL;
+ }
+ XDestroyResourceInfo(&resource_info);
+Index: magick/nt_base.c
+===================================================================
+RCS file: /GraphicsMagick/GraphicsMagick/magick/nt_base.c,v
+retrieving revision 1.35.2.6
+retrieving revision 1.35.2.7
+diff -u -r1.35.2.6 -r1.35.2.7
+--- magick/nt_base.c 20 Mar 2005 01:39:13 -0000 1.35.2.6
++++ magick/nt_base.c 19 Jun 2005 00:13:29 -0000 1.35.2.7
+@@ -2027,8 +2027,8 @@
+ }
+ entry->firsttime=FALSE;
+ (void) strncpy(entry->file_info.d_name,entry->Win32FindData.cFileName,
+- MaxTextExtent-1);
+- entry->file_info.d_name[MaxTextExtent-1]='\0';
++ sizeof(entry->file_info.d_name)-1);
++ entry->file_info.d_name[sizeof(entry->file_info.d_name)-1]='\0';
+ entry->file_info.d_namlen=strlen(entry->file_info.d_name);
+ return(&entry->file_info);
+ }
+Index: magick/version.h
+===================================================================
+RCS file: /GraphicsMagick/GraphicsMagick/magick/version.h,v
+retrieving revision 1.142.2.43
+retrieving revision 1.142.2.46
+diff -u -r1.142.2.43 -r1.142.2.46
+--- magick/version.h 1 May 2005 20:09:53 -0000 1.142.2.43
++++ magick/version.h 16 Jul 2005 01:42:24 -0000 1.142.2.46
+@@ -38,7 +38,7 @@
+ #define MagickLibVersion 0x010006
+ #define MagickLibVersionText "1.1.6"
+ #define MagickLibVersionNumber 1,0,6
+-#define MagickChangeDate "20050501"
++#define MagickChangeDate "20050715"
+ #define MagickReleaseDate "2005-05-01"
+
+
diff --git a/graphics/GraphicsMagick/files/patch-utility b/graphics/GraphicsMagick/files/patch-utility
new file mode 100644
index 000000000000..6dd5fb61c3d3
--- /dev/null
+++ b/graphics/GraphicsMagick/files/patch-utility
@@ -0,0 +1,21 @@
+--- magick/utility.c Sat Apr 2 17:35:06 2005
++++ magick/utility.c Sun Jul 24 18:22:40 2005
+@@ -47,4 +47,8 @@
+ #include "magick/utility.h"
+
++#if defined(POSIX)
++# include <sys/types.h>
++# include <sys/wait.h>
++#endif
+
+ /*
+@@ -3874,4 +3878,9 @@
+ #if defined(POSIX)
+ status=system(command);
++ if (status == -1)
++ perror(command);
++ else if (WIFSIGNALED(status)) {
++ fprintf(stderr, "Command ``\n%s\n'' terminated due to signal %d\n", command, WTERMSIG(status));
++ }
+ #elif defined(vms)
+ status=!system(command);
diff --git a/graphics/GraphicsMagick/files/patch-warnings b/graphics/GraphicsMagick/files/patch-warnings
new file mode 100644
index 000000000000..f317adbf1116
--- /dev/null
+++ b/graphics/GraphicsMagick/files/patch-warnings
@@ -0,0 +1,25 @@
+--- magick/blob.c Wed Apr 14 18:45:16 2004
++++ magick/blob.c Sun Jul 24 12:30:20 2005
+@@ -2364,5 +2364,5 @@
+ (void) rewind(image->blob->file);
+ (void) LogMagickEvent(BlobEvent,GetMagickModule(),
+- " read %d magic header bytes", count);
++ " read %td magic header bytes", count);
+ #if defined(HasZLIB)
+ if ((magick[0] == 0x1F) && (magick[1] == 0x8B) &&
+--- coders/ept.c Wed Apr 14 18:45:28 2004
++++ coders/ept.c Sun Jul 24 13:33:39 2005
+@@ -584,5 +584,5 @@
+ if (logging)
+ (void) LogMagickEvent(CoderEvent,GetMagickModule(),
+- "Writing EPS section at offset %lld",TellBlob(image));
++ "Writing EPS section at offset %lld", (long long)TellBlob(image));
+ for (c=fgetc(ps_file); c != EOF; c=fgetc(ps_file))
+ (void) WriteBlobByte(image,c);
+@@ -590,5 +590,5 @@
+ if (logging)
+ (void) LogMagickEvent(CoderEvent,GetMagickModule(),
+- "Writing TIFF section at offset %lld",TellBlob(image));
++ "Writing TIFF section at offset %lld", (long long)TellBlob(image));
+ for (c=fgetc(tiff_file); c != EOF; c=fgetc(tiff_file))
+ (void) WriteBlobByte(image,c);
diff --git a/graphics/GraphicsMagick/pkg-descr b/graphics/GraphicsMagick/pkg-descr
new file mode 100644
index 000000000000..e43f63a5ad60
--- /dev/null
+++ b/graphics/GraphicsMagick/pkg-descr
@@ -0,0 +1,13 @@
+This is a port of GraphicsMagick(TM), the "swiss army knife" of image
+processing. It provides a robust collection of tools and libraries which
+support reading, writing, and manipulating an image in over 88 major
+formats including formats like DPX, GIF, JPEG, JPEG-2000, PNG, PDF, SVG
+and TIFF.
+
+The program is the fork of a better-known ImageMagick (5.5.2), which
+emphasizes end-user and API-stabilities.
+
+WWW: http://www.graphicsmagick.org/
+
+- Ron van Daal
+ronvdaal@n1x.nl
diff --git a/graphics/GraphicsMagick/pkg-plist b/graphics/GraphicsMagick/pkg-plist
new file mode 100644
index 000000000000..2735ee22788f
--- /dev/null
+++ b/graphics/GraphicsMagick/pkg-plist
@@ -0,0 +1,246 @@
+bin/GraphicsMagick++-config
+bin/GraphicsMagick-config
+bin/GraphicsMagickWand-config
+bin/gm
+include/GraphicsMagick/Magick++.h
+include/GraphicsMagick/Magick++/Blob.h
+include/GraphicsMagick/Magick++/CoderInfo.h
+include/GraphicsMagick/Magick++/Color.h
+include/GraphicsMagick/Magick++/Drawable.h
+include/GraphicsMagick/Magick++/Exception.h
+include/GraphicsMagick/Magick++/Geometry.h
+include/GraphicsMagick/Magick++/Image.h
+include/GraphicsMagick/Magick++/Include.h
+include/GraphicsMagick/Magick++/Montage.h
+include/GraphicsMagick/Magick++/Pixels.h
+include/GraphicsMagick/Magick++/STL.h
+include/GraphicsMagick/Magick++/TypeMetric.h
+include/GraphicsMagick/magick/PreRvIcccm.h
+include/GraphicsMagick/magick/api.h
+include/GraphicsMagick/magick/attribute.h
+include/GraphicsMagick/magick/blob.h
+include/GraphicsMagick/magick/cache.h
+include/GraphicsMagick/magick/cache_view.h
+include/GraphicsMagick/magick/color.h
+include/GraphicsMagick/magick/command.h
+include/GraphicsMagick/magick/composite.h
+include/GraphicsMagick/magick/compress.h
+include/GraphicsMagick/magick/constitute.h
+include/GraphicsMagick/magick/decorate.h
+include/GraphicsMagick/magick/delegate.h
+include/GraphicsMagick/magick/deprecate.h
+include/GraphicsMagick/magick/draw.h
+include/GraphicsMagick/magick/effect.h
+include/GraphicsMagick/magick/enhance.h
+include/GraphicsMagick/magick/error.h
+include/GraphicsMagick/magick/fx.h
+include/GraphicsMagick/magick/gem.h
+include/GraphicsMagick/magick/image.h
+include/GraphicsMagick/magick/list.h
+include/GraphicsMagick/magick/log.h
+include/GraphicsMagick/magick/magic.h
+include/GraphicsMagick/magick/magick.h
+include/GraphicsMagick/magick/magick_config.h
+include/GraphicsMagick/magick/magick_types.h
+include/GraphicsMagick/magick/module.h
+include/GraphicsMagick/magick/monitor.h
+include/GraphicsMagick/magick/montage.h
+include/GraphicsMagick/magick/paint.h
+include/GraphicsMagick/magick/profile.h
+include/GraphicsMagick/magick/quantize.h
+include/GraphicsMagick/magick/registry.h
+include/GraphicsMagick/magick/render.h
+include/GraphicsMagick/magick/resize.h
+include/GraphicsMagick/magick/resource.h
+include/GraphicsMagick/magick/shear.h
+include/GraphicsMagick/magick/signature.h
+include/GraphicsMagick/magick/stream.h
+include/GraphicsMagick/magick/symbols.h
+include/GraphicsMagick/magick/timer.h
+include/GraphicsMagick/magick/transform.h
+include/GraphicsMagick/magick/utility.h
+include/GraphicsMagick/magick/version.h
+include/GraphicsMagick/magick/widget.h
+include/GraphicsMagick/magick/xwindow.h
+include/GraphicsMagick/wand/drawing_wand.h
+include/GraphicsMagick/wand/magick_wand.h
+include/GraphicsMagick/wand/pixel_wand.h
+include/GraphicsMagick/wand/wand_api.h
+%%DATADIR%%/Copyright.txt
+%%DATADIR%%/config/colors.mgk
+%%DATADIR%%/config/delegates.mgk
+%%DATADIR%%/config/log.mgk
+%%DATADIR%%/config/magic.mgk
+%%DATADIR%%/config/modules.mgk
+%%DATADIR%%/config/type-ghostscript.mgk
+%%DATADIR%%/config/type-solaris.mgk
+%%DATADIR%%/config/type-windows.mgk
+%%DATADIR%%/config/type.mgk
+lib/libGraphicsMagick++.a
+lib/libGraphicsMagick++.so
+lib/libGraphicsMagick++.so.1
+lib/libGraphicsMagick.a
+lib/libGraphicsMagick.so
+lib/libGraphicsMagick.so.1
+lib/libGraphicsMagickWand.a
+lib/libGraphicsMagickWand.so
+lib/libGraphicsMagickWand.so.0
+libdata/pkgconfig/GraphicsMagick++.pc
+libdata/pkgconfig/GraphicsMagick.pc
+libdata/pkgconfig/GraphicsMagickWand.pc
+%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/Graphics/Magick.pm
+%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics/Magick/.packlist
+%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics/Magick/Magick.so
+%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics/Magick/Magick.bs
+%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics/Magick/autosplit.ix
+@comment lib/GraphicsMagick-%%PORTVERSION%%/modules-%%Q%%/coders
+@comment lib/GraphicsMagick-%%PORTVERSION%%/modules-%%Q%%/filters
+%%PORTDOCS%%%%DOCSDIR%%/images/ball.png
+%%PORTDOCS%%%%DOCSDIR%%/images/corbis.png
+%%PORTDOCS%%%%DOCSDIR%%/images/examples.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/gm-125x80t.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gm-188x120t.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gm-282x180t.png
+%%PORTDOCS%%%%DOCSDIR%%/images/home.png
+%%PORTDOCS%%%%DOCSDIR%%/images/mail.png
+%%PORTDOCS%%%%DOCSDIR%%/images/pdfsages.png
+%%PORTDOCS%%%%DOCSDIR%%/images/pngnow.png
+%%PORTDOCS%%%%DOCSDIR%%/images/right_triangle.png
+%%PORTDOCS%%%%DOCSDIR%%/images/right_triangle_option.png
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/www/AUTHORS.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Changelog.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Copyright.html
+%%PORTDOCS%%%%DOCSDIR%%/www/FAQ.html
+%%PORTDOCS%%%%DOCSDIR%%/www/GraphicsMagick.html
+%%PORTDOCS%%%%DOCSDIR%%/www/INSTALL-mac.html
+%%PORTDOCS%%%%DOCSDIR%%/www/INSTALL-unix.html
+%%PORTDOCS%%%%DOCSDIR%%/www/INSTALL-vms.html
+%%PORTDOCS%%%%DOCSDIR%%/www/INSTALL-windows.html
+%%PORTDOCS%%%%DOCSDIR%%/www/ImageMagickObject.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Blob.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Cache.fig
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Cache.png
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Cache.svg
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/ChangeLog.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/CoderInfo.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Color.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Documentation.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Drawable.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Drawable_example_1.png
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Enumerations.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Exception.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/FormatCharacters.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Future.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Geometry.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Image.fig
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Image.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Image.png
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/ImageDesign.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/ImageMagick.png
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Install.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Magick++.png
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Montage.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/NEWS.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/PixelPacket.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Pixels.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/STL.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/TypeMetric.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/gm-188x120t.png
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/index.html
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/montage-sample-framed.jpg
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/right_triangle.png
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-anatomy-framed.fig
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-anatomy-framed.jpg
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-anatomy-plain.fig
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-anatomy-plain.jpg
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-sample-framed.jpg
+%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-sample-plain.jpg
+%%PORTDOCS%%%%DOCSDIR%%/www/NEWS.html
+%%PORTDOCS%%%%DOCSDIR%%/www/README.html
+%%PORTDOCS%%%%DOCSDIR%%/www/animate.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/animate.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/annotate.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/attribute.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/blob.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/cache.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/cache_view.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/color.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/composite.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/constitute.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/decorate.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/deprecate.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/display.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/draw.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/effect.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/enhance.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/error.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/fx.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/image.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/list.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/magick.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/memory.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/monitor.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/montage.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/paint.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/profile.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/quantize.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/registry.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/render.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/resize.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/resource.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/segment.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/shear.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/signature.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/stream.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/transform.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/types.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/widget.html
+%%PORTDOCS%%%%DOCSDIR%%/www/body.html
+%%PORTDOCS%%%%DOCSDIR%%/www/body.html.rej
+%%PORTDOCS%%%%DOCSDIR%%/www/books.html
+%%PORTDOCS%%%%DOCSDIR%%/www/color.html
+%%PORTDOCS%%%%DOCSDIR%%/www/composite.html
+%%PORTDOCS%%%%DOCSDIR%%/www/conjure.html
+%%PORTDOCS%%%%DOCSDIR%%/www/contribute.html
+%%PORTDOCS%%%%DOCSDIR%%/www/convert.html
+%%PORTDOCS%%%%DOCSDIR%%/www/cvs.html
+%%PORTDOCS%%%%DOCSDIR%%/www/development.html
+%%PORTDOCS%%%%DOCSDIR%%/www/display.html
+%%PORTDOCS%%%%DOCSDIR%%/www/download.html
+%%PORTDOCS%%%%DOCSDIR%%/www/formats.html
+%%PORTDOCS%%%%DOCSDIR%%/www/gm.html
+%%PORTDOCS%%%%DOCSDIR%%/www/header.html
+%%PORTDOCS%%%%DOCSDIR%%/www/identify.html
+%%PORTDOCS%%%%DOCSDIR%%/www/import.html
+%%PORTDOCS%%%%DOCSDIR%%/www/index.html
+%%PORTDOCS%%%%DOCSDIR%%/www/install.html
+%%PORTDOCS%%%%DOCSDIR%%/www/links.html
+%%PORTDOCS%%%%DOCSDIR%%/www/magick.css
+%%PORTDOCS%%%%DOCSDIR%%/www/miff.html
+%%PORTDOCS%%%%DOCSDIR%%/www/mission.html
+%%PORTDOCS%%%%DOCSDIR%%/www/mogrify.html
+%%PORTDOCS%%%%DOCSDIR%%/www/montage.html
+%%PORTDOCS%%%%DOCSDIR%%/www/perl.html
+%%PORTDOCS%%%%DOCSDIR%%/www/programming.html
+%%PORTDOCS%%%%DOCSDIR%%/www/quantize.html
+%%PORTDOCS%%%%DOCSDIR%%/www/smile.c
+%%PORTDOCS%%%%DOCSDIR%%/www/tools.html
+%%PORTDOCS%%%%DOCSDIR%%/www/utilities.html
+%%PORTDOCS%%%%DOCSDIR%%/www/windows.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/www/api
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/www/Magick++
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/www
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%WITH_PERL%%@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics/Magick
+%%WITH_PERL%%@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics 2>/dev/null || true
+%%WITH_PERL%%@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Graphics
+@dirrm %%DATADIR%%/config
+@dirrm %%DATADIR%%
+@dirrm include/GraphicsMagick/wand
+@dirrm include/GraphicsMagick/magick
+@dirrm include/GraphicsMagick/Magick++
+@dirrm include/GraphicsMagick