aboutsummaryrefslogtreecommitdiff
path: root/graphics/Hermes
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2007-08-30 15:57:05 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2007-08-30 15:57:05 +0000
commit12372ed18943061b631dd62635c7c79d0263692d (patch)
treef046578ab7353ca4d139f8ff30e65928673f0b36 /graphics/Hermes
parentce8d86f55570b9c460f22e6db483cc6464c3d089 (diff)
downloadports-12372ed18943061b631dd62635c7c79d0263692d.tar.gz
ports-12372ed18943061b631dd62635c7c79d0263692d.zip
- Fix build with gcc 4.x
PR: ports/115647 (based on) Submitted by: Oliver Brandmueller <ob@e-gitt.net>
Notes
Notes: svn path=/head/; revision=198535
Diffstat (limited to 'graphics/Hermes')
-rw-r--r--graphics/Hermes/Makefile4
-rw-r--r--graphics/Hermes/files/patch-src-HeadMMX.h11
-rw-r--r--graphics/Hermes/files/patch-src-HeadX86.h11
3 files changed, 22 insertions, 4 deletions
diff --git a/graphics/Hermes/Makefile b/graphics/Hermes/Makefile
index 801659487c81..1514ada1d6b7 100644
--- a/graphics/Hermes/Makefile
+++ b/graphics/Hermes/Makefile
@@ -33,10 +33,6 @@ PORTDOCS= *
IGNORE= is broken on sparc64: interchanges red and blue colour channels in images
.endif
-.if ${ARCH} == i386 && ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2 on i386
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/graphics/Hermes/files/patch-src-HeadMMX.h b/graphics/Hermes/files/patch-src-HeadMMX.h
new file mode 100644
index 000000000000..fa7a76eda017
--- /dev/null
+++ b/graphics/Hermes/files/patch-src-HeadMMX.h
@@ -0,0 +1,11 @@
+--- src/HeadMMX.h.orig Thu Aug 30 19:26:59 2007
++++ src/HeadMMX.h Thu Aug 30 19:27:59 2007
+@@ -51,7 +51,7 @@
+
+ /* Fix the underscore business with ELF compilers */
+
+-#if defined(__ELF__) && defined(__GNUC__)
++#if defined(__ELF__) && defined(__GNUC__) && __GNUC__ < 4
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
diff --git a/graphics/Hermes/files/patch-src-HeadX86.h b/graphics/Hermes/files/patch-src-HeadX86.h
new file mode 100644
index 000000000000..e3cb4826eb11
--- /dev/null
+++ b/graphics/Hermes/files/patch-src-HeadX86.h
@@ -0,0 +1,11 @@
+--- src/HeadX86.h.orig Thu Aug 30 19:28:22 2007
++++ src/HeadX86.h Thu Aug 30 19:28:44 2007
+@@ -83,7 +83,7 @@
+
+ /* Now fix up the ELF underscore problem */
+
+-#if defined(__ELF__) && defined(__GNUC__)
++#if defined(__ELF__) && defined(__GNUC__) && __GNUC__ < 4
+ #ifdef __cplusplus
+ extern "C" {
+ #endif