aboutsummaryrefslogtreecommitdiff
path: root/graphics/ImageMagick/Makefile
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2007-03-29 20:57:15 +0000
committerShaun Amott <shaun@FreeBSD.org>2007-03-29 20:57:15 +0000
commit26eea5af5d0acc101ae2692fe7b3b5c2d209ac04 (patch)
tree4a59309b97a4f7b6b322298e30e1e65ca85c7ec2 /graphics/ImageMagick/Makefile
parent573a68172fe33b5768c53c7e5047fdc0ecc4d2f1 (diff)
downloadports-26eea5af5d0acc101ae2692fe7b3b5c2d209ac04.tar.gz
ports-26eea5af5d0acc101ae2692fe7b3b5c2d209ac04.zip
Fix build with graphviz support in some cases where it fails.
PR: ports/111018 Submitted by: Scot Hetzel <swhetzel@gmail.com>
Notes
Notes: svn path=/head/; revision=188781
Diffstat (limited to 'graphics/ImageMagick/Makefile')
-rw-r--r--graphics/ImageMagick/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 37679622a2dd..726da4034156 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -181,8 +181,9 @@ PLIST_SUB+= JPEG2000="@comment "
# GraphViz dot graphs
.if defined(WITH_IMAGEMAGICK_DOT)
-BUILD_DEPENDS+= dot:${PORTSDIR}/graphics/graphviz
-RUN_DEPENDS+= dot:${PORTSDIR}/graphics/graphviz
+LIB_DEPENDS+= gvc.3:${PORTSDIR}/graphics/graphviz
+CFLAGS+= -I${LOCALBASE}/include/graphviz
+LDFLAGS+= -L${LOCALBASE}/lib/graphviz
.else
CONFIGURE_ARGS+= --without-dot --without-gvc
.endif