aboutsummaryrefslogtreecommitdiff
path: root/graphics/ImageMagick/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1996-11-06 07:53:24 +0000
committerThomas Gellekum <tg@FreeBSD.org>1996-11-06 07:53:24 +0000
commit56715fcd553e3a33a1fea619c0e7e1e0fcbe7c07 (patch)
tree76411f972e953977157fb60a8708be550b69948f /graphics/ImageMagick/Makefile
parent57aa94a945b9ac34dd5673ef69a85eaea1c28807 (diff)
downloadports-56715fcd553e3a33a1fea619c0e7e1e0fcbe7c07.tar.gz
ports-56715fcd553e3a33a1fea619c0e7e1e0fcbe7c07.zip
Upgrade to 3.7.7
Notes
Notes: svn path=/head/; revision=4307
Diffstat (limited to 'graphics/ImageMagick/Makefile')
-rw-r--r--graphics/ImageMagick/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 860bcb5bada7..01f9f5b796da 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -1,23 +1,31 @@
# New ports collection makefile for: ImageMagick
-# Version required: 3.6.2
+# Version required: 3.7.7
# Date created: 15 November 1994
# Whom: torstenb
#
-# $Id: Makefile,v 1.6 1995/06/24 11:37:55 asami Exp $
+# $Id: Makefile,v 1.7 1995/10/03 21:58:08 ache Exp $
#
-DISTNAME= ImageMagick-3.6.2
+DISTNAME= ImageMagick-3.7.7
CATEGORIES+= graphics
MASTER_SITES= ftp://ftp.x.org/contrib/applications/ImageMagick/
+MAINTAINER= ports@freebsd.org
+
LIB_DEPENDS= jpeg\\.6\\.:${PORTSDIR}/graphics/jpeg \
mpeg\\.1\\.:${PORTSDIR}/graphics/mpeg-lib \
tiff\\.3\\.:${PORTSDIR}/graphics/tiff \
- Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
+ png\\.0\\.:${PORTSDIR}/graphics/png
+PREFIX= ${LOCALBASE}
WRKSRC= ${WRKDIR}/ImageMagick
USE_IMAKE= YES
+# Yuck. Somehow, $LOCALBASE isn't expanded in the Makefiles...
+post-patch:
+ @mv ${WRKSRC}/Magick.tmpl ${WRKSRC}/Magick.tmpl.tmp
+ @sed -e "s|!!LOCALBASE!!|${LOCALBASE}|g" <${WRKSRC}/Magick.tmpl.tmp >${WRKSRC}/Magick.tmpl
+
pre-build:
@(cd ${WRKSRC}/magick;make)