aboutsummaryrefslogtreecommitdiff
path: root/graphics/ImageMagick
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2016-08-10 10:02:06 +0000
committerKoop Mast <kwm@FreeBSD.org>2016-08-10 10:02:06 +0000
commit448b8e4612a0fdb2a24e7ce69a077d6577e9ddfc (patch)
tree40b49d29dc5754b87b625c1f067c7e7c2051db90 /graphics/ImageMagick
parentdee5a4a40bcba12de8ad030611bd972223e48fb0 (diff)
downloadports-448b8e4612a0fdb2a24e7ce69a077d6577e9ddfc.tar.gz
ports-448b8e4612a0fdb2a24e7ce69a077d6577e9ddfc.zip
Update ImageMagick to 6.9.5-5.
Register indirect dependancies. Allow slave port to overwrite PORTSCOUT.
Notes
Notes: svn path=/head/; revision=420003
Diffstat (limited to 'graphics/ImageMagick')
-rw-r--r--graphics/ImageMagick/Makefile14
-rw-r--r--graphics/ImageMagick/distinfo6
-rw-r--r--graphics/ImageMagick/files/patch-tests_validate.c11
-rw-r--r--graphics/ImageMagick/pkg-plist1
4 files changed, 23 insertions, 9 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index cc2dde134e67..dc3bf9722cfd 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= ImageMagick
-DISTVERSION= 6.9.4-3
+DISTVERSION= 6.9.5-5
PORTEPOCH= 1
CATEGORIES= graphics perl5
MASTER_SITES= http://www.imagemagick.org/download/ \
@@ -36,13 +36,13 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libltdl.so:devel/libltdl
-PORTSCOUT= limit:6.*$$
+PORTSCOUT?= limit:6.*$$
CONFLICTS_INSTALL= execline-[0-9]* # bin/import
# This port uses .la files, keep libtool:keepla! (magick/module.c)
-USES= cpe gmake libtool:keepla localbase pathfix perl5 \
- pkgconfig:both shebangfix tar:xz
+USES= cpe gettext-runtime gmake gnome libtool:keepla \
+ localbase pathfix perl5 pkgconfig:both shebangfix tar:xz
CPE_PRODUCT= imagemagick
CPE_VENDOR= imagemagick
SHEBANG_FILES= www/source/examples.pl
@@ -50,7 +50,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= MAKE=${MAKE_CMD}
CONFIGURE_ARGS= --without-dps
USE_LDCONFIG= yes
-USE_GNOME= libxml2
+USE_GNOME= glib20 libxml2
+USE_XORG= sm ice x11
SAMPLE_FILES= coder.xml colors.xml delegates.xml log.xml magic.xml mime.xml \
policy.xml quantization-table.xml thresholds.xml type-apple.xml \
@@ -338,6 +339,7 @@ PLIST_SUB+= WMF="@comment "
# SVG (Scalable Vector Graphics) requires both libxml2 and X11
.if ${PORT_OPTIONS:MSVG} && ${PORT_OPTIONS:MX11}
LIB_DEPENDS+= librsvg-2.so:graphics/librsvg2
+USE_GNOME+= cairo gdkpixbuf2
CONFIGURE_ARGS+= --with-rsvg
.else
CONFIGURE_ARGS+= --without-rsvg
@@ -370,7 +372,7 @@ PKGNAMESUFFIX= -nox11
CONFLICTS_INSTALL+= ImageMagick-nox11-6*
CONFLICTS+= display-[0-9]*
CONFIGURE_ARGS+= --with-x
-USE_XORG= xext xt
+USE_XORG+= xext xt
PLIST_SUB+= X11=''
.endif
diff --git a/graphics/ImageMagick/distinfo b/graphics/ImageMagick/distinfo
index d28fdf98168f..aaf2403ecf2e 100644
--- a/graphics/ImageMagick/distinfo
+++ b/graphics/ImageMagick/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1463647427
-SHA256 (ImageMagick-6.9.4-3.tar.xz) = 567a658fab95d63f550817e5ec1bc83b5b0b150a52eed1d59f5de88b62e96d7a
-SIZE (ImageMagick-6.9.4-3.tar.xz) = 8783424
+TIMESTAMP = 1470820107
+SHA256 (ImageMagick-6.9.5-5.tar.xz) = b3b5cc1989a53b8847ffdc3b5ed740ba0c9c4e9b103cbbac7d0a78e5b7d2936f
+SIZE (ImageMagick-6.9.5-5.tar.xz) = 8784240
diff --git a/graphics/ImageMagick/files/patch-tests_validate.c b/graphics/ImageMagick/files/patch-tests_validate.c
new file mode 100644
index 000000000000..805d244b9600
--- /dev/null
+++ b/graphics/ImageMagick/files/patch-tests_validate.c
@@ -0,0 +1,11 @@
+--- tests/validate.c.orig 2016-08-10 11:23:44.131844000 +0200
++++ tests/validate.c 2016-08-10 11:24:56.257698000 +0200
+@@ -2394,7 +2394,7 @@
+ else
+ {
+ (void) FormatLocaleFile(stdout,"Version: %s\n",
+- GetMagickHomeURL();
++ GetMagickVersion((size_t *) NULL));
+ (void) FormatLocaleFile(stdout,"Copyright: %s\n\n",
+ GetMagickCopyright());
+ (void) FormatLocaleFile(stdout,
diff --git a/graphics/ImageMagick/pkg-plist b/graphics/ImageMagick/pkg-plist
index 43a27748df56..5b6108c814fe 100644
--- a/graphics/ImageMagick/pkg-plist
+++ b/graphics/ImageMagick/pkg-plist
@@ -1454,6 +1454,7 @@ man/man1/stream.1.gz
%%PORTDOCS%%%%DOCSDIR%%-6/www/quantize.html
%%PORTDOCS%%%%DOCSDIR%%-6/www/resources.html
%%PORTDOCS%%%%DOCSDIR%%-6/www/search.html
+%%PORTDOCS%%%%DOCSDIR%%-6/www/security-policy.html
%%PORTDOCS%%%%DOCSDIR%%-6/www/sitemap.html
%%PORTDOCS%%%%DOCSDIR%%-6/www/source/analyze.c
%%PORTDOCS%%%%DOCSDIR%%-6/www/source/coder.xml