aboutsummaryrefslogtreecommitdiff
path: root/graphics/ImageMagick
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-05-29 15:59:57 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-05-29 15:59:57 +0000
commit705fd6b0553711ec3ededd1af2737c9b038326c2 (patch)
treeb27ff47f348f483bcec6c30527c47035952d5955 /graphics/ImageMagick
parent905ef041513a9c04ad5f5d41d661d79680fc8a84 (diff)
downloadports-705fd6b0553711ec3ededd1af2737c9b038326c2.tar.gz
ports-705fd6b0553711ec3ededd1af2737c9b038326c2.zip
Update ImageMagick to 6.9.1-3.
Notes
Notes: svn path=/head/; revision=387870
Diffstat (limited to 'graphics/ImageMagick')
-rw-r--r--graphics/ImageMagick/Makefile6
-rw-r--r--graphics/ImageMagick/distinfo4
-rw-r--r--graphics/ImageMagick/files/extra-magick_locale.c98
-rw-r--r--graphics/ImageMagick/pkg-plist4
4 files changed, 6 insertions, 106 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 8719136dbb02..ebeb649c28a8 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= ImageMagick
-DISTVERSION= 6.9.1-2
+DISTVERSION= 6.9.1-3
PORTEPOCH= 1
CATEGORIES= graphics perl5
MASTER_SITES= http://www.imagemagick.org/download/ \
@@ -379,10 +379,6 @@ INSTALL_TARGET= install-strip
USE_GHOSTSCRIPT_BUILD=yes
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 900000
-EXTRA_PATCHES+= ${FILESDIR}/extra-magick_locale.c
-.endif
-
post-patch:
# strip library name of variable parts that can change due to
# the HDRI and Q16 option
diff --git a/graphics/ImageMagick/distinfo b/graphics/ImageMagick/distinfo
index 384ccccf379f..00f0d8cd6cdd 100644
--- a/graphics/ImageMagick/distinfo
+++ b/graphics/ImageMagick/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ImageMagick-6.9.1-2.tar.xz) = 5391aac3fedb7d627a89f06d195a1c3b422d2235aa6e0d0d26886b2e0a10a294
-SIZE (ImageMagick-6.9.1-2.tar.xz) = 7909464
+SHA256 (ImageMagick-6.9.1-3.tar.xz) = 5fd180603e60c624c05c644a8340f4f4e92c19dc3c41d374d38f76c69cd48ba3
+SIZE (ImageMagick-6.9.1-3.tar.xz) = 7965132
diff --git a/graphics/ImageMagick/files/extra-magick_locale.c b/graphics/ImageMagick/files/extra-magick_locale.c
deleted file mode 100644
index ba12452fbd6b..000000000000
--- a/graphics/ImageMagick/files/extra-magick_locale.c
+++ /dev/null
@@ -1,98 +0,0 @@
---- magick/locale.c.orig 2015-04-14 23:09:38.000000000 +0200
-+++ magick/locale.c 2015-04-27 12:00:08.997474000 +0200
-@@ -66,6 +66,14 @@
- #define MaxRecursionDepth 200
-
- /*
-+ Typedef declarations.
-+*/
-+#if defined(__CYGWIN__)
-+typedef struct _locale_t
-+ *locale_t;
-+#endif
-+
-+/*
- Static declarations.
- */
- static const char
-@@ -86,7 +94,7 @@ static SemaphoreInfo
- static SplayTreeInfo
- *locale_cache = (SplayTreeInfo *) NULL;
-
--#if defined(MAGICKCORE_HAVE_LOCALE_H)
-+#if defined(MAGICKCORE_HAVE_STRTOD_L)
- static volatile locale_t
- c_locale = (locale_t) NULL;
- #endif
-@@ -99,7 +107,7 @@ static MagickBooleanType
- LoadLocaleCache(SplayTreeInfo *,const char *,const char *,const char *,
- const size_t,ExceptionInfo *);
-
--#if defined(MAGICKCORE_HAVE_LOCALE_H)
-+#if defined(MAGICKCORE_HAVE_STRTOD_L)
- /*
- %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
- % %
-@@ -229,7 +237,7 @@ static SplayTreeInfo *AcquireLocaleSplay
- return(locale_cache);
- }
-
--#if defined(MAGICKCORE_HAVE_LOCALE_H)
-+#if defined(MAGICKCORE_HAVE_STRTOD_L)
- /*
- %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
- % %
-@@ -331,7 +339,7 @@ MagickExport ssize_t FormatLocaleFileLis
- ssize_t
- n;
-
--#if defined(MAGICKCORE_HAVE_LOCALE_H) && defined(MAGICKCORE_HAVE_VFPRINTF_L)
-+#if defined(MAGICKCORE_HAVE_VFPRINTF_L)
- {
- locale_t
- locale;
-@@ -347,7 +355,7 @@ MagickExport ssize_t FormatLocaleFileLis
- #endif
- }
- #else
--#if defined(MAGICKCORE_HAVE_LOCALE_H) && defined(MAGICKCORE_HAVE_USELOCALE)
-+#if defined(MAGICKCORE_HAVE_USELOCALE) && defined(MAGICKCORE_HAVE_STRTOD_L)
- {
- locale_t
- locale,
-@@ -422,7 +430,7 @@ MagickExport ssize_t FormatLocaleStringL
- ssize_t
- n;
-
--#if defined(MAGICKCORE_HAVE_LOCALE_H) && defined(MAGICKCORE_HAVE_VSNPRINTF_L)
-+#if defined(MAGICKCORE_HAVE_VSNPRINTF_L)
- {
- locale_t
- locale;
-@@ -438,7 +446,7 @@ MagickExport ssize_t FormatLocaleStringL
- #endif
- }
- #elif defined(MAGICKCORE_HAVE_VSNPRINTF)
--#if defined(MAGICKCORE_HAVE_LOCALE_H) && defined(MAGICKCORE_HAVE_USELOCALE)
-+#if defined(MAGICKCORE_HAVE_USELOCALE) && defined(MAGICKCORE_HAVE_STRTOD_L)
- {
- locale_t
- locale,
-@@ -981,7 +989,7 @@ MagickExport double InterpretLocaleValue
- value=(double) strtoul(string,&q,16);
- else
- {
--#if defined(MAGICKCORE_HAVE_LOCALE_H) && defined(MAGICKCORE_HAVE_STRTOD_L)
-+#if defined(MAGICKCORE_HAVE_STRTOD_L)
- locale_t
- locale;
-
-@@ -1420,7 +1428,7 @@ MagickExport void LocaleComponentTerminu
- LockSemaphoreInfo(locale_semaphore);
- if (locale_cache != (SplayTreeInfo *) NULL)
- locale_cache=DestroySplayTree(locale_cache);
--#if defined(MAGICKCORE_HAVE_LOCALE_H)
-+#if defined(MAGICKCORE_HAVE_STRTOD_L)
- DestroyCLocale();
- #endif
- UnlockSemaphoreInfo(locale_semaphore);
diff --git a/graphics/ImageMagick/pkg-plist b/graphics/ImageMagick/pkg-plist
index d2240bbdf850..101e7f147b6c 100644
--- a/graphics/ImageMagick/pkg-plist
+++ b/graphics/ImageMagick/pkg-plist
@@ -620,6 +620,9 @@ man/man1/stream.1.gz
%%PORTDOCS%%%%DOCSDIR%%-6/www/advanced-unix-installation.html
%%PORTDOCS%%%%DOCSDIR%%-6/www/advanced-windows-installation.html
%%PORTDOCS%%%%DOCSDIR%%-6/www/animate.html
+%%PORTDOCS%%%%DOCSDIR%%-6/www/css/bootstrap.min.css
+%%PORTDOCS%%%%DOCSDIR%%-6/www/css/magick.css
+%%PORTDOCS%%%%DOCSDIR%%-6/www/js/bootstrap.min.js
%%PORTDOCS%%%%DOCSDIR%%-6/www/openmp.html
%%PORTDOCS%%%%DOCSDIR%%-6/www/webp.html
%%PORTDOCS%%%%DOCSDIR%%-6/www/distribute-pixel-cache.html
@@ -1467,7 +1470,6 @@ man/man1/stream.1.gz
%%PORTDOCS%%%%DOCSDIR%%-6/www/source/type-windows.xml
%%PORTDOCS%%%%DOCSDIR%%-6/www/source/type.xml
%%PORTDOCS%%%%DOCSDIR%%-6/www/source/wand.c
-%%PORTDOCS%%%%DOCSDIR%%-6/www/sponsors.html
%%PORTDOCS%%%%DOCSDIR%%-6/www/stream.html
%%PORTDOCS%%%%DOCSDIR%%-6/www/subversion.html
%%PORTDOCS%%%%DOCSDIR%%-6/www/t-shirt.html