aboutsummaryrefslogtreecommitdiff
path: root/graphics/ImageMagick
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
commit7c47779cb9cc1f12908949c26b831e944047ed17 (patch)
treecc6e929ebf67eee2cc8ce1692ea0663387b3a559 /graphics/ImageMagick
parentb4c4d6656e7b913544a3cbd1bea7f40f7cad2e74 (diff)
downloadports-7c47779cb9cc1f12908949c26b831e944047ed17.tar.gz
ports-7c47779cb9cc1f12908949c26b831e944047ed17.zip
Fix usage of ${PERL5}.
${PERL5} points to a specific version of perl, say, perl5.22.1, it is fine to use it in a ports Makefile to do Perly things, but ports using it must use ${PERL}, that points to /usr/local/bin/perl so that if the minor version is updated, the shebang keep working. While there, make some ports use shebangfix, regen a few patches, and bump PORTREVISION where a shebang went from PERL5 to PERL. PR: 205367 With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=403913
Diffstat (limited to 'graphics/ImageMagick')
-rw-r--r--graphics/ImageMagick/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index b5cf1d4e6f19..85ce4b137da8 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ImageMagick
DISTVERSION= 6.9.2-8
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics perl5
MASTER_SITES= http://www.imagemagick.org/download/ \
@@ -106,7 +107,7 @@ _IMAGEMAGICK_THREADS_IGNORE_MSG=. Define WITH_THREADS
.endif
.if ${PORT_OPTIONS:MPERL}
-CONFIGURE_ARGS+= --with-perl=${PERL5} \
+CONFIGURE_ARGS+= --with-perl=${PERL} \
--with-perl-options="MAKE=${MAKE_CMD}"
PLIST_SUB+= WITH_PERL=''
# PerlMagick does not work with threads, if perl is not threaded, and vice versa