aboutsummaryrefslogtreecommitdiff
path: root/graphics/R-cran-rtiff
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2012-02-26 21:54:23 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2012-02-26 21:54:23 +0000
commit0ca99f6414250b258b315059a1db9f9b31467247 (patch)
tree2b1036a2d7ffcf6907021af531a7832289b7030a /graphics/R-cran-rtiff
parent93cc7cd78bea2e086f0b697423b71f9fa0b3fe1c (diff)
downloadports-0ca99f6414250b258b315059a1db9f9b31467247.tar.gz
ports-0ca99f6414250b258b315059a1db9f9b31467247.zip
- Add a new port: graphics/R-cran-rtiff
This package will read and write TIFF format images and return them as a pixmap object. Because the resulting object can be very large for even modestly sized TIFF images, images can be reduced as they are read for improved performance. This package is a wrapper around libtiff (www.libtiff.org), on which it depends (i.e. the libtiff shared library must be on your PATH for the binary to work, and tiffio.h must be on your system to build the package from source). By using libtiff's highlevel TIFFReadRGBAImage function, this package inherently support a wide range of image formats and compression schemes. This package also provides an implementation of the Ridler Autothresholding algorithm for easy generation of binary masks. WWW: http://cran.r-project.org/web/packages/rtiff/
Notes
Notes: svn path=/head/; revision=292282
Diffstat (limited to 'graphics/R-cran-rtiff')
-rw-r--r--graphics/R-cran-rtiff/Makefile26
-rw-r--r--graphics/R-cran-rtiff/distinfo2
-rw-r--r--graphics/R-cran-rtiff/pkg-descr13
3 files changed, 41 insertions, 0 deletions
diff --git a/graphics/R-cran-rtiff/Makefile b/graphics/R-cran-rtiff/Makefile
new file mode 100644
index 000000000000..85767c09adf3
--- /dev/null
+++ b/graphics/R-cran-rtiff/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: R-cran-rtiff
+# Date created: 2012-02-21
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rtiff
+PORTVERSION= 1.4.1
+CATEGORIES= graphics
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= A tiff reader for R
+
+LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff
+RUN_DEPENDS= R-cran-pixmap>0:${PORTSDIR}/graphics/R-cran-pixmap
+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LDFLAGS+= -L${LOCALBASE}/lib
+
+USE_R_MOD= yes
+R_MOD_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/R-cran-rtiff/distinfo b/graphics/R-cran-rtiff/distinfo
new file mode 100644
index 000000000000..8ba832bf4287
--- /dev/null
+++ b/graphics/R-cran-rtiff/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rtiff_1.4.1.tar.gz) = a8f11af2b617123294dddd61815327e31c67124c88b8f5145304d49cafa29dae
+SIZE (rtiff_1.4.1.tar.gz) = 102323
diff --git a/graphics/R-cran-rtiff/pkg-descr b/graphics/R-cran-rtiff/pkg-descr
new file mode 100644
index 000000000000..bde3709ee2d5
--- /dev/null
+++ b/graphics/R-cran-rtiff/pkg-descr
@@ -0,0 +1,13 @@
+This package will read and write TIFF format images and return them
+as a pixmap object. Because the resulting object can be very large
+for even modestly sized TIFF images, images can be reduced as they
+are read for improved performance. This package is a wrapper around
+libtiff (www.libtiff.org), on which it depends (i.e. the libtiff
+shared library must be on your PATH for the binary to work, and
+tiffio.h must be on your system to build the package from source).
+By using libtiff's highlevel TIFFReadRGBAImage function, this package
+inherently support a wide range of image formats and compression
+schemes. This package also provides an implementation of the Ridler
+Autothresholding algorithm for easy generation of binary masks.
+
+WWW: http://cran.r-project.org/web/packages/rtiff/