aboutsummaryrefslogtreecommitdiff
path: root/graphics/ampasCTL
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-09-24 21:28:32 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-09-24 21:28:32 +0000
commitf1b61496bc1b106f289c1cf2a9931d63c74e5ef6 (patch)
tree43ab9590026e4961d6953fccc2399f213ca7e7dd /graphics/ampasCTL
parent1e783fb20444fe5e3c91148de7c890fdc4bd0ffc (diff)
downloadports-f1b61496bc1b106f289c1cf2a9931d63c74e5ef6.tar.gz
ports-f1b61496bc1b106f289c1cf2a9931d63c74e5ef6.zip
- Bump portrevision
- Change master sites SF --> GH, recreate tarball - Change maintainer email gmx.ch --> FreeBSD.org - Use the new format for LIB_DEPENDS - USES pathfix pkgconfig - Add dependency for aclocal - Add DOCS Option, change and remove from pkg-plist - Use pathfix and REINPLACE_CMD instead of simple patches - Change WWW Approved by: wg/pawel (mentors)
Notes
Notes: svn path=/head/; revision=328197
Diffstat (limited to 'graphics/ampasCTL')
-rw-r--r--graphics/ampasCTL/Makefile47
-rw-r--r--graphics/ampasCTL/distinfo4
-rw-r--r--graphics/ampasCTL/files/patch-Makefile.in11
-rw-r--r--graphics/ampasCTL/files/patch-doc-Makefile.in11
-rw-r--r--graphics/ampasCTL/pkg-descr4
-rw-r--r--graphics/ampasCTL/pkg-plist5
6 files changed, 41 insertions, 41 deletions
diff --git a/graphics/ampasCTL/Makefile b/graphics/ampasCTL/Makefile
index bb854506e3e0..46c445efc467 100644
--- a/graphics/ampasCTL/Makefile
+++ b/graphics/ampasCTL/Makefile
@@ -3,29 +3,54 @@
PORTNAME= ampasCTL
PORTVERSION= 1.4.1
+PORTREVISION= 1
CATEGORIES= graphics devel
-MASTER_SITES= SF/${PORTNAME:L}/ctl/ctl-${PORTVERSION}/
DISTNAME= ctl-${DISTVERSION}
-MAINTAINER= nemysis@gmx.ch
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= Color Transformation Language interpreter
LICENSE= BSD
-LIB_DEPENDS= Imath:${PORTSDIR}/graphics/ilmbase
+LIB_DEPENDS= libImath.so:${PORTSDIR}/graphics/ilmbase
-USES= pkgconfig
-USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/ampas-CTL-${GH_COMMIT}/CTL
+
+USE_GITHUB= yes
+GH_ACCOUNT= ampas
+GH_PROJECT= CTL
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= ca179ca
+
+USES= pathfix pkgconfig
+PATHFIX_MAKEFILEIN= Makefile.am
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libtool
+USE_AUTOTOOLS= aclocal libtool
+USE_LDCONFIG= yes
+
+PORTDOCS= *
-PORTDOCS= AUTHORS ChangeLog NEWS README
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= AUTHORS ChangeLog NEWS README
+
+DOCSRCDIR2= ${WRKSRC}/doc
+DOCSDIR2= ${DOCSDIR}/doc
+DOC_FILES2= CtlManual.pdf CtlManual.doc
+
+OPTIONS_DEFINE= DOCS
NO_STAGE= yes
.include <bsd.port.options.mk>
+pre-configure:
+ @(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./bootstrap)
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|CtlManual.pdf CtlManual.doc||' \
+ ${WRKSRC}/doc/Makefile.am
+
test check: build
- @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
+ @(cd ${WRKSRC} ; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
.if defined(PACKAGE_BUILDING)
pre-install: test
@@ -33,8 +58,10 @@ pre-install: test
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${DOCSDIR2}
.endif
.include <bsd.port.mk>
diff --git a/graphics/ampasCTL/distinfo b/graphics/ampasCTL/distinfo
index fcab7094c1cc..5dcc818c6a76 100644
--- a/graphics/ampasCTL/distinfo
+++ b/graphics/ampasCTL/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ctl-1.4.1.tar.gz) = b202d9552eeb81f3ded66a6786719f6e1138fa4e31c866799b1efad6ef7a9f9a
-SIZE (ctl-1.4.1.tar.gz) = 996923
+SHA256 (ctl-1.4.1.tar.gz) = 89757647d8a3b53d1cf8e356c4d01c1112f7b57f518b052829339e0a4cd5ac39
+SIZE (ctl-1.4.1.tar.gz) = 1127090
diff --git a/graphics/ampasCTL/files/patch-Makefile.in b/graphics/ampasCTL/files/patch-Makefile.in
deleted file mode 100644
index 0f987f6b2404..000000000000
--- a/graphics/ampasCTL/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig 2007-08-04 09:11:41.000000000 +0900
-+++ Makefile.in 2007-10-08 06:50:25.000000000 +0900
-@@ -203,7 +203,7 @@
- AUTHORS COPYING ChangeLog INSTALL LICENSE NEWS \
- README README.CVS README.OSX README.win32 bootstrap
-
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
- pkgconfig_DATA = CTL.pc
- all: all-recursive
-
diff --git a/graphics/ampasCTL/files/patch-doc-Makefile.in b/graphics/ampasCTL/files/patch-doc-Makefile.in
deleted file mode 100644
index e13a9c10940a..000000000000
--- a/graphics/ampasCTL/files/patch-doc-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- doc/Makefile.in.orig 2007-08-04 09:11:41.000000000 +0900
-+++ doc/Makefile.in 2007-10-08 06:51:25.000000000 +0900
-@@ -171,7 +171,7 @@
- sysconfdir = @sysconfdir@
- target_alias = @target_alias@
- EXTRA_DIST = CtlManual.pdf CtlManual.doc
--docdir = $(datadir)/doc/CTL-@CTL_VERSION@
-+docdir = $(datadir)/doc/ampasCTL
- doc_DATA = $(EXTRA_DIST)
- all: all-am
-
diff --git a/graphics/ampasCTL/pkg-descr b/graphics/ampasCTL/pkg-descr
index 287655b6e1e5..698a72e4d7db 100644
--- a/graphics/ampasCTL/pkg-descr
+++ b/graphics/ampasCTL/pkg-descr
@@ -19,6 +19,4 @@ IlmCtlMathTest Confidence tests for IlmCtlMath
IlmCtlTest Confidence tests for IlmImfCtl
-WWW: http://www.openexr.com/
-WWW: http://www.oscars.org/science-technology/council/projects/ctl.html
-WWW: http://ampasctl.sourceforge.net/
+WWW: https://github.com/ampas/CTL/
diff --git a/graphics/ampasCTL/pkg-plist b/graphics/ampasCTL/pkg-plist
index 9b6f0e9ce182..d319988794e7 100644
--- a/graphics/ampasCTL/pkg-plist
+++ b/graphics/ampasCTL/pkg-plist
@@ -32,7 +32,4 @@ lib/libIlmCtlSimd.la
lib/libIlmCtlSimd.so
lib/libIlmCtlSimd.so.2
libdata/pkgconfig/CTL.pc
-%%PORTDOCS%%%%DOCSDIR%%/CtlManual.doc
-%%PORTDOCS%%%%DOCSDIR%%/CtlManual.pdf
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrmtry include/CTL
+@dirrm include/CTL