aboutsummaryrefslogtreecommitdiff
path: root/graphics/autoq3d
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-08-20 17:41:04 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-08-20 17:41:04 +0000
commitb44cb941e773542690b523c455e611c96e909115 (patch)
treebf74fc1700961bc6f3a77d73899d6564f67373a2 /graphics/autoq3d
parentb0c500d725d1691795c8f4ec5a2a5f3e412203c8 (diff)
downloadports-b44cb941e773542690b523c455e611c96e909115.tar.gz
ports-b44cb941e773542690b523c455e611c96e909115.zip
AutoQ3D Community is the open source software project of
this 3D modeling application. WWW: http://autoq3d.ecuadra.com/ PR: ports/ports/114889 Submitted by: Yinghong.Liu <relaxbsd at gmail.com>
Notes
Notes: svn path=/head/; revision=197983
Diffstat (limited to 'graphics/autoq3d')
-rw-r--r--graphics/autoq3d/Makefile63
-rw-r--r--graphics/autoq3d/distinfo3
-rw-r--r--graphics/autoq3d/pkg-descr4
-rw-r--r--graphics/autoq3d/pkg-plist57
4 files changed, 127 insertions, 0 deletions
diff --git a/graphics/autoq3d/Makefile b/graphics/autoq3d/Makefile
new file mode 100644
index 000000000000..eba0eee153dc
--- /dev/null
+++ b/graphics/autoq3d/Makefile
@@ -0,0 +1,63 @@
+# New ports collection makefile for: autoq3d
+# Date created: 28 Jul 2007
+# Whom: Yinghong.Liu <relaxbsd@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= autoq3d
+DISTVERSION= 1.36
+CATEGORIES= graphics
+MASTER_SITES= SF
+DISTNAME= AutoQ3DGPL${PORTVERSION:C/\./-/}qt4source
+
+MAINTAINER= relaxbsd@gmail.com
+COMMENT= A complete QT quick 3d model editor program
+
+USE_ZIP= yes
+USE_QT_VER= 4
+QT_COMPONENTS= qmake corelib moc gui opengl
+
+PORTDOCS= 3DQformat.txt ChangeLog.txt Install.txt license.txt
+
+.if !defined(WITHOUT_NLS)
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+.endif
+
+DESKTOP_ENTRIES= "AutoQ3D" \
+ "A complete QT quick 3d model editor program" \
+ "AutoQ3D" \
+ "AutoQ3D" \
+ "Qt;KDE;Graphics;" \
+ "false"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share/AutoQ3D-GPL|${DATADIR}|g' \
+ ${WRKSRC}/src/main.cpp \
+ ${WRKSRC}/src/fgui/cadform.cpp \
+ ${WRKSRC}/src/dialogs/prgsettings.cpp
+
+pre-build:
+ @cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${QMAKE} -spec ${QMAKESPEC}
+
+post-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/AutoQ3D ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/pixmaps
+ @${INSTALL_DATA} ${WRKSRC}/AutoQ3D.png ${PREFIX}/share/pixmaps
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/qref*.htm ${DATADIR}
+ @${MKDIR} ${DATADIR}/images
+ @${INSTALL_DATA} ${WRKSRC}/images/*.png ${DATADIR}/images
+.if !defined(WITHOUT_NLS)
+ @${INSTALL_DATA} ${WRKSRC}/*.qm ${DATADIR}
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/docs/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/autoq3d/distinfo b/graphics/autoq3d/distinfo
new file mode 100644
index 000000000000..48a938bedb7b
--- /dev/null
+++ b/graphics/autoq3d/distinfo
@@ -0,0 +1,3 @@
+MD5 (AutoQ3DGPL1-36qt4source.zip) = 969a93ab1e0eaf69b5457b9fdaa169a2
+SHA256 (AutoQ3DGPL1-36qt4source.zip) = 39769b39aa99102201bf64bce447543624daf84cc0c75826685211e58bbd219a
+SIZE (AutoQ3DGPL1-36qt4source.zip) = 221520
diff --git a/graphics/autoq3d/pkg-descr b/graphics/autoq3d/pkg-descr
new file mode 100644
index 000000000000..45b20137e26c
--- /dev/null
+++ b/graphics/autoq3d/pkg-descr
@@ -0,0 +1,4 @@
+AutoQ3D Community is the open source software project of
+this 3D modeling application.
+
+WWW: http://autoq3d.ecuadra.com/
diff --git a/graphics/autoq3d/pkg-plist b/graphics/autoq3d/pkg-plist
new file mode 100644
index 000000000000..419537c70aae
--- /dev/null
+++ b/graphics/autoq3d/pkg-plist
@@ -0,0 +1,57 @@
+bin/AutoQ3D
+%%DATADIR%%/images/array.png
+%%DATADIR%%/images/autoscale.png
+%%DATADIR%%/images/cascade.png
+%%DATADIR%%/images/console.png
+%%DATADIR%%/images/dist.png
+%%DATADIR%%/images/doclose.png
+%%DATADIR%%/images/document.png
+%%DATADIR%%/images/erase.png
+%%DATADIR%%/images/extrude.png
+%%DATADIR%%/images/fileclose.png
+%%DATADIR%%/images/filenew.png
+%%DATADIR%%/images/fileopen.png
+%%DATADIR%%/images/filesave.png
+%%DATADIR%%/images/filesaveas.png
+%%DATADIR%%/images/flip.png
+%%DATADIR%%/images/mnormals.png
+%%DATADIR%%/images/palette_color.png
+%%DATADIR%%/images/pan.png
+%%DATADIR%%/images/pani.png
+%%DATADIR%%/images/panm.png
+%%DATADIR%%/images/plxy.png
+%%DATADIR%%/images/plxz.png
+%%DATADIR%%/images/plyz.png
+%%DATADIR%%/images/polygon.png
+%%DATADIR%%/images/rectangle.png
+%%DATADIR%%/images/revolve.png
+%%DATADIR%%/images/rotate3d.png
+%%DATADIR%%/images/rotatei.png
+%%DATADIR%%/images/rotatem.png
+%%DATADIR%%/images/rotateview.png
+%%DATADIR%%/images/slice.png
+%%DATADIR%%/images/snap.png
+%%DATADIR%%/images/spherical.png
+%%DATADIR%%/images/switch.png
+%%DATADIR%%/images/texdocs.png
+%%DATADIR%%/images/texxyz.png
+%%DATADIR%%/images/tile.png
+%%DATADIR%%/images/trails.png
+%%DATADIR%%/images/triangles.png
+%%DATADIR%%/images/trinorm.png
+%%DATADIR%%/images/undo.png
+%%DATADIR%%/images/vfront.png
+%%DATADIR%%/images/viewmag2.png
+%%DATADIR%%/images/visometric.png
+%%DATADIR%%/images/vopts.png
+%%DATADIR%%/images/vright.png
+%%DATADIR%%/images/vtop.png
+%%DATADIR%%/images/vwprop.png
+%%DATADIR%%/images/zoomi.png
+%%DATADIR%%/images/zoomim.png
+%%NLS%%%%DATADIR%%/lan_sp.qm
+%%DATADIR%%/qref.htm
+%%DATADIR%%/qref_sp.htm
+share/pixmaps/AutoQ3D.png
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%