aboutsummaryrefslogtreecommitdiff
path: root/graphics/aview
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>1997-12-24 07:39:24 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>1997-12-24 07:39:24 +0000
commit6ad12af958af07f34f8bbb90255287741663d995 (patch)
treed8cea5c70de747d82870cf5089b6ed9bc508f3c7 /graphics/aview
parent742d411eeda4caca998d1f751fe4eaccbaabd05f (diff)
downloadports-6ad12af958af07f34f8bbb90255287741663d995.tar.gz
ports-6ad12af958af07f34f8bbb90255287741663d995.zip
Aview is a graphics viewer which utilize graphics/aalib,
It display graphics using ascii texts. PR: ports/5336 Submitted by: Frank Chen Hsiung Chan <frankch@waru.life.nthu.edu.tw>
Notes
Notes: svn path=/head/; revision=9163
Diffstat (limited to 'graphics/aview')
-rw-r--r--graphics/aview/Makefile21
-rw-r--r--graphics/aview/distinfo1
-rw-r--r--graphics/aview/files/patch-aa70
-rw-r--r--graphics/aview/pkg-comment1
-rw-r--r--graphics/aview/pkg-descr16
-rw-r--r--graphics/aview/pkg-plist3
6 files changed, 112 insertions, 0 deletions
diff --git a/graphics/aview/Makefile b/graphics/aview/Makefile
new file mode 100644
index 000000000000..3ab6706aa458
--- /dev/null
+++ b/graphics/aview/Makefile
@@ -0,0 +1,21 @@
+# New ports collection Makefile for: aview
+# Version required: 1.1
+# Date created: Dec 18 1997
+# Whom: frankch@waru.life.nthu.edu.tw
+#
+# $Id$
+#
+
+DISTNAME= aview-1.1
+CATEGORIES= graphics x11
+MASTER_SITES= ftp://ftp.ta.jcu.cz/pub/aa/
+
+MAINTAINER= frankch@waru.life.nthu.edu.tw
+
+RUN_DEPENDS= anytopnm:${PORTSDIR}/graphics/netpbm \
+ convert:${PORTSDIR}/graphics/ImageMagick
+LIB_DEPENDS= aa\\.1\\.:${PORTSDIR}/graphics/aalib
+
+GNU_CONFIGURE= YES
+
+.include <bsd.port.mk>
diff --git a/graphics/aview/distinfo b/graphics/aview/distinfo
new file mode 100644
index 000000000000..fc5cacc923ed
--- /dev/null
+++ b/graphics/aview/distinfo
@@ -0,0 +1 @@
+MD5 (aview-1.1.tar.gz) = 603ce1815c55b1ee456ab18363043f79
diff --git a/graphics/aview/files/patch-aa b/graphics/aview/files/patch-aa
new file mode 100644
index 000000000000..ecfd1df80b1f
--- /dev/null
+++ b/graphics/aview/files/patch-aa
@@ -0,0 +1,70 @@
+--- flip.c.orig Thu Dec 18 23:22:17 1997
++++ flip.c Thu Dec 18 23:22:59 1997
+@@ -659,15 +659,15 @@
+ static void selectsupported(aa_context * c)
+ {
+ int supported = 0;
+- if (c->driver->params.supported & AA_NORMAL_MASK)
++ if (c->params.supported & AA_NORMAL_MASK)
+ supported |= yesno(0, 0, "May I use normal text? ") ? AA_NORMAL_MASK : 0;
+- if (c->driver->params.supported & AA_DIM_MASK)
++ if (c->params.supported & AA_DIM_MASK)
+ supported |= yesno(0, 1, "May I use half bright(dim)? ") ? AA_DIM_MASK : 0;
+- if (c->driver->params.supported & AA_BOLD_MASK)
++ if (c->params.supported & AA_BOLD_MASK)
+ supported |= yesno(0, 2, "May I use bold as double bright?") ? AA_BOLD_MASK : 0;
+- if (c->driver->params.supported & AA_BOLDFONT_MASK)
++ if (c->params.supported & AA_BOLDFONT_MASK)
+ supported |= yesno(0, 3, "May I use bold as bold font? ") ? AA_BOLDFONT_MASK : 0;
+- if (c->driver->params.supported & AA_REVERSE_MASK)
++ if (c->params.supported & AA_REVERSE_MASK)
+ supported |= yesno(0, 4, "May I use reversed text? ") ? AA_REVERSE_MASK : 0;
+ aa_setsupported(c, supported);
+ }
+--- image.c.orig Thu Dec 18 23:21:31 1997
++++ image.c Thu Dec 18 23:21:50 1997
+@@ -1,5 +1,5 @@
+ #include <stdio.h>
+-#include <malloc.h>
++#include <stdlib.h>
+
+ int imgwidth, imgheight;
+ unsigned char *imgdata;
+--- ui.c.orig Thu Dec 18 23:20:31 1997
++++ ui.c Thu Dec 18 23:22:05 1997
+@@ -1,6 +1,6 @@
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <ctype.h>
+-#include <malloc.h>
+ #include <string.h>
+ #include <aalib.h>
+ #include "shrink.h"
+@@ -56,15 +56,15 @@
+ static void selectsupported(aa_context * c)
+ {
+ int supported = 0;
+- if (c->driver->params.supported & AA_NORMAL_MASK)
++ if (c->params.supported & AA_NORMAL_MASK)
+ supported |= yesno(0, 0, "May I use normal text? ") ? AA_NORMAL_MASK : 0;
+- if (c->driver->params.supported & AA_DIM_MASK)
++ if (c->params.supported & AA_DIM_MASK)
+ supported |= yesno(0, 1, "May I use half bright(dim)? ") ? AA_DIM_MASK : 0;
+- if (c->driver->params.supported & AA_BOLD_MASK)
++ if (c->params.supported & AA_BOLD_MASK)
+ supported |= yesno(0, 2, "May I use bold as double bright?") ? AA_BOLD_MASK : 0;
+- if (c->driver->params.supported & AA_BOLDFONT_MASK)
++ if (c->params.supported & AA_BOLDFONT_MASK)
+ supported |= yesno(0, 3, "May I use bold as bold font? ") ? AA_BOLDFONT_MASK : 0;
+- if (c->driver->params.supported & AA_REVERSE_MASK)
++ if (c->params.supported & AA_REVERSE_MASK)
+ supported |= yesno(0, 4, "May I use reversed text? ") ? AA_REVERSE_MASK : 0;
+ aa_setsupported(c, supported);
+ }
+--- asciiview.orig Thu Dec 18 23:25:19 1997
++++ asciiview Thu Dec 18 23:25:29 1997
+@@ -1,3 +1,4 @@
++#!/bin/sh
+ # asciiview - an ascii art image browser script. Front end for aview/aaflip
+ clear()
+ {
diff --git a/graphics/aview/pkg-comment b/graphics/aview/pkg-comment
new file mode 100644
index 000000000000..486f041272e4
--- /dev/null
+++ b/graphics/aview/pkg-comment
@@ -0,0 +1 @@
+Graphics viewer using aalib.
diff --git a/graphics/aview/pkg-descr b/graphics/aview/pkg-descr
new file mode 100644
index 000000000000..4cad95303088
--- /dev/null
+++ b/graphics/aview/pkg-descr
@@ -0,0 +1,16 @@
+Aview is powerful graphics viewer which utilize the aalib API and allows
+viewing netpbm format (and others in the presence of netpbm or ImageMagick)
+on console (using slang) and X.
+There are three programs.
+
+aview: the main program which could used to view pnm, ppm, pgm and pbm
+ files. It runs under X or slang.
+
+asciiview: a shell script wraps around aview to allow wider range of image
+ formats to be viewed. Netpbm package is required for the conversion.
+
+aaflip: a program to view flip animation using ascii text. Works under X
+ and slang.
+
+You could press h to get help. You may also save the pics in various text
+format. Thanks to aalib!
diff --git a/graphics/aview/pkg-plist b/graphics/aview/pkg-plist
new file mode 100644
index 000000000000..2cc47c94aeb0
--- /dev/null
+++ b/graphics/aview/pkg-plist
@@ -0,0 +1,3 @@
+bin/aview
+bin/asciiview
+bin/aaflip