aboutsummaryrefslogtreecommitdiff
path: root/graphics/ayam
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-04-08 11:06:33 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-04-08 11:06:33 +0000
commit7564064d3ea81d3866603538bd09ecf629a2c72e (patch)
tree62973b64c3461b57ce66f003cc9c344f111c1693 /graphics/ayam
parenta12b9b1240714b5927cba6341200833161192c9d (diff)
downloadports-7564064d3ea81d3866603538bd09ecf629a2c72e.tar.gz
ports-7564064d3ea81d3866603538bd09ecf629a2c72e.zip
- Update to 1.14
Approved by: miwi (mentor)
Notes
Notes: svn path=/head/; revision=210841
Diffstat (limited to 'graphics/ayam')
-rw-r--r--graphics/ayam/Makefile3
-rw-r--r--graphics/ayam/distinfo6
-rw-r--r--graphics/ayam/files/patch-Makefile.shared15
-rw-r--r--graphics/ayam/files/patch-ayam.c362
-rw-r--r--graphics/ayam/files/patch-aycore_shader.c24
-rw-r--r--graphics/ayam/pkg-plist8
6 files changed, 21 insertions, 397 deletions
diff --git a/graphics/ayam/Makefile b/graphics/ayam/Makefile
index a609e1cc4ca5..00f23ddb15ce 100644
--- a/graphics/ayam/Makefile
+++ b/graphics/ayam/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ayam
-PORTVERSION= 1.13
-PORTREVISION= 2
+PORTVERSION= 1.14
CATEGORIES= graphics
MASTER_SITES= SF
DISTNAME= ${PORTNAME}${PORTVERSION}.src
diff --git a/graphics/ayam/distinfo b/graphics/ayam/distinfo
index b5e783236d1d..3638b8b26e41 100644
--- a/graphics/ayam/distinfo
+++ b/graphics/ayam/distinfo
@@ -1,3 +1,3 @@
-MD5 (ayam1.13.src.tar.gz) = 64dcb78ebbdc53ff2394da3372f10435
-SHA256 (ayam1.13.src.tar.gz) = 798fc893024fe0af46ce3ea9551c3e04f3f649e392e4707f6e879c10fe7b6236
-SIZE (ayam1.13.src.tar.gz) = 3309549
+MD5 (ayam1.14.src.tar.gz) = 070cac2c38095ffa6d40b013fde4f6db
+SHA256 (ayam1.14.src.tar.gz) = a232f81f04fab96550b07ada6d62db226defcd63bb0449c255eb924a5dbfff41
+SIZE (ayam1.14.src.tar.gz) = 3591151
diff --git a/graphics/ayam/files/patch-Makefile.shared b/graphics/ayam/files/patch-Makefile.shared
index 1d1352626d44..a50576eda47b 100644
--- a/graphics/ayam/files/patch-Makefile.shared
+++ b/graphics/ayam/files/patch-Makefile.shared
@@ -1,5 +1,5 @@
---- Makefile.shared.orig 2007-09-21 13:30:36.000000000 +0200
-+++ Makefile.shared 2007-12-17 18:17:51.000000000 +0100
+--- Makefile.shared.orig 2008-04-03 20:21:22.000000000 +0200
++++ Makefile.shared 2008-04-07 12:09:04.000000000 +0200
@@ -4,7 +4,7 @@
# Makefile for Ayam (shared version)
@@ -179,12 +179,15 @@
# Ayslc Plugin (BMRT)
AYSLCINCDIR = $(BMRTDIR)/include
-@@ -489,7 +498,7 @@
+@@ -496,9 +505,9 @@
.cpp.o:
- $(CXX) -c $(CFLAGS) $*.cpp -o $@ -I. -IMF3D $(TOGLINC) $(TCLINC) $(TKINC) $(BMRTINC) $(GLINC) $(AFFINEINC) $(AQSISINC) -I$(OPENCSGINCDIR) -I$(GLEWINCDIR) -Iplugins
+ $(CXX) -c $(CFLAGS) $*.cpp -o $@ $(AYINC) -I$(OPENCSGINCDIR) -I$(GLEWINCDIR) -Iplugins
--all: ayamsh csphere.so mfio.so metaobj.so mopsi.so
-+all: ayamsh csphere.so mfio.so metaobj.so mopsi.so ayslx.so
+-all: ayamsh
++all: ayamsh plugins
+
+-plugins: csphere.so mfio.so metaobj.so mopsi.so
++plugins: csphere.so mfio.so metaobj.so mopsi.so ayslx.so
ayamsh: $(AYAMOBJS) $(TOGLOBJECT) $(AFFINEOBJS)
$(LD) $(AYAMOBJS) $(TOGLOBJECT) $(EXLDFLAGS) -o ayamsh $(TKLIB) $(TCLLIB) $(GLLIBS) $(X11LIBS) $(RIBOUTLIB) $(AQSISRI2RIB) $(SLCARGSLIB) $(AFFINEOBJS) $(AQSISOBJS) $(TIFFLIB) -lm $(DL)
diff --git a/graphics/ayam/files/patch-ayam.c b/graphics/ayam/files/patch-ayam.c
index d7fb5b6b0542..80965735d829 100644
--- a/graphics/ayam/files/patch-ayam.c
+++ b/graphics/ayam/files/patch-ayam.c
@@ -1,367 +1,5 @@
--- ayam.c.orig 2007-09-21 13:30:36.000000000 +0200
+++ ayam.c 2007-12-17 19:12:10.000000000 +0100
-@@ -598,227 +598,227 @@
-
- /* aycsg.cpp */
- #ifdef AYCSGWRAPPED
-- Tcl_CreateCommand(interp, "aycsgInit", aycsg_inittcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "aycsgInit", (Tcl_CmdProc *)aycsg_inittcmd,
-+ NULL, NULL);
- #endif
-
- /* clear.c */
-- Tcl_CreateCommand(interp, "newScene", ay_clear_scenetcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "newScene", (Tcl_CmdProc *)ay_clear_scenetcmd,
-+ NULL, NULL);
-
- /* clevel.c */
-- Tcl_CreateCommand(interp, "goTop", ay_clevel_gotoptcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "goTop", (Tcl_CmdProc *)ay_clevel_gotoptcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "goUp", ay_clevel_gouptcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "goUp", (Tcl_CmdProc *)ay_clevel_gouptcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "goDown", ay_clevel_godowntcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "goDown", (Tcl_CmdProc *)ay_clevel_godowntcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "getLevel", ay_clevel_gettcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "getLevel", (Tcl_CmdProc *)ay_clevel_gettcmd,
-+ NULL, NULL);
-
- /* clipb.c */
-- Tcl_CreateCommand(interp, "copOb", ay_clipb_copytcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "copOb", (Tcl_CmdProc *)ay_clipb_copytcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "cutOb", ay_clipb_cuttcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "cutOb", (Tcl_CmdProc *)ay_clipb_cuttcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "pasOb", ay_clipb_pastetcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "pasOb", (Tcl_CmdProc *)ay_clipb_pastetcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "cmovOb", ay_clipb_movetcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "cmovOb", (Tcl_CmdProc *)ay_clipb_movetcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "repOb", ay_clipb_replacetcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "repOb", (Tcl_CmdProc *)ay_clipb_replacetcmd,
-+ NULL, NULL);
-
- /* conv.c */
-- Tcl_CreateCommand(interp, "convOb", ay_convert_forcetcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "convOb", (Tcl_CmdProc *)ay_convert_forcetcmd,
-+ NULL, NULL);
-
- /* draw.c */
-
- /* error.c */
-- Tcl_CreateCommand(interp, "ayError", ay_error_tcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "ayError", (Tcl_CmdProc *)ay_error_tcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "getGLErr", ay_error_getglerrortcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "getGLErr", (Tcl_CmdProc *)ay_error_getglerrortcmd,
-+ NULL, NULL);
-
- /* instt.c */
-- Tcl_CreateCommand(interp, "resolveIn", ay_instt_resolvetcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "resolveIn", (Tcl_CmdProc *)ay_instt_resolvetcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "getMaster", ay_instt_getmastertcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "getMaster", (Tcl_CmdProc *)ay_instt_getmastertcmd,
-+ NULL, NULL);
-
- /* notify.c */
-- Tcl_CreateCommand(interp, "forceNot", ay_notify_forcetcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "forceNot", (Tcl_CmdProc *)ay_notify_forcetcmd,
-+ NULL, NULL);
-
- /* object.c */
-- Tcl_CreateCommand(interp, "crtOb", ay_object_createtcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "crtOb", (Tcl_CmdProc *)ay_object_createtcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "delOb", ay_object_deletetcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "delOb", (Tcl_CmdProc *)ay_object_deletetcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "nameOb", ay_object_setnametcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "nameOb", (Tcl_CmdProc *)ay_object_setnametcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "hasChild", ay_object_haschildtcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "hasChild", (Tcl_CmdProc *)ay_object_haschildtcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "getType", ay_object_gettypetcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "getType", (Tcl_CmdProc *)ay_object_gettypetcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "getName", ay_object_getnametcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "getName", (Tcl_CmdProc *)ay_object_getnametcmd,
-+ NULL, NULL);
-
- /* pomesht.c */
-- Tcl_CreateCommand(interp, "mergePo", ay_pomesht_mergetcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-- Tcl_CreateCommand(interp, "optiPo", ay_pomesht_optimizetcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-- Tcl_CreateCommand(interp, "splitPo", ay_pomesht_splittcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "mergePo", (Tcl_CmdProc *)ay_pomesht_mergetcmd,
-+ NULL, NULL);
-+ Tcl_CreateCommand(interp, "optiPo", (Tcl_CmdProc *)ay_pomesht_optimizetcmd,
-+ NULL, NULL);
-+ Tcl_CreateCommand(interp, "splitPo", (Tcl_CmdProc *)ay_pomesht_splittcmd,
-+ NULL, NULL);
-
- /* prop.c */
-- Tcl_CreateCommand(interp, "setProp", ay_prop_settcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "setProp", (Tcl_CmdProc *)ay_prop_settcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "getProp", ay_prop_gettcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "getProp", (Tcl_CmdProc *)ay_prop_gettcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "setTrafo", ay_prop_settrafotcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "setTrafo", (Tcl_CmdProc *)ay_prop_settrafotcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "getTrafo", ay_prop_gettrafotcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "getTrafo", (Tcl_CmdProc *)ay_prop_gettrafotcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "setAttr", ay_prop_setattrtcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "setAttr", (Tcl_CmdProc *)ay_prop_setattrtcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "getAttr", ay_prop_getattrtcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "getAttr", (Tcl_CmdProc *)ay_prop_getattrtcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "setMat", ay_prop_setmattcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "setMat", (Tcl_CmdProc *)ay_prop_setmattcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "getMat", ay_prop_getmattcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "getMat", (Tcl_CmdProc *)ay_prop_getmattcmd,
-+ NULL, NULL);
-
- /* prefs.c */
-- Tcl_CreateCommand(interp, "setPrefs", ay_prefs_settcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "setPrefs", (Tcl_CmdProc *)ay_prefs_settcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "getPrefs", ay_prefs_gettcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "getPrefs", (Tcl_CmdProc *)ay_prefs_gettcmd,
-+ NULL, NULL);
-
- /* read.c */
-- Tcl_CreateCommand(interp, "replaceScene", ay_read_replacetcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "replaceScene", (Tcl_CmdProc *)ay_read_replacetcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "insertScene", ay_read_inserttcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "insertScene", (Tcl_CmdProc *)ay_read_inserttcmd,
-+ NULL, NULL);
-
-
- /* sel.c */
-- Tcl_CreateCommand(interp, "selOb", ay_sel_setfromlbtcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "selOb", (Tcl_CmdProc *)ay_sel_setfromlbtcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "getSel", ay_sel_getseltcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "getSel", (Tcl_CmdProc *)ay_sel_getseltcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "hSL", ay_sel_hsltcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "hSL", (Tcl_CmdProc *)ay_sel_hsltcmd,
-+ NULL, NULL);
-
-
- /* shader.c */
-- Tcl_CreateCommand(interp, "shaderScanSLC", ay_shader_scanslctcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "shaderScanSLC", (Tcl_CmdProc *)ay_shader_scanslctcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "shaderScanSLX", ay_shader_scanslxtcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "shaderScanSLX", (Tcl_CmdProc *)ay_shader_scanslxtcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "shaderSet", ay_shader_settcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "shaderSet", (Tcl_CmdProc *)ay_shader_settcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "shaderGet", ay_shader_gettcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "shaderGet", (Tcl_CmdProc *)ay_shader_gettcmd,
-+ NULL, NULL);
-
- /* tags.c */
-- Tcl_CreateCommand(interp, "tagIsTemp", ay_tags_istemptcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-- Tcl_CreateCommand(interp, "setTags", ay_tags_settcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-- Tcl_CreateCommand(interp, "addTag", ay_tags_addtcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-- Tcl_CreateCommand(interp, "getTags", ay_tags_gettcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-- Tcl_CreateCommand(interp, "delTags", ay_tags_deletetcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "tagIsTemp", (Tcl_CmdProc *)ay_tags_istemptcmd,
-+ NULL, NULL);
-+ Tcl_CreateCommand(interp, "setTags", (Tcl_CmdProc *)ay_tags_settcmd,
-+ NULL, NULL);
-+ Tcl_CreateCommand(interp, "addTag", (Tcl_CmdProc *)ay_tags_addtcmd,
-+ NULL, NULL);
-+ Tcl_CreateCommand(interp, "getTags", (Tcl_CmdProc *)ay_tags_gettcmd,
-+ NULL, NULL);
-+ Tcl_CreateCommand(interp, "delTags", (Tcl_CmdProc *)ay_tags_deletetcmd,
-+ NULL, NULL);
-
- /* tcmd.c */
-- Tcl_CreateCommand(interp, "revert", ay_tcmd_reverttcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "revert", (Tcl_CmdProc *)ay_tcmd_reverttcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "show", ay_tcmd_showtcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "show", (Tcl_CmdProc *)ay_tcmd_showtcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "hide", ay_tcmd_hidetcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "hide", (Tcl_CmdProc *)ay_tcmd_hidetcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "getVersion", ay_tcmd_getvertcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "getVersion", (Tcl_CmdProc *)ay_tcmd_getvertcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "getPnt", ay_tcmd_getpointtcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "getPnt", (Tcl_CmdProc *)ay_tcmd_getpointtcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "setPnt", ay_tcmd_setpointtcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "setPnt", (Tcl_CmdProc *)ay_tcmd_setpointtcmd,
-+ NULL, NULL);
-
- #ifdef AYENABLEWAIT
-- Tcl_CreateCommand(interp, "waitPid", ay_tcmd_waitpidtcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "waitPid", (Tcl_CmdProc *)ay_tcmd_waitpidtcmd,
-+ NULL, NULL);
- #endif /* AYENABLEWAIT */
-
- #ifdef AYENABLEFEXIT
-- Tcl_CreateCommand(interp, "fastExit", ay_tcmd_fastexittcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "fastExit", (Tcl_CmdProc *)ay_tcmd_fastexittcmd,
-+ NULL, NULL);
- #endif /* AYENABLEFEXIT */
-
-- Tcl_CreateCommand(interp, "withOb", ay_tcmd_withobtcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "withOb", (Tcl_CmdProc *)ay_tcmd_withobtcmd,
-+ NULL, NULL);
-
- /* tmp.c */
-- Tcl_CreateCommand(interp, "tmpGet", ay_tmp_gettcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "tmpGet", (Tcl_CmdProc *)ay_tmp_gettcmd,
-+ NULL, NULL);
-
- /* trafo.c */
-- Tcl_CreateCommand(interp, "delegTrafo", ay_trafo_delegatetcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "delegTrafo", (Tcl_CmdProc *)ay_trafo_delegatetcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "movOb", ay_trafo_movobtcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "movOb", (Tcl_CmdProc *)ay_trafo_movobtcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "movSel", ay_trafo_movseltcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "movSel", (Tcl_CmdProc *)ay_trafo_movseltcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "scalOb", ay_trafo_scalobtcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "scalOb", (Tcl_CmdProc *)ay_trafo_scalobtcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "scalSel", ay_trafo_scalseltcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "scalSel", (Tcl_CmdProc *)ay_trafo_scalseltcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "rotOb", ay_trafo_rotobtcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "rotOb", (Tcl_CmdProc *)ay_trafo_rotobtcmd,
-+ NULL, NULL);
-
-- Tcl_CreateCommand(interp, "rotSel", ay_trafo_rotseltcmd,
-- (ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
-+ Tcl_CreateCommand(interp, "rotSel", (Tcl_CmdProc *)ay_trafo_rotseltcmd,
-+ NULL, NULL);
-
- /* oact.c */
- Togl_CreateCommand("moveoac", ay_oact_movetcb);
@@ -842,8 +842,8 @@
/* objsel.c */
Togl_CreateCommand("processObjSel", ay_objsel_processcb);
diff --git a/graphics/ayam/files/patch-aycore_shader.c b/graphics/ayam/files/patch-aycore_shader.c
index c751437dc20c..477bf7e5e11d 100644
--- a/graphics/ayam/files/patch-aycore_shader.c
+++ b/graphics/ayam/files/patch-aycore_shader.c
@@ -9,30 +9,6 @@
#else
/* change all ; to : in shader search path */
Tcl_DStringInit(&ds);
-@@ -415,7 +415,11 @@
- }
-
- /* XXXX temporarily discard array arguments */
-+#ifdef AYAQSIS10
- if(symbol->svd_arraylen < 1)
-+#else
-+ if(symbol->svd_arraylen < 2)
-+#endif
- {
-
- Tcl_DStringAppend(&ds, "{ ", -1);
-@@ -450,7 +454,10 @@
- break;
- }
-
-- arraylen = symbol->svd_arraylen;
-+ arraylen = symbol->svd_arraylen-1;
-+#ifdef AYAQSIS10
-+ arraylen++;
-+#endif
- sprintf(buffer, "%d ", arraylen);
- Tcl_DStringAppend(&ds, buffer, -1);
-
@@ -1094,7 +1094,8 @@
ay_mat_object *material = NULL;
ay_shader *newshader = NULL, **shader = NULL;
diff --git a/graphics/ayam/pkg-plist b/graphics/ayam/pkg-plist
index f589d7416cda..9d67d08ea453 100644
--- a/graphics/ayam/pkg-plist
+++ b/graphics/ayam/pkg-plist
@@ -11,6 +11,7 @@ lib/ayam/mfio.tcl
lib/ayam/mfio.so
lib/ayam/tcl/about.tcl
lib/ayam/tcl/action.tcl
+lib/ayam/tcl/acurve.tcl
lib/ayam/tcl/ai.tcl
lib/ayam/tcl/ayam.tcl
lib/ayam/tcl/balloon.tcl
@@ -31,6 +32,7 @@ lib/ayam/tcl/control.tcl
lib/ayam/tcl/cylinder.tcl
lib/ayam/tcl/disk.tcl
lib/ayam/tcl/extrnc.tcl
+lib/ayam/tcl/extrnp.tcl
lib/ayam/tcl/extrude.tcl
lib/ayam/tcl/gordon.tcl
lib/ayam/tcl/hyperb.tcl
@@ -48,6 +50,7 @@ lib/ayam/tcl/ncurve.tcl
lib/ayam/tcl/npatch.tcl
lib/ayam/tcl/objbar.tcl
lib/ayam/tcl/objsel.tcl
+lib/ayam/tcl/offnc.tcl
lib/ayam/tcl/olb.tcl
lib/ayam/tcl/pamesh.tcl
lib/ayam/tcl/pane.tcl
@@ -68,12 +71,14 @@ lib/ayam/tcl/root.tcl
lib/ayam/tcl/run.tcl
lib/ayam/tcl/script.tcl
lib/ayam/tcl/sdmesh.tcl
+lib/ayam/tcl/select.tcl
lib/ayam/tcl/shader.tcl
lib/ayam/tcl/shortcut.tcl
lib/ayam/tcl/skin.tcl
lib/ayam/tcl/sphere.tcl
lib/ayam/tcl/splash.tcl
lib/ayam/tcl/sweep.tcl
+lib/ayam/tcl/swing.tcl
lib/ayam/tcl/tc.tcl
lib/ayam/tcl/text.tcl
lib/ayam/tcl/tgui.tcl
@@ -203,6 +208,7 @@ lib/ayam/tcl/BWidget-1.2.1/lang/fr.rc
%%PORTDOCS%%%%DOCSDIR%%/html/pics/meta.gif
%%PORTDOCS%%%%DOCSDIR%%/html/pics/multip.gif
%%PORTDOCS%%%%DOCSDIR%%/html/pics/ncircle.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/pics/offnc.gif
%%PORTDOCS%%%%DOCSDIR%%/html/pics/plotcur.gif
%%PORTDOCS%%%%DOCSDIR%%/html/pics/prefs.gif
%%PORTDOCS%%%%DOCSDIR%%/html/pics/primitives.gif
@@ -216,6 +222,8 @@ lib/ayam/tcl/BWidget-1.2.1/lang/fr.rc
%%PORTDOCS%%%%DOCSDIR%%/html/pics/splitnc.gif
%%PORTDOCS%%%%DOCSDIR%%/html/pics/ssweep.gif
%%PORTDOCS%%%%DOCSDIR%%/html/pics/sweep.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/pics/swin.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/pics/swing.gif
%%PORTDOCS%%%%DOCSDIR%%/html/pics/tce.gif
%%PORTDOCS%%%%DOCSDIR%%/html/pics/text-ayam.gif
%%PORTDOCS%%%%DOCSDIR%%/html/pics/tgui.gif