aboutsummaryrefslogtreecommitdiff
path: root/graphics/blender
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2007-08-07 17:06:36 +0000
committerBeech Rintoul <beech@FreeBSD.org>2007-08-07 17:06:36 +0000
commit8478b53c18f69edde8e32beda8f8b7541d2968e8 (patch)
tree21a784049f2ac3669cd87523c896f4b47f8500af /graphics/blender
parent05bebba99d64db456a01beb7d910832ae3003e27 (diff)
downloadports-8478b53c18f69edde8e32beda8f8b7541d2968e8.tar.gz
ports-8478b53c18f69edde8e32beda8f8b7541d2968e8.zip
- Update to 2.44.1
- Add options PR: ports/115026 Submitted by: David Yeske <dyeske@gmail.com> Approved by: sat (mentor)
Notes
Notes: svn path=/head/; revision=197302
Diffstat (limited to 'graphics/blender')
-rw-r--r--graphics/blender/Makefile96
-rw-r--r--graphics/blender/distinfo6
-rw-r--r--graphics/blender/files/patch-source_blender_blenlib_intern-storage.c20
-rw-r--r--graphics/blender/files/patch-source_nan_definitions.mk31
-rw-r--r--graphics/blender/files/patch-user-def.mk77
-rw-r--r--graphics/blender/pkg-descr10
-rw-r--r--graphics/blender/pkg-plist15
7 files changed, 199 insertions, 56 deletions
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index 22249fd87819..2ffd7f931d23 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -3,48 +3,84 @@
# Whom: Jimmy Olgeni <olgeni@uli.it>
#
# $FreeBSD$
-#
PORTNAME= blender
-PORTVERSION= 2.25
-PORTREVISION= 3
+PORTVERSION= 2.44.1
CATEGORIES= graphics games
-MASTER_SITES= http://download.blender.org/release/Publisher${PORTVERSION}/
-DISTNAME= blender-publisher-${PORTVERSION}-freebsd-4.2-i386
-DIST_SUBDIR= blender
+MASTER_SITES= CENKES
MAINTAINER= dyeske@gmail.com
-COMMENT= Fully functional 3D modeling/rendering/animation/gaming package
+COMMENT= 3D modeling/rendering/animation/gaming package
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ png.5:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ SDL.11:${PORTSDIR}/devel/sdl12 \
+ Half.4:${PORTSDIR}/graphics/OpenEXR \
+ openal.0:${PORTSDIR}/audio/openal \
+ alut.1:${PORTSDIR}/audio/freealut \
+ avutil.1:${PORTSDIR}/multimedia/ffmpeg
-LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+CONFLICTS= blender-devel-[0-9]*
+PLIST_FILES= bin/blender
+USE_XORG= x11 xext xmu xi
+USE_GETTEXT= yes
+USE_PYTHON= 2.5+
+USE_SDL= sdl
+USE_GL= gl glu
+USE_GMAKE= yes
-USE_X_PREFIX= YES
-NO_BUILD= YES
-ONLY_FOR_ARCHS= i386
+PORTDOCS= README bf-members.txt blender-scons.txt python-dev-guide.txt \
+ blender-cmake.txt blender-guardedalloc.txt \
+ interface_API.txt blender-scons-dev.txt oldbugs.txt
+
+OPTIONS= OCFLAGS "With Optimized Cflags" off \
+ NOPORTDOCS "Don't Install Docs" off
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500000
-LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
+MAKE_ENV+= NAN_CPPFLAGS="-I${LOCALBASE}/include/freetype2 \
+ -I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/OpenEXR \
+ -I${PYTHON_INCLUDEDIR}"
+MAKE_ENV+= NAN_FREETYPE="${LOCALBASE}"
+MAKE_ENV+= NAN_OPENEXR="${LOCALBASE}"
+MAKE_ENV+= WITH_BF_BLENDERPLAYER="false"
+
+.if defined(WITH_OCFLAGS)
+CFLAGS+= -O3 -ffast-math
.endif
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|sdl11-config|${SDL_CONFIG}|; \
+ s|2.3|${PYTHON_VER}|' \
+ ${WRKSRC}/source/nan_definitions.mk
+
+ @${REINPLACE_CMD} -e \
+ 's|gcc|${CC}|; \
+ s|g++|${CXX}|; \
+ s|-pipe||; \
+ s|-O2|${CFLAGS}|; \
+ s|-D_THREAD_SAFE|${PTHREAD_CFLAGS}|; \
+ s|/usr/X11R6|${X11BASE}|' \
+ ${WRKSRC}/source/nan_compile.mk
+
+ @${REINPLACE_CMD} -e \
+ 's|-lc_r||; \
+ s|-pthread|-lintl -lIlmThread ${PTHREAD_LIBS}|' \
+ ${WRKSRC}/source/nan_link.mk
+
+ @${REINPLACE_CMD} -e \
+ 's|-FIX_NAN_WARN||' \
+ ${WRKSRC}/source/nan_warn.mk
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/blenderplayer ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/blenderpublisher ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/share/doc/blender
- ${MKDIR} ${PREFIX}/lib/blender/plugins/texture \
- ${PREFIX}/lib/blender/plugins/sequence
-.for SEQ in blur.so scatter.so showzbuf.so
- ${INSTALL_PROGRAM} ${WRKSRC}/plugins/sequence/${SEQ} \
- ${PREFIX}/lib/blender/plugins/sequence
-.endfor
-.for TEXT in clouds2.so tiles.so
- ${INSTALL_PROGRAM} ${WRKSRC}/plugins/texture/${TEXT} \
- ${PREFIX}/lib/blender/plugins/texture
-.endfor
- ${MKDIR} ${PREFIX}/share/doc/blender
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/blender
- ${INSTALL_DATA} ${WRKSRC}/copyright.txt ${PREFIX}/share/doc/blender
- ${INSTALL_DATA} ${WRKSRC}/playerlicense.txt ${PREFIX}/share/doc/blender
+ @${INSTALL_PROGRAM} ${WRKSRC}/obj/freebsd/bin/blender ${PREFIX}/bin
+.if !defined(WITH_NOPORTDOCS)
+ @${MV} ${WRKSRC}/README ${WRKSRC}/doc/
+ @${INSTALL} -d ${DOCSDIR}/
+ @cd ${WRKSRC}/doc/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
+.endif
.include <bsd.port.post.mk>
diff --git a/graphics/blender/distinfo b/graphics/blender/distinfo
index 9680c25c94ad..23c54fc6e341 100644
--- a/graphics/blender/distinfo
+++ b/graphics/blender/distinfo
@@ -1,3 +1,3 @@
-MD5 (blender/blender-publisher-2.25-freebsd-4.2-i386.tar.gz) = a6945dac70322b3ccface8bc8c4e0d6a
-SHA256 (blender/blender-publisher-2.25-freebsd-4.2-i386.tar.gz) = 8a3252178a12c619fe75fe401bd2570c46a9740d708cfb5800115c48bc9712b5
-SIZE (blender/blender-publisher-2.25-freebsd-4.2-i386.tar.gz) = 3007810
+MD5 (blender-2.44.1.tar.gz) = 926d6ca3f0b1b4aeaa75a2b1767dc2a3
+SHA256 (blender-2.44.1.tar.gz) = 8d682ece9ce8ef15cffb5bb16e9099b11bef4c0eb3efae9b352853d58406b317
+SIZE (blender-2.44.1.tar.gz) = 14743807
diff --git a/graphics/blender/files/patch-source_blender_blenlib_intern-storage.c b/graphics/blender/files/patch-source_blender_blenlib_intern-storage.c
new file mode 100644
index 000000000000..d8f979bdbf3b
--- /dev/null
+++ b/graphics/blender/files/patch-source_blender_blenlib_intern-storage.c
@@ -0,0 +1,20 @@
+--- source/blender/blenlib/intern/storage.c.orig Sun Mar 19 14:28:01 2006
++++ source/blender/blenlib/intern/storage.c Mon Aug 21 23:50:20 2006
+@@ -50,7 +50,7 @@
+ #include <time.h>
+ #include <sys/stat.h>
+
+-#if !defined(linux) && (defined(__sgi) || defined(__sun__) || defined(__sun) || defined(__sparc) || defined(__sparc__))
++#if !defined(__FreeBSD__) && !defined(linux) && (defined(__sgi) || defined(__sun__) || defined(__sun) || defined(__sparc) || defined(__sparc__))
+ #include <sys/statfs.h>
+ #endif
+
+@@ -196,7 +196,7 @@
+ #ifdef __BeOS
+ return -1;
+ #endif
+-#if !defined(linux) && (defined (__sgi) || defined (__sun__) || defined (__sun) || defined(__sparc) || defined(__sparc__))
++#if !defined(__FreeBSD__) && !defined(linux) && (defined (__sgi) || defined (__sun__) || defined (__sun) || defined(__sparc) || defined(__sparc__))
+
+ if (statfs(name, &disk, sizeof(struct statfs), 0)){
+ /* printf("diskfree: Couldn't get information about %s.\n",dir); */
diff --git a/graphics/blender/files/patch-source_nan_definitions.mk b/graphics/blender/files/patch-source_nan_definitions.mk
new file mode 100644
index 000000000000..81c41c1bb688
--- /dev/null
+++ b/graphics/blender/files/patch-source_nan_definitions.mk
@@ -0,0 +1,31 @@
+--- source/nan_definitions.mk.orig Wed Nov 22 11:05:35 2006
++++ source/nan_definitions.mk Wed Mar 21 21:24:37 2007
+@@ -55,9 +55,9 @@
+ export NAN_LIBDIR ?= $(NANBLENDERHOME)/../lib
+ export NAN_OBJDIR ?= $(NANBLENDERHOME)/obj
+ # Library Config_Guess DIRectory
+- export LCGDIR = $(NAN_LIBDIR)/$(CONFIG_GUESS)
++ export LCGDIR = $(NAN_LIBDIR)/freebsd
+ # Object Config_Guess DIRectory
+- export OCGDIR = $(NAN_OBJDIR)/$(CONFIG_GUESS)
++ export OCGDIR = $(NAN_OBJDIR)/freebsd
+
+ export NAN_MOTO ?= $(LCGDIR)/moto
+ ifeq ($(FREE_WINDOWS), true)
+@@ -132,7 +132,7 @@
+ export NAN_OPENEXR_LIBS ?= $(NAN_OPENEXR)/lib/libIlmImf.a $(NAN_OPENEXR)/lib/libHalf.a $(NAN_OPENEXR)/lib/libIex.a
+ else
+ export NAN_OPENEXR ?= /usr/local
+- export NAN_OPENEXR_LIBS ?= $(NAN_OPENEXR)/lib/libIlmImf.a $(NAN_OPENEXR)/lib/libHalf.a $(NAN_OPENEXR)/lib/libIex.a
++ export NAN_OPENEXR_LIBS ?= $(NAN_OPENEXR)/lib/libIlmImf.a $(NAN_OPENEXR)/lib/libIlmThread.a $(NAN_OPENEXR)/lib/libHalf.a $(NAN_OPENEXR)/lib/libIex.a
+ endif
+ endif
+ export NAN_OPENEXR_INC ?= -I$(NAN_OPENEXR)/include -I$(NAN_OPENEXR)/include/OpenEXR
+@@ -291,6 +291,7 @@
+
+ # enable freetype2 support for text objects
+ # export WITH_FREETYPE2 ?= true
++ export NAN_NO_KETSJI=true
+
+ else
+ ifeq ($(OS),irix)
diff --git a/graphics/blender/files/patch-user-def.mk b/graphics/blender/files/patch-user-def.mk
new file mode 100644
index 000000000000..cb48c86b7bae
--- /dev/null
+++ b/graphics/blender/files/patch-user-def.mk
@@ -0,0 +1,77 @@
+--- user-def.mk.orig 1969-12-31 14:00:00.000000000 -1000
++++ user-def.mk 2007-08-07 00:38:53.000000000 -0800
+@@ -0,0 +1,74 @@
++export NAN_DEBUG=-g
++
++export TYPE := $(shell echo `uname -s`)
++
++# Allow 64bit compiles.
++export NAN_YESIAMSTUPID=true
++
++ifeq ($(TYPE), SunOS)
++ export NAN_PYTHON=/usr/local
++ export NAN_PYTHON_VERSION=2.5
++ export NAN_OPENAL=/export/scratch/blender/src/openal/SunOS5.8
++ export NAN_JPEG=/usr/local
++ export NAN_PNG=/usr/local
++ export NAN_SDL=/usr/local
++ export NAN_SDLLIBS ?= $(shell $(NAN_SDL)/bin/sdl-config --libs) -lSDL_mixer
++ export NAN_OPENEXR=/usr/local
++ export NAN_OPENEXR_LIBS ?= $(NAN_OPENEXR)/lib/libIlmImf.a \
++ $(NAN_OPENEXR)/lib/libIlmThread.a \
++ $(NAN_OPENEXR)/lib/libHalf.a \
++ $(NAN_OPENEXR)/lib/libIex.a
++
++ export NAN_ZLIB=/usr/local
++ export NAN_FREETYPE=/usr/local
++ export NAN_MOZILLA_INC=/usr/local/include/mozilla-1.0.1/
++ export NAN_MOZILLA_LIB=/usr/local/lib/mozilla-1.0.1/
++ export NAN_NSPR=/export/scratch/blender/SunOS5.8
++ export NAN_GETTEXT=/opt/gnu
++ export WITH_FREETYPE2=true
++ export INTERNATIONAL=true
++ export EXPYTHON=true
++ export WITH_BF_GAMEPLAYER=true
++ export NAN_NO_PLUGIN=true
++# export NAN_NO_KETSJI=true
++ export WITH_FFMPEG=true
++# export NAN_FFMPEG=/export/scratch/blender/src/lib/solaris-2.8-sparc/ffmpeg
++ export NAN_ICONV_LIBS=-L/opt/gnu/lib -R/opt/gnu/lib -liconv
++ export WITH_ICONV=false
++else
++ export WITH_ICONV=false
++# export WITH_FFMPEG=true
++ export WITH_FFMPEG=false
++ export NAN_PYTHON=/usr/local
++ export NAN_PYTHON_VERSION=2.5
++ export NAN_OPENAL=/usr
++ export NAN_FMOD=/usr/local
++ export NAN_JPEG=/usr/local
++ export NAN_PNG=/usr/local
++ export WITH_OPENEXR=true
++# export NAN_OPENEXR=/usr/local
++ export NAN_OPENEXR=/usr/local
++ export NAN_OPENEXR_LIBS ?= $(NAN_OPENEXR)/lib/libIlmImf.a \
++ $(NAN_OPENEXR)/lib/libHalf.a \
++ $(NAN_OPENEXR)/lib/libIex.a
++
++# $(NAN_OPENEXR)/lib/libIlmThread.a \
++
++ export NAN_SDL=/export/scratch/blender/src/lib/linux-glibc2.2.5-i386/sdl
++ export NAN_ODE=/export/scratch/blender/src/blender/extern/ode/dist
++ export NAN_ZLIB=/usr/local
++# export NAN_FREETYPE=/usr
++ export NAN_MESA=/export/scratch/crap/Mesa-6.2.1
++ export NAN_MOZILLA_INC=/usr/include/mozilla/
++ export NAN_MOZILLA_LIB=/usr/lib/mozilla/
++ # I think it only needs includes so should be alright...
++ export NAN_NSPR=/export/scratch/blender/src/nspr-4.2.2/mozilla/nsprpub/dist
++
++ export WITH_FREETYPE2=true
++ export INTERNATIONAL=true
++ export NAN_NO_STATIC = true
++ export NAN_NO_PLUGIN=true
++endif
++
++export WITH_VERSE=true
++export WITH_BULLET=true
diff --git a/graphics/blender/pkg-descr b/graphics/blender/pkg-descr
index c242ccdc4419..6970edb1caac 100644
--- a/graphics/blender/pkg-descr
+++ b/graphics/blender/pkg-descr
@@ -1,10 +1,4 @@
Blender is a free and fully functional 3D
-modeling/rendering/animation/gaming package. Blender is distributed
-without sources, it is exclusively developed and maintained by the Dutch
-company NaN.
+modeling/rendering/animation/gaming package.
-This software is free to be applied for any purpose, excluding commercial
-distribution. For more about this, read the copyright notice included
-in the download file (share/doc/blender/copyright.txt).
-
-WWW: http://www.blender.org
+WWW: http://www.blender.org/
diff --git a/graphics/blender/pkg-plist b/graphics/blender/pkg-plist
deleted file mode 100644
index 8089029b9530..000000000000
--- a/graphics/blender/pkg-plist
+++ /dev/null
@@ -1,15 +0,0 @@
-bin/blenderplayer
-bin/blenderpublisher
-lib/blender/plugins/sequence/blur.so
-lib/blender/plugins/sequence/scatter.so
-lib/blender/plugins/sequence/showzbuf.so
-lib/blender/plugins/texture/clouds2.so
-lib/blender/plugins/texture/tiles.so
-share/doc/blender/README
-share/doc/blender/copyright.txt
-share/doc/blender/playerlicense.txt
-@dirrm share/doc/blender
-@dirrm lib/blender/plugins/sequence
-@dirrm lib/blender/plugins/texture
-@dirrm lib/blender/plugins
-@dirrm lib/blender