aboutsummaryrefslogtreecommitdiff
path: root/graphics/box
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-03-31 18:58:18 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-03-31 18:58:18 +0000
commitb318309bba3d8e223d3587d5e07fdae7993bf7dc (patch)
treec4e9e1115f2b1298266ae31a1e88e36bbbc192d9 /graphics/box
parent72683063d1adad91938b131c88bcc51b3c1be4ad (diff)
downloadports-b318309bba3d8e223d3587d5e07fdae7993bf7dc.tar.gz
ports-b318309bba3d8e223d3587d5e07fdae7993bf7dc.zip
- Fix license
- Switch to new test framework - Switch to options helpers
Notes
Notes: svn path=/head/; revision=412286
Diffstat (limited to 'graphics/box')
-rw-r--r--graphics/box/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/graphics/box/Makefile b/graphics/box/Makefile
index 237fa0efab50..26974926c67c 100644
--- a/graphics/box/Makefile
+++ b/graphics/box/Makefile
@@ -11,8 +11,8 @@ DIST_SUBDIR= box
MAINTAINER= ports@FreeBSD.org
COMMENT= Compiler for box, the figure description language
-LICENSE= GPLv2 LGPL3
-LICENSE_COMB= dual
+LICENSE= GPLv2+ LGPL3+
+LICENSE_COMB= multi
BUILD_DEPENDS= docbook-to-man:${PORTSDIR}/textproc/docbook-to-man
LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo
@@ -23,24 +23,23 @@ CONFIGURE_ARGS= --with-cairo
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE=yes
MAKE_ENV= INSTALL_STRIP_FLAG=${STRIP}
+TEST_TARGET= check
PORTDOCS= AUTHORS ChangeLog README STYLE
PORTEXAMPLES= *
-OPTIONS_DEFINE= DOCS EXAMPLES
+PLIST_SUB= PLIST_VER=${PORTVERSION:R}
-PLIST_SUB+= PLIST_VER=${PORTVERSION:R}
+OPTIONS_DEFINE= DOCS EXAMPLES
post-patch:
${TOUCH} ${WRKSRC}/man/${PORTNAME}.sgml
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+post-install-EXAMPLES-on:
@(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
-regression-test: build
- @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} check)
-
.include <bsd.port.mk>