aboutsummaryrefslogtreecommitdiff
path: root/graphics/cadubi
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-20 16:10:44 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-20 16:10:44 +0000
commit8cebaee266a7dbf82723fcf91bccf2a08dc73e06 (patch)
tree59d22d6bfea1a371159ebf7c46211c761b05c43a /graphics/cadubi
parentc513e3c18e708724c2f3b125b3029f6e6e5bc0c0 (diff)
downloadports-8cebaee266a7dbf82723fcf91bccf2a08dc73e06.tar.gz
ports-8cebaee266a7dbf82723fcf91bccf2a08dc73e06.zip
- Update to version 1.3
PR: ports/63137 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=101515
Diffstat (limited to 'graphics/cadubi')
-rw-r--r--graphics/cadubi/Makefile20
-rw-r--r--graphics/cadubi/distinfo4
-rw-r--r--graphics/cadubi/files/patch-CADUBI_pl32
-rw-r--r--graphics/cadubi/files/patch-cadubi9
-rw-r--r--graphics/cadubi/pkg-descr2
-rw-r--r--graphics/cadubi/pkg-plist9
6 files changed, 22 insertions, 54 deletions
diff --git a/graphics/cadubi/Makefile b/graphics/cadubi/Makefile
index 0517660c2f85..3b8f9a584045 100644
--- a/graphics/cadubi/Makefile
+++ b/graphics/cadubi/Makefile
@@ -6,25 +6,31 @@
#
PORTNAME= cadubi
-PORTVERSION= 1.2
+PORTVERSION= 1.3
CATEGORIES= graphics editors
-MASTER_SITES= ftp://ftp.dei.uc.pt/.raid1/linux/files/console/graphics/ \
- http://www.logicallemon.com/projects/cadubi/downloads/
-DISTNAME= ${PORTNAME}_${PORTVERSION}
+MASTER_SITES= http://langworth.com/downloads/
MAINTAINER= ports@FreeBSD.org
COMMENT= ASCII drawing utility
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey
+USE_PERL5= yes
NO_BUILD= yes
+do-configure:
+ @${PERL} -pi -e \
+ 's|Bin/help|Bin/../share/cadubi/help|g' ${WRKSRC}/cadubi
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/cadubi ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/CADUBI.pl ${PREFIX}/libexec
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/help.txt ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/logo.txt ${DATADIR}
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/cadubi
- ${INSTALL_DATA} ${WRKSRC}/CADUBI.help ${PREFIX}/share/doc/cadubi
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/extras/ansi_term_codes.txt ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/graphics/cadubi/distinfo b/graphics/cadubi/distinfo
index e55a01e6a2a5..a7b647613ffe 100644
--- a/graphics/cadubi/distinfo
+++ b/graphics/cadubi/distinfo
@@ -1,2 +1,2 @@
-MD5 (cadubi_1.2.tar.gz) = 53315c148dffda233f04ad83bafd20aa
-SIZE (cadubi_1.2.tar.gz) = 46347
+MD5 (cadubi-1.3.tar.gz) = e4ba1f6995bfdae8639341446782b859
+SIZE (cadubi-1.3.tar.gz) = 12559
diff --git a/graphics/cadubi/files/patch-CADUBI_pl b/graphics/cadubi/files/patch-CADUBI_pl
deleted file mode 100644
index d7bbb51fb3e3..000000000000
--- a/graphics/cadubi/files/patch-CADUBI_pl
+++ /dev/null
@@ -1,32 +0,0 @@
---- CADUBI.pl.orig Thu Jan 27 03:54:45 2000
-+++ CADUBI.pl Sun Jul 29 01:10:28 2001
-@@ -59,6 +59,7 @@ $AUDIBLE = 1; # beep unless -m, --mute
- $status_changed = 1; # used with &status so we don't constantly redraw.
- $current_filename = undef; # name of file we're working with
- $cadubi_done = 0; # main loop var
-+$Helpfile = $Bin . "/../share/doc/cadubi";
-
- # runtime statements
- &initKeys(); # setup %controlkeys and %keymap
-@@ -716,10 +717,10 @@ sub HandleKeystroke {
-
- # help
- if (ord($key) == $keymap{'^h'}) { #Help
-- if (-e $Bin.'/CADUBI.help') {
-+ if (-e $Helpfile.'/CADUBI.help') {
- my @oldmap = @charmap;
- my @oldpos = @pos;
-- &readfile($Bin.'/CADUBI.help');
-+ &readfile($Helpfile.'/CADUBI.help');
- &status('Press a key to continue...', 1);
- my $temp = ReadKey(0);
- @charmap = @oldmap;
-@@ -729,7 +730,7 @@ sub HandleKeystroke {
- &status;
- } else {
- &beep;
-- &status("'".$Bin."/CADUBI.help' not available");
-+ &status("'".$Helpfile."/CADUBI.help' not available");
- }
- return 0;
- }
diff --git a/graphics/cadubi/files/patch-cadubi b/graphics/cadubi/files/patch-cadubi
deleted file mode 100644
index ec1b8b9f05e0..000000000000
--- a/graphics/cadubi/files/patch-cadubi
+++ /dev/null
@@ -1,9 +0,0 @@
---- cadubi.orig Thu Jan 27 03:54:51 2000
-+++ cadubi Sun Jul 29 01:10:59 2001
-@@ -32,5 +32,5 @@ use FindBin qw($Bin); use lib "$Bin/../l
- my $CADUBI_Arguments = undef;
- $CADUBI_Arguments .= ' --mute' unless $AUDIBLE;
- $CADUBI_Arguments .= ' '.$ADD_OPS if $ADD_OPS;
--exec ('perl '.$Bin.'/CADUBI.pl'.$CADUBI_Arguments.' '.join(' ',@ARGV));
-+exec ('perl '.$Bin.'/../libexec/CADUBI.pl'.$CADUBI_Arguments.' '.join(' ',@ARGV));
-
diff --git a/graphics/cadubi/pkg-descr b/graphics/cadubi/pkg-descr
index 38efe47d5d3d..af165b59a57c 100644
--- a/graphics/cadubi/pkg-descr
+++ b/graphics/cadubi/pkg-descr
@@ -6,4 +6,4 @@ foreground colors, bold, and inverse. This text art, commonly
called "ASCII art," is used in various places such as online
BBSes, email and login prompts.
-WWW: http://www.logicallemon.com/projects/cadubi/
+WWW: http://langworth.com/CadubiProject
diff --git a/graphics/cadubi/pkg-plist b/graphics/cadubi/pkg-plist
index a2c4e769eac2..6286a23b54b7 100644
--- a/graphics/cadubi/pkg-plist
+++ b/graphics/cadubi/pkg-plist
@@ -1,4 +1,7 @@
bin/cadubi
-libexec/CADUBI.pl
-%%PORTDOCS%%share/doc/cadubi/CADUBI.help
-%%PORTDOCS%%@dirrm share/doc/cadubi
+%%DATADIR%%/help.txt
+%%DATADIR%%/logo.txt
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/ansi_term_codes.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%