aboutsummaryrefslogtreecommitdiff
path: root/graphics/cbview
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2004-06-17 06:36:55 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2004-06-17 06:36:55 +0000
commit1caec808be8e763ab041c8bafbebc69654acf0d3 (patch)
tree6de402c1f4b4ab64b7c661a8e2ec0d8a45b5091e /graphics/cbview
parent30afb3b9fd91dfdb208e1c2e4e43c2e368c6d879 (diff)
downloadports-1caec808be8e763ab041c8bafbebc69654acf0d3.tar.gz
ports-1caec808be8e763ab041c8bafbebc69654acf0d3.zip
CBView is a viewer/converter for CBR/CBZ comic book archives, written with
Notes
Notes: svn path=/head/; revision=111651
Diffstat (limited to 'graphics/cbview')
-rw-r--r--graphics/cbview/Makefile36
-rw-r--r--graphics/cbview/distinfo2
-rw-r--r--graphics/cbview/pkg-descr4
3 files changed, 42 insertions, 0 deletions
diff --git a/graphics/cbview/Makefile b/graphics/cbview/Makefile
new file mode 100644
index 000000000000..b01c267a7e69
--- /dev/null
+++ b/graphics/cbview/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: cbview
+# Date created: 05 May 2004
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cbview
+PORTVERSION= 0.06
+CATEGORIES= graphics
+MASTER_SITES= http://elvine.org/code/cbview/
+
+MAINTAINER= mezz@FreeBSD.org
+COMMENT= A viewer/converter for CBR/CBZ comic book archives
+
+RUN_DEPENDS= unrar:${PORTSDIR}/archivers/unrar \
+ unzip:${PORTSDIR}/archivers/unzip \
+ ${SITE_PERL}/${PERL_ARCH}/Gtk2.pm:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
+ ${SITE_PERL}/String/ShellQuote.pm:${PORTSDIR}/textproc/p5-String-ShellQuote
+
+NO_BUILD= yes
+USE_X_PREFIX= yes
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= COPYING Changes INSTALL README TODO
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/cbview/distinfo b/graphics/cbview/distinfo
new file mode 100644
index 000000000000..9535cb48e266
--- /dev/null
+++ b/graphics/cbview/distinfo
@@ -0,0 +1,2 @@
+MD5 (cbview-0.06.tar.gz) = 6f101dbcecc6d70f59a4b8cec4152446
+SIZE (cbview-0.06.tar.gz) = 16351
diff --git a/graphics/cbview/pkg-descr b/graphics/cbview/pkg-descr
new file mode 100644
index 000000000000..e69af595e220
--- /dev/null
+++ b/graphics/cbview/pkg-descr
@@ -0,0 +1,4 @@
+CBView is a viewer/converter for CBR/CBZ comic book archives, written with
+gtk2-perl.
+
+WWW: http://elvine.org/code/cbview/