aboutsummaryrefslogtreecommitdiff
path: root/graphics/chbg
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2002-03-27 16:29:49 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2002-03-27 16:29:49 +0000
commit542df3d748d087ff4ad81c6366edc16d672dc6e2 (patch)
tree595f964af6f6abeb35c10d7185213602103c48b5 /graphics/chbg
parent733c76ecd0fb70cb688b76a9e2593bcc094ecc38 (diff)
downloadports-542df3d748d087ff4ad81c6366edc16d672dc6e2.tar.gz
ports-542df3d748d087ff4ad81c6366edc16d672dc6e2.zip
- update to 1.5
- take over maintainership (old maintainer isn't reachable) - now buildable without GNOME too (WANT_GNOME) Approved by: steve
Notes
Notes: svn path=/head/; revision=56750
Diffstat (limited to 'graphics/chbg')
-rw-r--r--graphics/chbg/Makefile31
-rw-r--r--graphics/chbg/distinfo2
-rw-r--r--graphics/chbg/files/patch-ab13
-rw-r--r--graphics/chbg/files/patch-configure13
-rw-r--r--graphics/chbg/pkg-descr3
-rw-r--r--graphics/chbg/pkg-plist9
6 files changed, 46 insertions, 25 deletions
diff --git a/graphics/chbg/Makefile b/graphics/chbg/Makefile
index 788508c7d371..996bb55918c9 100644
--- a/graphics/chbg/Makefile
+++ b/graphics/chbg/Makefile
@@ -6,23 +6,42 @@
#
PORTNAME= chbg
-PORTVERSION= 1.2
-PORTREVISION= 1
+PORTVERSION= 1.5
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.idata.sk/~ondrej/sw/
MASTER_SITE_SUBDIR= ${PORTNAME}
EXTRACT_SUFX= .tgz
-MAINTAINER= p@dancris.com
+MAINTAINER= netchild@FreeBSD.org
+LIB_DEPENDS= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf/
+
+# GNOME parts aren't prefix safe, the get installed into "gnome-config --prefix"
USE_X_PREFIX= yes
-USE_GNOMECTRL= yes
+WANT_GNOME= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+.include <bsd.port.pre.mk>
+
+.if defined(HAVE_GNOME)
+USE_GNOMECTRL= yes
+.else
+USE_GTK= yes
+.endif
+
MAN1= chbg.1
-.include <bsd.port.mk>
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(GNOME_PREFIX\)/share/control-center|\$\(GNOME_PREFIX\)/share/gnome/control-center|g; \
+ s|\$\(GNOME_PREFIX\)/share/pixmaps|\$\(GNOME_PREFIX\)/share/gnome/pixmaps|g; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.post.mk>
diff --git a/graphics/chbg/distinfo b/graphics/chbg/distinfo
index 07caca199046..b0bb3c4628e7 100644
--- a/graphics/chbg/distinfo
+++ b/graphics/chbg/distinfo
@@ -1 +1 @@
-MD5 (chbg-1.2.tgz) = 2574812720db2ce2c007c7fd2781b86a
+MD5 (chbg-1.5.tgz) = 3ee8b01a7e089570f66d89dac353cc2c
diff --git a/graphics/chbg/files/patch-ab b/graphics/chbg/files/patch-ab
deleted file mode 100644
index 5a0ba7d5ae2f..000000000000
--- a/graphics/chbg/files/patch-ab
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.in 2000/12/18 17:14:56 1.1
-+++ Makefile.in 2000/12/18 17:15:24
-@@ -374,8 +374,8 @@
- if test -n "$(GNOME_PREFIX)"; then \
- $(mkinstalldirs) $(DESTDIR)$(GNOME_PREFIX)/share/gnome/apps/Graphics; \
- $(INSTALL_DATA) $(srcdir)/chbg.desktop $(DESTDIR)$(GNOME_PREFIX)/share/gnome/apps/Graphics; \
-- $(mkinstalldirs) $(DESTDIR)$(GNOME_PREFIX)/share/pixmaps; \
-- $(INSTALL_DATA) $(srcdir)/chbg_64x64.xpm $(DESTDIR)$(GNOME_PREFIX)/share/pixmaps; \
-+ $(mkinstalldirs) $(DESTDIR)$(GNOME_PREFIX)/share/gnome/pixmaps; \
-+ $(INSTALL_DATA) $(srcdir)/chbg_64x64.xpm $(DESTDIR)$(GNOME_PREFIX)/share/gnome/pixmaps; \
- fi
-
- uninstall-local:
diff --git a/graphics/chbg/files/patch-configure b/graphics/chbg/files/patch-configure
new file mode 100644
index 000000000000..746c87594704
--- /dev/null
+++ b/graphics/chbg/files/patch-configure
@@ -0,0 +1,13 @@
+--- configure.orig Sun Mar 24 14:42:24 2002
++++ configure Sun Mar 24 14:43:21 2002
+@@ -3259,8 +3259,8 @@
+ echo "$ac_t""no" 1>&6
+ fi
+
+- if eval "test x$GNOME_CONFIG = xyes"; then
+- GNOME_PREFIX=`gnome-config --prefix`
++ if eval "test x$GNOME_CONFIG != xno"; then
++ GNOME_PREFIX=`$GNOME_CONFIG --prefix`
+ echo "configure: warning: "Will install Gnome things to $GNOME_PREFIX"" 1>&2
+ fi
+ fi
diff --git a/graphics/chbg/pkg-descr b/graphics/chbg/pkg-descr
index f02510ec0d92..de3d8a6d908e 100644
--- a/graphics/chbg/pkg-descr
+++ b/graphics/chbg/pkg-descr
@@ -2,6 +2,3 @@ ChBg is used for changing desktop background pictures with some period.
Can also be used as a xscreensaver hack.
WWW: http://www.idata.sk/~ondrej/chbg/
-
-- Peter Jones
-p@dancris.com
diff --git a/graphics/chbg/pkg-plist b/graphics/chbg/pkg-plist
index 1ef75a39efdc..ceee58c8d372 100644
--- a/graphics/chbg/pkg-plist
+++ b/graphics/chbg/pkg-plist
@@ -1,6 +1,11 @@
bin/chbg
-share/gnome/apps/Graphics/chbg.desktop
-share/gnome/pixmaps/chbg_64x64.xpm
+%%GNOME:%%share/gnome/apps/Graphics/chbg.desktop
+%%GNOME:%%share/gnome/control-center/.data/ChBgxss1.desktop
+%%GNOME:%%share/gnome/control-center/.data/ChBgxss2.desktop
+%%GNOME:%%share/gnome/control-center/.data/ChBgxss3.desktop
+%%GNOME:%%share/gnome/control-center/.data/chbg_logo.xpm
+%%GNOME:%%share/gnome/pixmaps/chbg_64x64.xpm
+share/locale/de/LC_MESSAGES/chbg.mo
share/locale/fr/LC_MESSAGES/chbg.mo
share/locale/sk/LC_MESSAGES/chbg.mo
share/locale/ja/LC_MESSAGES/chbg.mo