aboutsummaryrefslogtreecommitdiff
path: root/graphics/cinepaint
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2011-11-15 16:35:43 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2011-11-15 16:35:43 +0000
commit30e7ce895a15335cf586741dbb8134c6a9cea617 (patch)
tree67b7faeca32f4328d798e0652838c9c0ddd53291 /graphics/cinepaint
parent460bc54c09ca8976eb24a6c4d5864aaa4e4a2af4 (diff)
downloadports-30e7ce895a15335cf586741dbb8134c6a9cea617.tar.gz
ports-30e7ce895a15335cf586741dbb8134c6a9cea617.zip
- Unbreak - fix build with latest x11-toolkits/fltk
Feature safe: yes
Notes
Notes: svn path=/head/; revision=285861
Diffstat (limited to 'graphics/cinepaint')
-rw-r--r--graphics/cinepaint/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/graphics/cinepaint/Makefile b/graphics/cinepaint/Makefile
index 912c36e61967..1af947b41ed0 100644
--- a/graphics/cinepaint/Makefile
+++ b/graphics/cinepaint/Makefile
@@ -29,8 +29,6 @@ USE_GETTEXT= yes
USE_LDCONFIG= yes
USE_XORG= xpm
-BROKEN= does not compile
-
MAN1= cinepaint.1 cinepainttool.1
PLIST_SUB= VER=${PORTVERSION}-1
@@ -69,4 +67,8 @@ post-patch:
's|static GDrawableType|static GImageType|' \
${WRKSRC}/plug-ins/psd/psd.c
+ @${FIND} ${WRKSRC} -type f -name "*.c" -o -name "*.cpp" -o -name "*.cxx" -o -name "*.h" | ${XARGS} \
+ ${REINPLACE_CMD} -e '/^#include <FL/s|.h>$$|.H>|; /^#include "FL/s|.h"$$|.H"|; \
+ s|fl_file_chooser.H|Fl_File_Chooser.H|g; s|#include <Fl|#include <FL|g; s|<FL/gl.H>|<FL/gl.h>|'
+
.include <bsd.port.post.mk>