aboutsummaryrefslogtreecommitdiff
path: root/graphics/dcraw
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-02-22 20:29:39 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-02-22 20:29:39 +0000
commit7b8522faa38b860b60816c09431fcb315c17e024 (patch)
tree13969dc9619054b3717fa698179c0c1e042b62b9 /graphics/dcraw
parent2f0ad830642fd5e1ae40ce6fe6c8c2e4a668f044 (diff)
downloadports-7b8522faa38b860b60816c09431fcb315c17e024.tar.gz
ports-7b8522faa38b860b60816c09431fcb315c17e024.zip
- Update to 8.05
- Pass maintainer-ship to submitter PR: 92495 Submitted by: Andrew Pantyukhin <infofarmer@gmail.com> Approved by: Arjan van Leeuwen <avleeuwen@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=156710
Diffstat (limited to 'graphics/dcraw')
-rw-r--r--graphics/dcraw/Makefile8
-rw-r--r--graphics/dcraw/distinfo6
-rw-r--r--graphics/dcraw/files/patch-dcraw.c13
3 files changed, 7 insertions, 20 deletions
diff --git a/graphics/dcraw/Makefile b/graphics/dcraw/Makefile
index 255f3724030b..7522c494fd49 100644
--- a/graphics/dcraw/Makefile
+++ b/graphics/dcraw/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= dcraw
-PORTVERSION= 8.00
+PORTVERSION= 8.05
CATEGORIES= graphics
MASTER_SITES= http://bsd.gubkin.ru/myports/ \
http://www.piwebs.com/distfiles/${PORTNAME}/
-MAINTAINER= avleeuwen@piwebs.com
+MAINTAINER= infofarmer@gmail.com
COMMENT= Decoder for RAW files from digital cameras
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
@@ -23,7 +23,7 @@ MAN1= dcraw.1
PLIST_FILES= bin/dcraw
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/dcraw ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/dcraw.1 ${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/graphics/dcraw/distinfo b/graphics/dcraw/distinfo
index c53a8fec9b31..899c2a4557e0 100644
--- a/graphics/dcraw/distinfo
+++ b/graphics/dcraw/distinfo
@@ -1,3 +1,3 @@
-MD5 (dcraw-8.00.tar.bz2) = 098a49cfd59b46255c9f49a5558b82d2
-SHA256 (dcraw-8.00.tar.bz2) = 14ec041301fa6d11f80e1852b73c4994c7f4cd691d573ff094f3091910bd0ee6
-SIZE (dcraw-8.00.tar.bz2) = 49902
+MD5 (dcraw-8.05.tar.bz2) = 891a528ac366e9b17474f9b3410dfbcb
+SHA256 (dcraw-8.05.tar.bz2) = 9a29238938114e8bbe604d53b2fff400b404dbe3557376b9714bac3da2b546f3
+SIZE (dcraw-8.05.tar.bz2) = 50434
diff --git a/graphics/dcraw/files/patch-dcraw.c b/graphics/dcraw/files/patch-dcraw.c
deleted file mode 100644
index c50b5a66847f..000000000000
--- a/graphics/dcraw/files/patch-dcraw.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- dcraw.c.orig Sat Jan 21 11:47:53 2006
-+++ dcraw.c Mon Jan 23 16:23:23 2006
-@@ -1140,8 +1140,9 @@
- void CLASS layer_thumb (FILE *tfp)
- {
- int i, c;
-+ char *thumb;
- colors = thumb_misc >> 5;
-- char *thumb = malloc (thumb_length*colors);
-+ thumb = malloc (thumb_length*colors);
- merror (thumb, "layer_thumb()");
- fprintf (tfp, "P%d\n%d %d\n255\n",
- 5 + (thumb_misc >> 6), thumb_width, thumb_height);