aboutsummaryrefslogtreecommitdiff
path: root/graphics/dcraw
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-23 15:26:09 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-23 15:26:09 +0000
commit7c0d12165fdc8d74530844c70fa6d58053a117f9 (patch)
tree3227b21a2605ee34683ea2e41a3e39ef7527903f /graphics/dcraw
parentac4bc1c8584e87f064e52fd4b963984a9cc6601c (diff)
downloadports-7c0d12165fdc8d74530844c70fa6d58053a117f9.tar.gz
ports-7c0d12165fdc8d74530844c70fa6d58053a117f9.zip
- Update to 8.00
PR: ports/92158 Submitted by: Andrew Pantyukhin <infofarmer@gmail.com> Approved by: Arjan van Leeuwen <avleeuwen@piwebs.com> (maintainer)
Notes
Notes: svn path=/head/; revision=154242
Diffstat (limited to 'graphics/dcraw')
-rw-r--r--graphics/dcraw/Makefile5
-rw-r--r--graphics/dcraw/distinfo6
-rw-r--r--graphics/dcraw/files/patch-dcraw.c13
3 files changed, 19 insertions, 5 deletions
diff --git a/graphics/dcraw/Makefile b/graphics/dcraw/Makefile
index 251801facc46..255f3724030b 100644
--- a/graphics/dcraw/Makefile
+++ b/graphics/dcraw/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dcraw
-PORTVERSION= 7.94
+PORTVERSION= 8.00
CATEGORIES= graphics
MASTER_SITES= http://bsd.gubkin.ru/myports/ \
http://www.piwebs.com/distfiles/${PORTNAME}/
@@ -14,7 +14,8 @@ MASTER_SITES= http://bsd.gubkin.ru/myports/ \
MAINTAINER= avleeuwen@piwebs.com
COMMENT= Decoder for RAW files from digital cameras
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ lcms.1:${PORTSDIR}/graphics/lcms
USE_BZIP2= yes
diff --git a/graphics/dcraw/distinfo b/graphics/dcraw/distinfo
index 244ea051cbc3..c53a8fec9b31 100644
--- a/graphics/dcraw/distinfo
+++ b/graphics/dcraw/distinfo
@@ -1,3 +1,3 @@
-MD5 (dcraw-7.94.tar.bz2) = dc3d42a707a6efeff1d52c0b31d0537b
-SHA256 (dcraw-7.94.tar.bz2) = 1a0743d3494225df6a32aa870fd36ecd57f053b27483807bce10ccdea06c0f76
-SIZE (dcraw-7.94.tar.bz2) = 48241
+MD5 (dcraw-8.00.tar.bz2) = 098a49cfd59b46255c9f49a5558b82d2
+SHA256 (dcraw-8.00.tar.bz2) = 14ec041301fa6d11f80e1852b73c4994c7f4cd691d573ff094f3091910bd0ee6
+SIZE (dcraw-8.00.tar.bz2) = 49902
diff --git a/graphics/dcraw/files/patch-dcraw.c b/graphics/dcraw/files/patch-dcraw.c
new file mode 100644
index 000000000000..c50b5a66847f
--- /dev/null
+++ b/graphics/dcraw/files/patch-dcraw.c
@@ -0,0 +1,13 @@
+--- dcraw.c.orig Sat Jan 21 11:47:53 2006
++++ dcraw.c Mon Jan 23 16:23:23 2006
+@@ -1140,8 +1140,9 @@
+ void CLASS layer_thumb (FILE *tfp)
+ {
+ int i, c;
++ char *thumb;
+ colors = thumb_misc >> 5;
+- char *thumb = malloc (thumb_length*colors);
++ thumb = malloc (thumb_length*colors);
+ merror (thumb, "layer_thumb()");
+ fprintf (tfp, "P%d\n%d %d\n255\n",
+ 5 + (thumb_misc >> 6), thumb_width, thumb_height);