aboutsummaryrefslogtreecommitdiff
path: root/graphics/devil/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-04-02 00:31:25 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-04-02 00:31:25 +0000
commitec05e2e29011cdf399d19d563dbd0c9eba0e2106 (patch)
treeba82e4422344e309a0cd6c1bfda7bf57a6592408 /graphics/devil/Makefile
parent8ace6f3c60e27160502040905d6da07a839b9f8b (diff)
downloadports-ec05e2e29011cdf399d19d563dbd0c9eba0e2106.tar.gz
ports-ec05e2e29011cdf399d19d563dbd0c9eba0e2106.zip
- Add nvidia-texture-tools support
- Mark MAKE_JOBS_SAFE
Notes
Notes: svn path=/head/; revision=231455
Diffstat (limited to 'graphics/devil/Makefile')
-rw-r--r--graphics/devil/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/graphics/devil/Makefile b/graphics/devil/Makefile
index 61203746ccfb..9ad7bb9300b3 100644
--- a/graphics/devil/Makefile
+++ b/graphics/devil/Makefile
@@ -8,7 +8,7 @@
PORTNAME= devil
PORTVERSION= 1.7.8
PORTEPOCH= 1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF/openil
DISTNAME= DevIL-${PORTVERSION}
@@ -23,7 +23,8 @@ OPTIONS= JPEG "Enable JPEG support" on \
PNG "Enable PNG support" on \
TIFF "Enable TIFF support" on \
X11 "Enable X11 support" on \
- SDL "Enable SDL support" off
+ SDL "Enable SDL support" off \
+ NVTT "Enable NVidia texture tools support" off
WRKSRC= ${WRKDIR}/${DISTNAME:L}
@@ -34,9 +35,9 @@ AUTOMAKE_ARGS= --add-missing --copy --force-missing
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-ILU \
--disable-allegro --disable-directx8 --disable-directx9 \
- --disable-altivec --disable-sse --disable-sse2 --disable-sse3 \
- --without-nvtt
+ --disable-altivec --disable-sse --disable-sse2 --disable-sse3
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
@@ -100,6 +101,14 @@ USE_SDL= sdl
CONFIGURE_ARGS+=--disable-sdl
.endif
+.if defined(WITH_NVTT)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libnvtt.so:${PORTSDIR}/graphics/nvidia-texture-tools
+RUN_DEPENDS+= ${LOCALBASE}/lib/libnvtt.so:${PORTSDIR}/graphics/nvidia-texture-tools
+LDFLAGS+= ${PTHREAD_LIBS}
+.else
+CONFIGURE_ARGS+=--without-nvtt
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS/s|docs||g' ${WRKSRC}/Makefile.am
@${REINPLACE_CMD} -e '/^pkgdir=/s|$$(libdir)/|$$(prefix)/libdata/|g' \