aboutsummaryrefslogtreecommitdiff
path: root/graphics/diacanvas2
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-05-07 22:33:39 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-05-07 22:33:39 +0000
commitea617e7fdc1717804bbc0e20cca5d676ada9d1d7 (patch)
treed3e7fe878c3a06486aafb6912166b9ed98b76ddf /graphics/diacanvas2
parent48216a14b5aa031542f1888b2ab9d82443e99f6c (diff)
downloadports-ea617e7fdc1717804bbc0e20cca5d676ada9d1d7.tar.gz
ports-ea617e7fdc1717804bbc0e20cca5d676ada9d1d7.zip
Fixing broken pkg-plist and make it build fine with python-bindings.
PR: ports/65815 Submitted by: Jens Rehsack <rehsack@liwing.de>
Notes
Notes: svn path=/head/; revision=108649
Diffstat (limited to 'graphics/diacanvas2')
-rw-r--r--graphics/diacanvas2/Makefile26
1 files changed, 24 insertions, 2 deletions
diff --git a/graphics/diacanvas2/Makefile b/graphics/diacanvas2/Makefile
index f991f54f4b5c..40919b37ee78 100644
--- a/graphics/diacanvas2/Makefile
+++ b/graphics/diacanvas2/Makefile
@@ -18,8 +18,6 @@ COMMENT= A general drawing canvas from dia dialog editor
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gnome/__init__.py:${PORTSDIR}/x11-toolkits/py-gnome2
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gnome/__init__.py:${PORTSDIR}/x11-toolkits/py-gnome2
-BROKEN= "Broken pkg-plist"
-
USE_GNOME= gnomehack libgnomeprint libgnomeprintui libartlgpl2 \
libgnomecanvas
USE_PYTHON= 2.2+
@@ -30,10 +28,34 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_SHLIB= yes
+.if !defined(DISPLAY)
+BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
+CONFIGURE_ENV+= DISPLAY=localhost:1001
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|unit_tests doc|unit_tests|g' ${WRKSRC}/Makefile.in
+pre-configure:
+.if exists(${WRKDIR}/.Xvfb.pid)
+ @-${CAT} ${WRKDIR}/.Xvfb.pid | ${XARGS} kill
+ @${RM} -f ${WRKDIR}/.Xvfb.pid
+.endif
+.if !defined(DISPLAY)
+ #
+ # This is a UGLY hack to not have to specify a X-Display.
+ #
+ ${X11BASE}/bin/Xvfb :1001 -screen 0 800x600x24 > /dev/null 2>&1 & ${ECHO} $$! > ${WRKDIR}/.Xvfb.pid
+ @sleep 5
+.endif
+
+post-configure:
+.if !defined(DISPLAY)
+ @-${CAT} ${WRKDIR}/.Xvfb.pid | ${XARGS} kill
+ @${RM} -f ${WRKDIR}/.Xvfb.pid
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}