aboutsummaryrefslogtreecommitdiff
path: root/graphics/enfle/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-02-21 06:45:25 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-02-21 06:45:25 +0000
commit222e09d12a824c437f29142a1b1e1bc5eb55b3c9 (patch)
tree42f319e2f550596f069db4bd06398977cfde45db /graphics/enfle/Makefile
parentd93921bc6224b30c62a3504dc347b720994aa043 (diff)
downloadports-222e09d12a824c437f29142a1b1e1bc5eb55b3c9.tar.gz
ports-222e09d12a824c437f29142a1b1e1bc5eb55b3c9.zip
build with giflib
Notes
Notes: svn path=/head/; revision=291983
Diffstat (limited to 'graphics/enfle/Makefile')
-rw-r--r--graphics/enfle/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/graphics/enfle/Makefile b/graphics/enfle/Makefile
index c5383989bb9b..34bfca699dcc 100644
--- a/graphics/enfle/Makefile
+++ b/graphics/enfle/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= arc.1:${PORTSDIR}/archivers/libarc \
jasper.4:${PORTSDIR}/graphics/jasper \
jpeg.11:${PORTSDIR}/graphics/jpeg \
mng.1:${PORTSDIR}/graphics/libmng \
- ungif.5:${PORTSDIR}/graphics/libungif \
+ gif.5:${PORTSDIR}/graphics/giflib \
png.6:${PORTSDIR}/graphics/png \
theora.0:${PORTSDIR}/multimedia/libtheora
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -77,7 +77,10 @@ post-patch:
/LIB/s|-lpthread|${PTHREAD_LIBS}|g ; \
/LIB/s|-lc_r|${PTHREAD_LIBS}|g ; \
/CFLAGS/s|-pthread|${PTHREAD_CFLAGS}|g ; \
- /DLOPEN/s|-ldl||g' ${WRKSRC}/configure
+ /DLOPEN/s|-ldl||g ; \
+ s|-lungif|-lgif|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-lungif|-lgif|' \
+ ${WRKSRC}/lib/avcodec/config.mak
@${REINPLACE_CMD} -e \
'/enfle -N/s|^|#|g' ${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} -e \