aboutsummaryrefslogtreecommitdiff
path: root/graphics/enfle
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2010-10-22 21:04:29 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2010-10-22 21:04:29 +0000
commit183b41722d052112205ee06ef04512ebedf60f8e (patch)
tree692179d9c59294d143303170048344326da30d3f /graphics/enfle
parentdc0490dbe50b44cb3023497651326f8a92158cff (diff)
downloadports-183b41722d052112205ee06ef04512ebedf60f8e.tar.gz
ports-183b41722d052112205ee06ef04512ebedf60f8e.zip
- Update to 20101006.
- Add an option to build with support for AVCODEC. PR: ports/151548 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=263455
Diffstat (limited to 'graphics/enfle')
-rw-r--r--graphics/enfle/Makefile21
-rw-r--r--graphics/enfle/distinfo6
-rw-r--r--graphics/enfle/pkg-plist9
3 files changed, 26 insertions, 10 deletions
diff --git a/graphics/enfle/Makefile b/graphics/enfle/Makefile
index 247dca3a4a6c..038c5d844dd1 100644
--- a/graphics/enfle/Makefile
+++ b/graphics/enfle/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= enfle
-PORTVERSION= 20071024
-PORTREVISION= 5
+PORTVERSION= 20101006
CATEGORIES= graphics
MASTER_SITES= http://enfle.fennel.org/files/stable/
@@ -24,8 +23,10 @@ LIB_DEPENDS= arc.1:${PORTSDIR}/archivers/libarc \
theora.0:${PORTSDIR}/multimedia/libtheora
RUN_DEPENDS:= ${BUILD_DEPENDS}
-OPTIONS= SIMD "Enable x86 SIMD (MMX/SSE)" off
+OPTIONS= SIMD "Enable x86 SIMD (MMX/SSE)" off \
+ AVCODEC "Enable libavcodec support" off
+USE_LDCONFIG= yes
USE_BZIP2= yes
USE_XORG= ice x11 xext xv
USE_GNOME= esound
@@ -37,7 +38,7 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
ac_cv_header_libmpeg3_h=no \
ac_cv_header_decore_h=no \
ac_cv_header_avifile_h=no
-CONFIGURE_ARGS= --with-ungif --disable-avcodec
+CONFIGURE_ARGS= --with-ungif
PKGDEINSTALL= ${PKGINSTALL}
@@ -63,6 +64,14 @@ PLIST_SUB+= DISABLED="@comment "
PLIST_SUB+= DISABLED=""
.endif
+.if defined(WITH_AVCODEC)
+LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg
+PLIST_SUB+= AVCODEC=""
+.else
+CONFIGURE_ARGS+= --disable-system-avcodec
+PLIST_SUB+= AVCODEC="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|/usr/local/|${LOCALBASE}/|g ; \
@@ -70,14 +79,12 @@ post-patch:
/LIB/s|-lpthread|${PTHREAD_LIBS}|g ; \
/LIB/s|-lc_r|${PTHREAD_LIBS}|g ; \
/CFLAGS/s|-pthread|${PTHREAD_CFLAGS}|g ; \
- /LIB/s|-ldl||g' ${WRKSRC}/configure
+ /DLOPEN/s|-ldl||g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e \
'/enfle -N/s|^|#|g' ${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} -e \
's|/usr/share/X11|${LOCALBASE}/lib/X11|g ; \
/X11R6/d' ${WRKSRC}/plugins/loader/xpm/xpm.c
- @${REINPLACE_CMD} -e \
- 's|arciver_|archiver_|g' ${WRKSRC}/plugins/archiver/rar/unrar.c
.if ${OSVERSION} < 700000
@${REINPLACE_CMD} -e \
'/^SUBDIRS/s|effect|| ; \
diff --git a/graphics/enfle/distinfo b/graphics/enfle/distinfo
index 623396e908b8..46d556e64b68 100644
--- a/graphics/enfle/distinfo
+++ b/graphics/enfle/distinfo
@@ -1,3 +1,3 @@
-MD5 (enfle-20071024.tar.bz2) = 947de0d1dcc143e8f19ccace8ecfff0e
-SHA256 (enfle-20071024.tar.bz2) = 093381d78bb1c9551ec74c5aba954e215babadb99a7247d86c7af05f5cfb1207
-SIZE (enfle-20071024.tar.bz2) = 2284883
+MD5 (enfle-20101006.tar.bz2) = cf433e138f9c17c35f11d3077f743451
+SHA256 (enfle-20101006.tar.bz2) = 69a5a7311f8531da6e3f2e7193cb3da0222ca524539684548dfcdf512a6418af
+SIZE (enfle-20101006.tar.bz2) = 2599311
diff --git a/graphics/enfle/pkg-plist b/graphics/enfle/pkg-plist
index e8f5fc195406..729d3b1f5547 100644
--- a/graphics/enfle/pkg-plist
+++ b/graphics/enfle/pkg-plist
@@ -14,6 +14,9 @@ lib/enfle/plugins/audio/audio_esd.so
lib/enfle/plugins/audio/audio_oss.a
lib/enfle/plugins/audio/audio_oss.la
lib/enfle/plugins/audio/audio_oss.so
+%%AVCODEC%%lib/enfle/plugins/audiodecoder/audiodecoder_avcodec.a
+%%AVCODEC%%lib/enfle/plugins/audiodecoder/audiodecoder_avcodec.la
+%%AVCODEC%%lib/enfle/plugins/audiodecoder/audiodecoder_avcodec.so
%%DISABLED%%lib/enfle/plugins/audiodecoder/audiodecoder_mad.a
%%DISABLED%%lib/enfle/plugins/audiodecoder/audiodecoder_mad.la
%%DISABLED%%lib/enfle/plugins/audiodecoder/audiodecoder_mad.so
@@ -101,6 +104,9 @@ lib/enfle/plugins/streamer/streamer_bz2.so
lib/enfle/plugins/streamer/streamer_gz.a
lib/enfle/plugins/streamer/streamer_gz.la
lib/enfle/plugins/streamer/streamer_gz.so
+lib/enfle/plugins/streamer/streamer_xz.a
+lib/enfle/plugins/streamer/streamer_xz.la
+lib/enfle/plugins/streamer/streamer_xz.so
lib/enfle/plugins/ui/ui_convert.a
lib/enfle/plugins/ui/ui_convert.la
lib/enfle/plugins/ui/ui_convert.so
@@ -113,6 +119,9 @@ lib/enfle/plugins/ui/ui_wallpaper.so
lib/enfle/plugins/video/video_Xlib.a
lib/enfle/plugins/video/video_Xlib.la
lib/enfle/plugins/video/video_Xlib.so
+%%AVCODEC%%lib/enfle/plugins/videodecoder/videodecoder_avcodec.a
+%%AVCODEC%%lib/enfle/plugins/videodecoder/videodecoder_avcodec.la
+%%AVCODEC%%lib/enfle/plugins/videodecoder/videodecoder_avcodec.so
%%DISABLED%%lib/enfle/plugins/videodecoder/videodecoder_libmpeg2.a
%%DISABLED%%lib/enfle/plugins/videodecoder/videodecoder_libmpeg2.la
%%DISABLED%%lib/enfle/plugins/videodecoder/videodecoder_libmpeg2.so