aboutsummaryrefslogtreecommitdiff
path: root/graphics/epstool
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-16 06:55:22 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-16 06:55:22 +0000
commite8c890c3bbd61a1088cafca6425ba7a4b0a9294a (patch)
tree3af3b77f84e00a3cd843038d54241b9a03896121 /graphics/epstool
parent5c2ddcd67152b619b1f3027338631d3fdc28129b (diff)
downloadports-e8c890c3bbd61a1088cafca6425ba7a4b0a9294a.tar.gz
ports-e8c890c3bbd61a1088cafca6425ba7a4b0a9294a.zip
Stagify.
Approved by: portmgr@
Notes
Notes: svn path=/head/; revision=357951
Diffstat (limited to 'graphics/epstool')
-rw-r--r--graphics/epstool/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/graphics/epstool/Makefile b/graphics/epstool/Makefile
index e4803a7dc2ab..a8269a8e1430 100644
--- a/graphics/epstool/Makefile
+++ b/graphics/epstool/Makefile
@@ -22,21 +22,19 @@ MAKE_ARGS= MAKE="${GMAKE}" GSCDEBUG="" CC="${CC}" CCAUX="${CC}" \
ALL_TARGET= ${PORTNAME}
MAKE_JOBS_UNSAFE= yes
-MAN1= epstool.1
-PLIST_FILES= bin/epstool
+PLIST_FILES= bin/epstool man/man1/epstool.1.gz
.if !defined(NOPORTDOCS)
PORTDOCS= epstool.htm gsview.css
.endif
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/epstool ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/doc/epstool.1 ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/epstool ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/epstool.1 ${STAGEDIR}${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/epstool.htm ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/gsview.css ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/epstool.htm ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/gsview.css ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>