aboutsummaryrefslogtreecommitdiff
path: root/graphics/evas-loader-xpm
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2008-03-11 21:13:53 +0000
committerStanislav Sedov <stas@FreeBSD.org>2008-03-11 21:13:53 +0000
commit9a2e4c8b780fc607dc4b4adabefb354c84401a96 (patch)
treef59767aed29b447d3d80ab987e898598663c27e3 /graphics/evas-loader-xpm
parent621c804e48a9fdddd6a00d78585fa8cb20c8460e (diff)
downloadports-9a2e4c8b780fc607dc4b4adabefb354c84401a96.tar.gz
ports-9a2e4c8b780fc607dc4b4adabefb354c84401a96.zip
- Update enlightenment-devel and EFL libraries to the latest snapshot
- Deprecate old unsupported apps and modules (entice, devian, eveil, engage) - Split evas and ecore to separate modules to handle dependencies properly - Disable PAM in enlightenment-devel as it don't work anyway (requires root privilegies) - Add DBUS support. Thanks to: az
Notes
Notes: svn path=/head/; revision=208836
Diffstat (limited to 'graphics/evas-loader-xpm')
-rw-r--r--graphics/evas-loader-xpm/Makefile62
-rw-r--r--graphics/evas-loader-xpm/distinfo3
-rw-r--r--graphics/evas-loader-xpm/pkg-descr6
-rw-r--r--graphics/evas-loader-xpm/pkg-plist8
4 files changed, 79 insertions, 0 deletions
diff --git a/graphics/evas-loader-xpm/Makefile b/graphics/evas-loader-xpm/Makefile
new file mode 100644
index 000000000000..e5a731c666a0
--- /dev/null
+++ b/graphics/evas-loader-xpm/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: evas-loader-xpm
+# Date created: 15 September 2007
+# Whom: Stanislav Sedov <stas@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= loader-xpm
+PORTVERSION= 0.9.9.042
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
+ http://download.enlightenment.org/snapshots/2008-01-25/
+PKGNAMEPREFIX= evas-
+DISTNAME= evas-${PORTVERSION}
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= A hardware accelerated canvas API (XPM engine)
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_FREETYPE2= yes
+USE_LDCONFIG= yes
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_XORG= xpm
+USE_EFL= evas
+
+MAKEDIRS= ${WRKSRC}/src/modules/loaders/xpm
+
+CONFIGURE_ARGS= --disable-software-x11 \
+ --disable-software-16-x11 \
+ --disable-software-xcb \
+ --disable-directfb \
+ --disable-sdl \
+ --disable-buffer \
+ --disable-software-qtopia \
+ --disable-gl-x11 \
+ --disable-cairo-x11 \
+ --disable-xrender-x11 \
+ --disable-xrender-xcb \
+ --disable-glitz-x11 \
+ --disable-image-loader-gif \
+ --disable-image-loader-png \
+ --disable-image-loader-jpeg \
+ --disable-image-loader-eet \
+ --disable-image-loader-edb \
+ --disable-image-loader-tiff \
+ --enable-image-loader-xpm \
+ --disable-image-loader-svg
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's,\$$\(top_builddir\)/src/lib/\.libs,${LOCALBASE}/lib,' \
+ -e 's,\$$\(top_builddir\)/src/lib/libevas\.la,-levas,' \
+ ${MAKEDIRS:S,$,/Makefile.in,}
+
+do-build:
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
+
+do-install:
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
+
+.include <bsd.port.mk>
diff --git a/graphics/evas-loader-xpm/distinfo b/graphics/evas-loader-xpm/distinfo
new file mode 100644
index 000000000000..5e8e2bc542ac
--- /dev/null
+++ b/graphics/evas-loader-xpm/distinfo
@@ -0,0 +1,3 @@
+MD5 (evas-0.9.9.042.tar.bz2) = 6811e52b0607ce21061a23462a1f9854
+SHA256 (evas-0.9.9.042.tar.bz2) = e7ebc64a983950979b5488cc0b6fe2b3220f24da554c12c96a4f9131e5a76440
+SIZE (evas-0.9.9.042.tar.bz2) = 7373199
diff --git a/graphics/evas-loader-xpm/pkg-descr b/graphics/evas-loader-xpm/pkg-descr
new file mode 100644
index 000000000000..e525449b6c61
--- /dev/null
+++ b/graphics/evas-loader-xpm/pkg-descr
@@ -0,0 +1,6 @@
+A hardware-accelerated canvas API for X-Windows that can draw anti-aliased
+text, smooth super and sub-sampled images, alpha-blend, as well as drop down to
+using normal X11 primitives such as pixmaps, lines and rectangles for speed if
+your CPU or graphics hardware is too slow.
+
+WWW: http://enlightenment.sourceforge.net/Libraries/Evas/
diff --git a/graphics/evas-loader-xpm/pkg-plist b/graphics/evas-loader-xpm/pkg-plist
new file mode 100644
index 000000000000..45841362f182
--- /dev/null
+++ b/graphics/evas-loader-xpm/pkg-plist
@@ -0,0 +1,8 @@
+lib/evas/modules/loaders/xpm/%%E17_ARCH%%/module.a
+lib/evas/modules/loaders/xpm/%%E17_ARCH%%/module.la
+lib/evas/modules/loaders/xpm/%%E17_ARCH%%/module.so
+@dirrm lib/evas/modules/loaders/xpm/%%E17_ARCH%%
+@dirrm lib/evas/modules/loaders/xpm
+@dirrmtry lib/evas/modules/loaders
+@dirrmtry lib/evas/modules
+@dirrmtry lib/evas