aboutsummaryrefslogtreecommitdiff
path: root/graphics/evas
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2005-06-16 09:50:46 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2005-06-16 09:50:46 +0000
commitdac4e80946898ce976476eba5671d76adf24c7c5 (patch)
tree91238821988b18f8c7b09ce6d67ad0420dfc7298 /graphics/evas
parente6ae83e8af7d12bceab3eb7381520155df2af683 (diff)
downloadports-dac4e80946898ce976476eba5671d76adf24c7c5.tar.gz
ports-dac4e80946898ce976476eba5671d76adf24c7c5.zip
Upgrade to 0.9.9.010, and it's not api compatible with old one,
But, only graphics/ruby-evas depends on evas 0.6, and it's out of date. I will remove graphics/ruby-evas later.
Notes
Notes: svn path=/head/; revision=137533
Diffstat (limited to 'graphics/evas')
-rw-r--r--graphics/evas/Makefile35
-rw-r--r--graphics/evas/distinfo4
-rw-r--r--graphics/evas/files/patch-doc::Makefile.in11
-rw-r--r--graphics/evas/files/patch-evas_object.c11
-rw-r--r--graphics/evas/pkg-plist101
5 files changed, 51 insertions, 111 deletions
diff --git a/graphics/evas/Makefile b/graphics/evas/Makefile
index 9b5e34ae9f95..2aff30dfc999 100644
--- a/graphics/evas/Makefile
+++ b/graphics/evas/Makefile
@@ -6,30 +6,29 @@
#
PORTNAME= evas
-PORTVERSION= 0.6.0
-PORTREVISION= 1
+PORTVERSION= 0.9.9.010
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= enlightenment
+MASTER_SITES= http://enlightenment.freedesktop.org/files/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= vanilla@FreeBSD.org
COMMENT= A hardware-accelerated canvas API for X-Windows
-LIB_DEPENDS= Imlib2.3:${PORTSDIR}/graphics/imlib2
+LIB_DEPENDS= Imlib2.3:${PORTSDIR}/graphics/imlib2 \
+ edb.1:${PORTSDIR}/databases/edb \
+ eet.9:${PORTSDIR}/devel/eet
-USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_LIBTOOL_VER=15
-USE_FREETYPE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype1 \
- -I${LOCALBASE}/include -I${X11BASE}/include" \
- LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-CONFIGURE_ARGS= --disable-gl
+USE_LIBTOOL_VER= 15
+USE_FREETYPE2= yes
INSTALLS_SHLIB= yes
-USE_REINPLACE= yes
+USE_GNOME= gnomehack pkgconfig gnometarget
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.include <bsd.port.pre.mk>
-post-patch:
- @${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
- ${WRKSRC}/configure
+.if defined(WITH_MMX) && (${ARCH} == "i386")
+CONFIGURE_ARGS+= --enable-mmx
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/evas/distinfo b/graphics/evas/distinfo
index 5fd0d43e23cc..913f1f6c9116 100644
--- a/graphics/evas/distinfo
+++ b/graphics/evas/distinfo
@@ -1,2 +1,2 @@
-MD5 (evas-0.6.0.tar.bz2) = f38d95e7d34e4d7329396a8f3988913a
-SIZE (evas-0.6.0.tar.bz2) = 8105244
+MD5 (evas-0.9.9.010.tar.gz) = e7197ca22ee4aec41905cc0d03a7e899
+SIZE (evas-0.9.9.010.tar.gz) = 1403596
diff --git a/graphics/evas/files/patch-doc::Makefile.in b/graphics/evas/files/patch-doc::Makefile.in
deleted file mode 100644
index 021c256ef99b..000000000000
--- a/graphics/evas/files/patch-doc::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- doc/Makefile.in.orig Fri Sep 21 12:31:16 2001
-+++ doc/Makefile.in Sun Oct 7 18:29:54 2001
-@@ -84,7 +84,7 @@
-
- EXTRA_DIST = evas.sdw evas.pdf
-
--evasdir = $(datadir)/evas/doc
-+evasdir = $(datadir)/doc/evas
- evas_DATA = evas.sdw evas.pdf
-
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/graphics/evas/files/patch-evas_object.c b/graphics/evas/files/patch-evas_object.c
deleted file mode 100644
index 362c2b486a09..000000000000
--- a/graphics/evas/files/patch-evas_object.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/evas_object.c.orig Sun Aug 15 16:22:01 2004
-+++ src/evas_object.c Sun Aug 15 16:22:07 2004
-@@ -10,6 +10,8 @@
- #define RECTS_INTERSECT(x, y, w, h, xx, yy, ww, hh) \
- ((SPANS_COMMON((x), (w), (xx), (ww))) && (SPANS_COMMON((y), (h), (yy), (hh))))
-
-+void _evas_cleanup_clip(Evas e, Evas_Object o);
-+
- Evas_Layer
- _evas_get_object_layer(Evas e, Evas_Object o)
- {
diff --git a/graphics/evas/pkg-plist b/graphics/evas/pkg-plist
index ec9259c77792..3367af089282 100644
--- a/graphics/evas/pkg-plist
+++ b/graphics/evas/pkg-plist
@@ -1,73 +1,36 @@
bin/evas-config
-bin/evas_test
-bin/evas_test_old
+bin/evas_buffer_test
+bin/evas_gl_x11_test
+bin/evas_software_x11_perf_load
+bin/evas_software_x11_perf_test
+bin/evas_software_x11_test
include/Evas.h
+include/Evas_Engine_Buffer.h
+include/Evas_Engine_GL_X11.h
+include/Evas_Engine_Software_X11.h
lib/libevas.a
lib/libevas.so
-lib/libevas.so.6
-share/aclocal/evas.m4
-share/doc/evas/evas.pdf
-share/doc/evas/evas.sdw
-share/evas/fnt/andover.ttf
-share/evas/fnt/cinema.ttf
-share/evas/fnt/grunge.ttf
-share/evas/fnt/morpheus.ttf
-share/evas/fnt/notepad.ttf
-share/evas/img/book.png
-share/evas/img/bulb.png
-share/evas/img/calc.png
-share/evas/img/evas_icon.png
-share/evas/img/evas_test_alpha1.png
-share/evas/img/evas_test_alpha2.png
-share/evas/img/evas_test_anti_alias.png
-share/evas/img/evas_test_canvas.png
-share/evas/img/evas_test_cheese.png
-share/evas/img/evas_test_control_bg.png
-share/evas/img/evas_test_control_selection1.png
-share/evas/img/evas_test_control_selection2.png
-share/evas/img/evas_test_image_0.png
-share/evas/img/evas_test_image_1.png
-share/evas/img/evas_test_image_10.png
-share/evas/img/evas_test_image_11.png
-share/evas/img/evas_test_image_12.png
-share/evas/img/evas_test_image_13.png
-share/evas/img/evas_test_image_14.png
-share/evas/img/evas_test_image_15.png
-share/evas/img/evas_test_image_2.png
-share/evas/img/evas_test_image_3.png
-share/evas/img/evas_test_image_4.png
-share/evas/img/evas_test_image_5.png
-share/evas/img/evas_test_image_6.png
-share/evas/img/evas_test_image_7.png
-share/evas/img/evas_test_image_8.png
-share/evas/img/evas_test_image_9.png
-share/evas/img/evas_test_mmx.png
-share/evas/img/evas_test_pointer.png
-share/evas/img/evas_test_pointer_big.png
-share/evas/img/evas_test_view_bg.png
-share/evas/img/evas_test_view_bubble.png
-share/evas/img/evas_test_view_bubble_shadow.png
-share/evas/img/evas_test_view_logo.png
-share/evas/img/evas_test_view_logo_image.png
-share/evas/img/evas_test_view_logo_image_brush.png
-share/evas/img/evas_test_view_logo_image_paint.png
-share/evas/img/evas_test_view_logo_impress.png
-share/evas/img/evas_test_view_logo_shadow.png
-share/evas/img/evas_test_wonder_1.png
-share/evas/img/evas_test_wonder_2.png
-share/evas/img/evas_test_wonder_3.png
-share/evas/img/evas_test_wonder_4.png
-share/evas/img/evas_test_wonder_5.png
-share/evas/img/evas_test_wonder_6.png
-share/evas/img/evas_test_wonder_7.png
-share/evas/img/logo001.png
-share/evas/img/mouse.png
-share/evas/img/mush.png
-share/evas/img/sky001.png
-share/evas/img/spider.png
-share/evas/img/term.png
-share/evas/img/worlds.png
-@dirrm share/doc/evas
-@dirrm share/evas/fnt
-@dirrm share/evas/img
-@dirrm share/evas
+lib/libevas.so.1
+libdata/pkgconfig/evas.pc
+%%DATADIR%%/Vera.ttf
+%%DATADIR%%/VeraBI.ttf
+%%DATADIR%%/VeraBd.ttf
+%%DATADIR%%/VeraIt.ttf
+%%DATADIR%%/VeraMoBI.ttf
+%%DATADIR%%/VeraMoBd.ttf
+%%DATADIR%%/VeraMoIt.ttf
+%%DATADIR%%/VeraMono.ttf
+%%DATADIR%%/VeraSe.ttf
+%%DATADIR%%/VeraSeBd.ttf
+%%DATADIR%%/backdrop.png
+%%DATADIR%%/e_logo.png
+%%DATADIR%%/evas_logo.png
+%%DATADIR%%/fonts.alias
+%%DATADIR%%/fonts.dir
+%%DATADIR%%/panel.png
+%%DATADIR%%/panel_shadow.png
+%%DATADIR%%/panel_top.png
+%%DATADIR%%/t1.png
+%%DATADIR%%/t2.png
+%%DATADIR%%/test_pattern.png
+@dirrm %%DATADIR%%