aboutsummaryrefslogtreecommitdiff
path: root/graphics/evince
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2007-07-09 00:25:15 +0000
committerMichael Johnson <ahze@FreeBSD.org>2007-07-09 00:25:15 +0000
commit718cf58619b490d62c0d560ebaca308a4e06a891 (patch)
tree5ebbbcfdb0debb64e40709466200930a95503a9d /graphics/evince
parent26e61f7104d4ccddcce4aca15fd1abcd99a15a4c (diff)
downloadports-718cf58619b490d62c0d560ebaca308a4e06a891.tar.gz
ports-718cf58619b490d62c0d560ebaca308a4e06a891.zip
Reenable djvu [1] and impress
Reported by: crsd via irc.freenode.org/#FreeBSD-GNOME
Notes
Notes: svn path=/head/; revision=195239
Diffstat (limited to 'graphics/evince')
-rw-r--r--graphics/evince/Makefile38
1 files changed, 19 insertions, 19 deletions
diff --git a/graphics/evince/Makefile b/graphics/evince/Makefile
index 9f93e12c87aa..f32956fe7e38 100644
--- a/graphics/evince/Makefile
+++ b/graphics/evince/Makefile
@@ -40,9 +40,9 @@ OPTIONS= DVI "Enable DVI viewer support" off \
T1LIB "Enable T1LIB for TYPE1 fonts to DVI (Enables DVI)" off \
NAUTILUS "Enable Nautilus plugin" on \
DBUS "Enable D-BUS support" on \
- COMICS "Enable comic book archives support" off
-# IMPRESS "Enable Impress presentations support" off \
-# DJVU "Enable DJVU support" off
+ COMICS "Enable comic book archives support" off \
+ IMPRESS "Enable Impress presentations support" off \
+ DJVU "Enable DJVU support" off
.include <bsd.port.pre.mk>
@@ -73,25 +73,25 @@ CONFIGURE_ARGS+= --disable-nautilus
PLIST_SUB+= NAUTILUS="@comment "
.endif
-#.if defined(WITH_IMPRESS)
-#CONFIGURE_ARGS+= --enable-impress
-#.else
+.if defined(WITH_IMPRESS)
+CONFIGURE_ARGS+= --enable-impress
+.else
CONFIGURE_ARGS+= --disable-impress
-#.endif
+.endif
-#.if exists(${X11BASE}/bin/djview)
-#DJVU_DIR?= # empty
-#.else
-#DJVU_DIR?= -nox11
-#.endif
-#
-#.if defined(WITH_DJVU)
-#LIB_DEPENDS+= djvulibre.17:${PORTSDIR}/graphics/djvulibre${DJVU_DIR}
-#CONFIGURE_ARGS+= --enable-djvu
-#GCONF_SCHEMAS+= evince-thumbnailer-djvu.schemas
-#.else
+.if exists(${X11BASE}/bin/djview)
+DJVU_DIR?= # empty
+.else
+DJVU_DIR?= -nox11
+.endif
+
+.if defined(WITH_DJVU)
+LIB_DEPENDS+= djvulibre.18:${PORTSDIR}/graphics/djvulibre${DJVU_DIR}
+CONFIGURE_ARGS+= --enable-djvu
+GCONF_SCHEMAS+= evince-thumbnailer-djvu.schemas
+.else
CONFIGURE_ARGS+= --disable-djvu
-#.endif
+.endif
.if !defined(WITHOUT_DBUS)
LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib