aboutsummaryrefslogtreecommitdiff
path: root/graphics/evolvotron
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2004-01-11 17:56:51 +0000
committerPete Fritchman <petef@FreeBSD.org>2004-01-11 17:56:51 +0000
commit666eb0a218ce63b313eea1bd207539199715aa9d (patch)
tree10d887e22fd3b883270c578b6e6dc2418f6f4960 /graphics/evolvotron
parente059d8e5804d52fbe485ece949aa0d03b697e409 (diff)
downloadports-666eb0a218ce63b313eea1bd207539199715aa9d.tar.gz
ports-666eb0a218ce63b313eea1bd207539199715aa9d.zip
- update to 0.2.3
- unbreak on -current - install docs PR: 59863 Submitted by: Markus Brueffer <brueffer@phoenix-systems.de> Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=97937
Diffstat (limited to 'graphics/evolvotron')
-rw-r--r--graphics/evolvotron/Makefile28
-rw-r--r--graphics/evolvotron/distinfo2
-rw-r--r--graphics/evolvotron/files/patch-common.pro44
-rw-r--r--graphics/evolvotron/files/patch-dialog_mutation_parameters.h4
-rw-r--r--graphics/evolvotron/files/patch-matrix.cpp6
-rw-r--r--graphics/evolvotron/pkg-plist4
6 files changed, 71 insertions, 17 deletions
diff --git a/graphics/evolvotron/Makefile b/graphics/evolvotron/Makefile
index b33a94b9f8c8..e8e77445a1e7 100644
--- a/graphics/evolvotron/Makefile
+++ b/graphics/evolvotron/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= evolvotron
-PORTVERSION= 0.0.5
+PORTVERSION= 0.2.3
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,21 +15,27 @@ COMMENT= Generative software that evolves images/textures/patterns
WRKSRC= ${WRKDIR}/${PORTNAME}
-QTDIR?= ${X11BASE}
USE_QT_VER= 3
-
+USE_PYTHON= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
-MAKE_ENV= QTDIR="${QTDIR}"
-
-.include <bsd.port.pre.mk>
+MAKE_ENV= QTDIR="${QT_PREFIX}" \
+ QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++
+CONFIGURE_ENV= QTDIR="${QT_PREFIX}" \
+ QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's/-pthread/${PTHREAD_LIBS}/' ${WRKSRC}/common.pro
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/evolvotron ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/evolvotron/evolvotron ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/evolvotron_mutate/evolvotron_mutate ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/evolvotron_render/evolvotron_render ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/evolvotron.html ${DOCSDIR}
+.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/evolvotron/distinfo b/graphics/evolvotron/distinfo
index a9bd1ef4e2fa..85c5a5078dc2 100644
--- a/graphics/evolvotron/distinfo
+++ b/graphics/evolvotron/distinfo
@@ -1 +1 @@
-MD5 (evolvotron-0.0.5.tar.gz) = ee20e4bea2742202f336316bcfbba702
+MD5 (evolvotron-0.2.3.tar.gz) = 515461d06f247a54d810ed4178eed26c
diff --git a/graphics/evolvotron/files/patch-common.pro b/graphics/evolvotron/files/patch-common.pro
new file mode 100644
index 000000000000..f7338521594a
--- /dev/null
+++ b/graphics/evolvotron/files/patch-common.pro
@@ -0,0 +1,44 @@
+--- common.pro.orig Mon Nov 3 09:40:15 2003
++++ common.pro Mon Dec 1 03:16:47 2003
+@@ -29,8 +29,6 @@
+ # Now leaving these ON for general distribution as they DO have SOME effect
+ # (or at least they have in the past... see the README), and should be portable.
+
+-QMAKE_CXXFLAGS_RELEASE -= -O2
+-QMAKE_CXXFLAGS_RELEASE += -O3 -fomit-frame-pointer -funroll-loops -ffast-math
+
+ ##################
+ # Architecture specific optimisations
+@@ -38,23 +36,6 @@
+ # (On a different setup you may need to change what's subtracted out of the flags.)
+ # NB -march=X implies -mcpu=X... no need to specify both the same
+
+-contains(CONFIG_OPTS, p4 ){
+- QMAKE_CXXFLAGS_RELEASE -= -march=i386 -mcpu=i686
+- QMAKE_CXXFLAGS_RELEASE += -march=pentium4 -mfpmath=sse -msse2
+- BUILD_INFO+= Pentium4
+-}
+-
+-contains(CONFIG_OPTS, p3 ){
+- QMAKE_CXXFLAGS_RELEASE -= -march=i386 -mcpu=i686
+- QMAKE_CXXFLAGS_RELEASE += -march=pentium3 -mfpmath=sse -msse
+- BUILD_INFO+= Pentium3
+-}
+-
+-contains(CONFIG_OPTS, xp ){
+- QMAKE_CXXFLAGS_RELEASE -= -march=i386 -mcpu=i686
+- QMAKE_CXXFLAGS_RELEASE += -march=athlon-xp -mfpmath=sse -msse
+- BUILD_INFO+= Athlon-XP
+-}
+
+ ##################
+ # Optimisation insanity
+@@ -67,7 +48,7 @@
+ #######################################
+ # Version numbering. This is ENTIRELY controlled by what is echoed by the VERSION script
+
+-VERSION_NUMBER = $${system(../VERSION)}
++VERSION_NUMBER = $${system(./VERSION)}
+ QMAKE_CXXFLAGS_RELEASE += '-DEVOLVOTRON_VERSION="$$VERSION_NUMBER"'
+ QMAKE_CXXFLAGS_DEBUG += '-DEVOLVOTRON_VERSION="$$VERSION_NUMBER"'
+ QMAKE_CXXFLAGS_RELEASE += '-DEVOLVOTRON_BUILD="$$VERSION_NUMBER (Build options: $$BUILD_INFO Release)"'
diff --git a/graphics/evolvotron/files/patch-dialog_mutation_parameters.h b/graphics/evolvotron/files/patch-dialog_mutation_parameters.h
index ed14ad16359d..37e5b3df4ed4 100644
--- a/graphics/evolvotron/files/patch-dialog_mutation_parameters.h
+++ b/graphics/evolvotron/files/patch-dialog_mutation_parameters.h
@@ -1,5 +1,5 @@
---- dialog_mutation_parameters.h.orig Sun Mar 16 19:22:14 2003
-+++ dialog_mutation_parameters.h Sun Mar 16 19:22:32 2003
+--- libevolvotron/dialog_mutation_parameters.h.orig Mon Dec 1 03:09:32 2003
++++ libevolvotron/dialog_mutation_parameters.h Mon Dec 1 03:10:15 2003
@@ -23,6 +23,7 @@
#ifndef _dialog_mutation_parameters_h_
#define _dialog_mutation_parameters_h_
diff --git a/graphics/evolvotron/files/patch-matrix.cpp b/graphics/evolvotron/files/patch-matrix.cpp
index ad2a6e4ce56a..9fcb6dd809f7 100644
--- a/graphics/evolvotron/files/patch-matrix.cpp
+++ b/graphics/evolvotron/files/patch-matrix.cpp
@@ -1,10 +1,10 @@
---- matrix.cpp.orig Thu Apr 17 17:49:39 2003
-+++ matrix.cpp Thu Apr 17 17:49:52 2003
+--- libevolvotron/matrix.cpp.orig Mon Dec 1 03:12:54 2003
++++ libevolvotron/matrix.cpp Mon Dec 1 03:13:12 2003
@@ -26,6 +26,7 @@
#include "random.h"
#include <iostream>
+#include <time.h>
+ //! Test code
void testmatrix_extract_runtime(Matrix<2,2,float>& m_out,const Matrix<3,3,float>& m_in)
- {
diff --git a/graphics/evolvotron/pkg-plist b/graphics/evolvotron/pkg-plist
index 881903f2b6a4..9e3e1d3967c7 100644
--- a/graphics/evolvotron/pkg-plist
+++ b/graphics/evolvotron/pkg-plist
@@ -1 +1,5 @@
bin/evolvotron
+bin/evolvotron_mutate
+bin/evolvotron_render
+%%PORTDOCS%%%%DOCSDIR%%/evolvotron.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%