aboutsummaryrefslogtreecommitdiff
path: root/graphics/evolvotron
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-04-17 16:03:35 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-04-17 16:03:35 +0000
commit2354d33181f3931bca0d769b9f102f2ac46e3c90 (patch)
tree2fe43dcd3ff921ba83dc9857ead53694a47521a3 /graphics/evolvotron
parent31bbd086c7c2f61f1efb058f43fb18e93b19a5b2 (diff)
downloadports-2354d33181f3931bca0d769b9f102f2ac46e3c90.tar.gz
ports-2354d33181f3931bca0d769b9f102f2ac46e3c90.zip
Evolvotron is interactive "generative art" software to evolve
images/textures/patterns through an iterative process of random mutation and user-selection driven evolution PR: 50232 Submitted by: David Yeske <dyeske@yahoo.com>
Notes
Notes: svn path=/head/; revision=79150
Diffstat (limited to 'graphics/evolvotron')
-rw-r--r--graphics/evolvotron/Makefile34
-rw-r--r--graphics/evolvotron/distinfo1
-rw-r--r--graphics/evolvotron/files/patch-dialog_mutation_parameters.h10
-rw-r--r--graphics/evolvotron/files/patch-matrix.cpp10
-rw-r--r--graphics/evolvotron/pkg-descr8
-rw-r--r--graphics/evolvotron/pkg-plist1
6 files changed, 64 insertions, 0 deletions
diff --git a/graphics/evolvotron/Makefile b/graphics/evolvotron/Makefile
new file mode 100644
index 000000000000..035abd098708
--- /dev/null
+++ b/graphics/evolvotron/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: evolvotron
+# Date created: 16 Mar 2003
+# Whom: David Yeske <dyeske@yahoo.com>
+#
+# $FreeBSD$
+
+PORTNAME= evolvotron
+PORTVERSION= 0.0.4
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= dyeske@yahoo.com
+COMMENT= Generative software that evolves images/textures/patterns
+
+WRKSRC= ${WRKDIR}
+
+QTDIR?= ${X11BASE}
+USE_QT_VER= 3
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+
+MAKE_ENV= QTDIR="${QTDIR}"
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} qmake \
+ -spec ${X11BASE}/share/qt/mkspecs/freebsd-g++ \
+ evolvotron.pro
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/evolvotron ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/evolvotron/distinfo b/graphics/evolvotron/distinfo
new file mode 100644
index 000000000000..f40ab108da7d
--- /dev/null
+++ b/graphics/evolvotron/distinfo
@@ -0,0 +1 @@
+MD5 (evolvotron-0.0.4.tar.gz) = 96444c348abfb6e680697f6cbf5ad98e
diff --git a/graphics/evolvotron/files/patch-dialog_mutation_parameters.h b/graphics/evolvotron/files/patch-dialog_mutation_parameters.h
new file mode 100644
index 000000000000..ed14ad16359d
--- /dev/null
+++ b/graphics/evolvotron/files/patch-dialog_mutation_parameters.h
@@ -0,0 +1,10 @@
+--- dialog_mutation_parameters.h.orig Sun Mar 16 19:22:14 2003
++++ dialog_mutation_parameters.h Sun Mar 16 19:22:32 2003
+@@ -23,6 +23,7 @@
+ #ifndef _dialog_mutation_parameters_h_
+ #define _dialog_mutation_parameters_h_
+
++#include <time.h>
+ #include <qdialog.h>
+ #include <qvbox.h>
+ #include <qgrid.h>
diff --git a/graphics/evolvotron/files/patch-matrix.cpp b/graphics/evolvotron/files/patch-matrix.cpp
new file mode 100644
index 000000000000..ad2a6e4ce56a
--- /dev/null
+++ b/graphics/evolvotron/files/patch-matrix.cpp
@@ -0,0 +1,10 @@
+--- matrix.cpp.orig Thu Apr 17 17:49:39 2003
++++ matrix.cpp Thu Apr 17 17:49:52 2003
+@@ -26,6 +26,7 @@
+ #include "random.h"
+
+ #include <iostream>
++#include <time.h>
+
+ void testmatrix_extract_runtime(Matrix<2,2,float>& m_out,const Matrix<3,3,float>& m_in)
+ {
diff --git a/graphics/evolvotron/pkg-descr b/graphics/evolvotron/pkg-descr
new file mode 100644
index 000000000000..8de8db713528
--- /dev/null
+++ b/graphics/evolvotron/pkg-descr
@@ -0,0 +1,8 @@
+Evolvotron is interactive "generative art" software to evolve
+images/textures/patterns through an iterative process of random
+mutation and user-selection driven evolution.
+
+WWW: http://www.bottlenose.demon.co.uk/share/evolvotron/
+
+- David
+dyeske@yahoo.com
diff --git a/graphics/evolvotron/pkg-plist b/graphics/evolvotron/pkg-plist
new file mode 100644
index 000000000000..881903f2b6a4
--- /dev/null
+++ b/graphics/evolvotron/pkg-plist
@@ -0,0 +1 @@
+bin/evolvotron