aboutsummaryrefslogtreecommitdiff
path: root/graphics/f-spot
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-05-16 06:41:48 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-05-16 06:41:48 +0000
commitb5a99d7b9298f704af69cd920d60b013fd717777 (patch)
tree083717244892bebe68ba450deb18108f3756dd13 /graphics/f-spot
parent9b12c0ad7e1eff6f5f49b03d807457ffb3a7d384 (diff)
downloadports-b5a99d7b9298f704af69cd920d60b013fd717777.tar.gz
ports-b5a99d7b9298f704af69cd920d60b013fd717777.zip
F-Spot is an application designed to provide personal photo management
to the GNOME desktop. Plans include import, export, printing and advanced sorting of digital images. F-Spot is written in C# using Mono and Gtk#. WWW: http://www.gnome.org/projects/f-spot/ BSD# - Project by: http://www.mono-project.com/Mono:FreeBSD
Notes
Notes: svn path=/head/; revision=135331
Diffstat (limited to 'graphics/f-spot')
-rw-r--r--graphics/f-spot/Makefile34
-rw-r--r--graphics/f-spot/distinfo2
-rw-r--r--graphics/f-spot/files/patch-src::f-spot.exe.config.in29
-rw-r--r--graphics/f-spot/pkg-descr6
-rw-r--r--graphics/f-spot/pkg-plist40
5 files changed, 111 insertions, 0 deletions
diff --git a/graphics/f-spot/Makefile b/graphics/f-spot/Makefile
new file mode 100644
index 000000000000..d713ac54bfee
--- /dev/null
+++ b/graphics/f-spot/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: f-spot
+# Date created: 20041008
+# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
+#
+# $Id: Makefile,v 1.5 2005/05/16 03:31:37 mezz7 Exp $
+# $FreeBSD$
+#
+
+PORTNAME= f-spot
+PORTVERSION= 0.0.13
+CATEGORIES= graphics gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.0
+
+MAINTAINER= tmclaugh@sdf.lonestar.org
+COMMENT= Personal photo management to the GNOME desktop
+
+LIB_DEPENDS= lcms.1:${PORTSDIR}/graphics/lcms \
+ exif.12:${PORTSDIR}/graphics/libexif \
+ sqlite.2:${PORTSDIR}/databases/sqlite2 \
+ gphoto2.2:${PORTSDIR}/graphics/libgphoto2
+BUILD_DEPENDS= gapi-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_GNOME= gnomehack gnomeprefix gnometarget intlhack
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER=15
+USE_GMAKE= yes
+
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/graphics/f-spot/distinfo b/graphics/f-spot/distinfo
new file mode 100644
index 000000000000..1d8f76293c63
--- /dev/null
+++ b/graphics/f-spot/distinfo
@@ -0,0 +1,2 @@
+MD5 (f-spot-0.0.13.tar.bz2) = 4666af7dfea7aeeef7c7cd5697a378c0
+SIZE (f-spot-0.0.13.tar.bz2) = 705222
diff --git a/graphics/f-spot/files/patch-src::f-spot.exe.config.in b/graphics/f-spot/files/patch-src::f-spot.exe.config.in
new file mode 100644
index 000000000000..69cfd83017e8
--- /dev/null
+++ b/graphics/f-spot/files/patch-src::f-spot.exe.config.in
@@ -0,0 +1,29 @@
+--- src/f-spot.exe.config.in.orig Sun May 15 22:07:34 2005
++++ src/f-spot.exe.config.in Sun May 15 22:07:40 2005
+@@ -1,14 +1,14 @@
+ <configuration>
+- <dllmap dll="libglib-2.0-0.dll" target="libglib-2.0.so.0"/>
+- <dllmap dll="libgobject-2.0-0.dll" target="libgobject-2.0.so.0"/>
+- <dllmap dll="libgtk-win32-2.0-0.dll" target="libgtk-x11-2.0.so.0"/>
+- <dllmap dll="libgdk-2.0-0.dll" target="libgdk-x11-2.0.so.0"/>
+- <dllmap dll="libgdk_pixbuf-2.0-0.dll" target="libgdk_pixbuf-2.0.so.0"/>
+- <dllmap dll="libgnomevfs-2-0.dll" target="libgnomevfs-2.so.0"/>
+- <dllmap dll="libgnomeui-2-0.dll" target="libgnomeui-2.so.0"/>
+- <dllmap dll="libfspot" target="@expanded_libdir@/f-spot/libfspot.so.0"/>
+- <dllmap dll="libfspoteog" target="@expanded_libdir@/f-spot/libfspoteog.so.0"/>
+- <dllmap dll="libfspotjpeg" target="@expanded_libdir@/f-spot/libfspotjpg.so.0"/>
+- <dllmap dll="liblcms-1.0.0.dll" target="liblcms.so.1"/>
+- <dllmap dll="libexif.dll" target="libexif.so.@EXIF_SOVERSION@"/>
++ <dllmap dll="libglib-2.0-0.dll" target="libglib-2.0.so"/>
++ <dllmap dll="libgobject-2.0-0.dll" target="libgobject-2.0.so"/>
++ <dllmap dll="libgtk-win32-2.0-0.dll" target="libgtk-x11-2.0.so"/>
++ <dllmap dll="libgdk-2.0-0.dll" target="libgdk-x11-2.0.so"/>
++ <dllmap dll="libgdk_pixbuf-2.0-0.dll" target="libgdk_pixbuf-2.0.so"/>
++ <dllmap dll="libgnomevfs-2-0.dll" target="libgnomevfs-2.so"/>
++ <dllmap dll="libgnomeui-2-0.dll" target="libgnomeui-2.so"/>
++ <dllmap dll="libfspot" target="@expanded_libdir@/f-spot/libfspot.so"/>
++ <dllmap dll="libfspoteog" target="@expanded_libdir@/f-spot/libfspoteog.so"/>
++ <dllmap dll="libfspotjpeg" target="@expanded_libdir@/f-spot/libfspotjpg.so"/>
++ <dllmap dll="liblcms-1.0.0.dll" target="liblcms.so"/>
++ <dllmap dll="libexif.dll" target="libexif.so"/>
+ </configuration>
diff --git a/graphics/f-spot/pkg-descr b/graphics/f-spot/pkg-descr
new file mode 100644
index 000000000000..a6961fdcd97a
--- /dev/null
+++ b/graphics/f-spot/pkg-descr
@@ -0,0 +1,6 @@
+F-Spot is an application designed to provide personal photo management
+to the GNOME desktop. Plans include import, export, printing and
+advanced sorting of digital images. F-Spot is written in C# using Mono
+and Gtk#.
+
+WWW: http://www.gnome.org/projects/f-spot/
diff --git a/graphics/f-spot/pkg-plist b/graphics/f-spot/pkg-plist
new file mode 100644
index 000000000000..6d9f0e9368e2
--- /dev/null
+++ b/graphics/f-spot/pkg-plist
@@ -0,0 +1,40 @@
+bin/f-spot
+lib/f-spot/f-spot.exe
+lib/f-spot/f-spot.exe.config
+lib/f-spot/libfspot.a
+lib/f-spot/libfspot.so
+lib/f-spot/libfspot.so.0
+lib/f-spot/libfspoteog.a
+lib/f-spot/libfspoteog.so
+lib/f-spot/libfspoteog.so.0
+lib/f-spot/libfspotjpegtran.a
+lib/f-spot/libfspotjpegtran.so
+lib/f-spot/libfspotjpegtran.so.0
+lib/f-spot/libgphoto2-sharp.dll
+lib/f-spot/libgphoto2-sharp.dll.config
+share/gnome/applications/f-spot.desktop
+share/gnome/pixmaps/f-spot-logo.png
+share/locale/bg/LC_MESSAGES/f-spot.mo
+share/locale/ca/LC_MESSAGES/f-spot.mo
+share/locale/cs/LC_MESSAGES/f-spot.mo
+share/locale/da/LC_MESSAGES/f-spot.mo
+share/locale/de/LC_MESSAGES/f-spot.mo
+share/locale/el/LC_MESSAGES/f-spot.mo
+share/locale/en_CA/LC_MESSAGES/f-spot.mo
+share/locale/en_GB/LC_MESSAGES/f-spot.mo
+share/locale/es/LC_MESSAGES/f-spot.mo
+share/locale/eu/LC_MESSAGES/f-spot.mo
+share/locale/fr/LC_MESSAGES/f-spot.mo
+share/locale/hu/LC_MESSAGES/f-spot.mo
+share/locale/it/LC_MESSAGES/f-spot.mo
+share/locale/ja/LC_MESSAGES/f-spot.mo
+share/locale/nb/LC_MESSAGES/f-spot.mo
+share/locale/nl/LC_MESSAGES/f-spot.mo
+share/locale/no/LC_MESSAGES/f-spot.mo
+share/locale/pl/LC_MESSAGES/f-spot.mo
+share/locale/rw/LC_MESSAGES/f-spot.mo
+share/locale/sv/LC_MESSAGES/f-spot.mo
+share/locale/zh_CN/LC_MESSAGES/f-spot.mo
+@unexec rmdir %D/share/locale/rw/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/rw 2> /dev/null || true
+@dirrm lib/f-spot