aboutsummaryrefslogtreecommitdiff
path: root/graphics/fly
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-10-17 13:58:21 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-10-17 13:58:21 +0000
commit9af25b7e9c3813f1d33a911cd99bc73f24a34248 (patch)
tree3e8ff9824aed2f61355caec5ac15143846e4e899 /graphics/fly
parentdfb35d8f89dc40f80a1b1cc869d2f986756e9a85 (diff)
downloadports-9af25b7e9c3813f1d33a911cd99bc73f24a34248.tar.gz
ports-9af25b7e9c3813f1d33a911cd99bc73f24a34248.zip
Add in a null-pointer check to fail with an error message when fly is given
an input file of the wrong type (or a corrupt file). Bump PORTREVISION. PR: ports/86137 Submitted by: Nick Fishman <kwlogical@bellsouth.net>
Notes
Notes: svn path=/head/; revision=145659
Diffstat (limited to 'graphics/fly')
-rw-r--r--graphics/fly/Makefile1
-rw-r--r--graphics/fly/files/patch-fly.c14
2 files changed, 15 insertions, 0 deletions
diff --git a/graphics/fly/Makefile b/graphics/fly/Makefile
index 7f190010777d..b9a2aa505693 100644
--- a/graphics/fly/Makefile
+++ b/graphics/fly/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fly
PORTVERSION= 2.0.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://members.optushome.com.au/martingleeson/%SUBDIR%/ \
http://martin.gleeson.com/%SUBDIR%/
diff --git a/graphics/fly/files/patch-fly.c b/graphics/fly/files/patch-fly.c
new file mode 100644
index 000000000000..8dbccf2e1c38
--- /dev/null
+++ b/graphics/fly/files/patch-fly.c
@@ -0,0 +1,14 @@
+--- fly.c.orig Sun Nov 25 19:39:28 2001
++++ fly.c Mon Oct 17 23:48:51 2005
+@@ -1270,6 +1270,11 @@
+ } else {
+ img_file = gdImageCreateFromPng(img_to_copy);
+ }
++ if (img_file == NULL) {
++ fprintf(stderr, "Error: Cannot read image file \"%s\" of type \"%s\"\n",
++ filename, imgtype == GIF ? "gif" : (imgtype == JPEG ? "jpeg" : "png"));
++ exit(1);
++ }
+ fclose(img_to_copy);
+
+ if( resize == 1 )