aboutsummaryrefslogtreecommitdiff
path: root/graphics/fpc-graph
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-12-05 23:29:36 +0000
committerJohn Marino <marino@FreeBSD.org>2015-12-05 23:29:36 +0000
commitf01cba6e50575183cf50dc87ded17319b63e1a14 (patch)
tree6ef0e1020a116341931d3335d3863622b9586ead /graphics/fpc-graph
parentc502e77d8f318117c0982f8999f2e243e8ef511c (diff)
downloadports-f01cba6e50575183cf50dc87ded17319b63e1a14.tar.gz
ports-f01cba6e50575183cf50dc87ded17319b63e1a14.zip
FPC ecosystem: Upgrade version 2.6.4 => 3.0.0
This is the first major release of FreePascal in nearly four years. There are a ton of new features, way more to list here. see: http://wiki.freepascal.org/FPC_New_Features_3.0 Several new unit ports were added, some were contracted. Most of those were absorbed into the main FPC packages, but two units are no longer supported: sndfile and matroshka. All 99 remaining ports (including Lazarus ports) were build tested on FreeBSD i386 and amd64 Release 10.2
Notes
Notes: svn path=/head/; revision=403082
Diffstat (limited to 'graphics/fpc-graph')
-rw-r--r--graphics/fpc-graph/Makefile3
-rw-r--r--graphics/fpc-graph/files/patch-packages_graph_fpmake.pp67
-rw-r--r--graphics/fpc-graph/pkg-plist11
3 files changed, 72 insertions, 9 deletions
diff --git a/graphics/fpc-graph/Makefile b/graphics/fpc-graph/Makefile
index 3100b9c05245..f53a49633c31 100644
--- a/graphics/fpc-graph/Makefile
+++ b/graphics/fpc-graph/Makefile
@@ -1,14 +1,13 @@
# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 3
CATEGORIES= graphics lang
PKGNAMESUFFIX= -graph
MAINTAINER= freebsd-fpc@FreeBSD.org
COMMENT= Free Pascal interface to graphical applications
-USE_FPC= x11 sdl pthreads
+USE_FPC= sdl x11 ${ARCH:Mi386:S/i386/pthreads/}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
diff --git a/graphics/fpc-graph/files/patch-packages_graph_fpmake.pp b/graphics/fpc-graph/files/patch-packages_graph_fpmake.pp
new file mode 100644
index 000000000000..f40b3671e659
--- /dev/null
+++ b/graphics/fpc-graph/files/patch-packages_graph_fpmake.pp
@@ -0,0 +1,67 @@
+--- packages/graph/fpmake.pp.orig 2015-11-13 21:15:29 UTC
++++ packages/graph/fpmake.pp
+@@ -26,14 +26,14 @@ begin
+ P.NeedLibC:= false; // true for headers that indirectly link to libc? OS specific?
+
+ P.CPUs:=[i386,x86_64,powerpc,i8086];
+- P.OSes:=[go32v2,win32,win64,linux,freebsd,darwin,msdos];
++ P.OSes:=[go32v2,win32,win64,linux,dragonfly,freebsd,darwin,msdos];
+
+- P.Dependencies.Add('sdl',[i386,powerpc],[win32,linux,freebsd,darwin]);
++ P.Dependencies.Add('sdl',[i386,powerpc],[win32,linux,dragonfly,freebsd,darwin]);
+ P.Dependencies.Add('ptc',[win32,win64,linux]);
+
+ // Dependencies for ptc, due to fpcmake bug:
+ P.Dependencies.Add('fcl-base',[win32,win64,linux]);
+- P.Dependencies.Add('x11',[freebsd,linux]); // ptc only depends on reebsd and linux on x11
++ P.Dependencies.Add('x11',[dragonfly,freebsd,linux]); // ptc only depends on reebsd and linux on x11
+ P.Dependencies.Add('hermes',[win32,win64,linux]);
+ P.Dependencies.Add('opengl',[win32,win64,linux]);
+
+@@ -44,15 +44,15 @@ begin
+ P.SourcePath.Add('src/go32v2',[go32v2]);
+ P.SourcePath.Add('src/msdos',[msdos]);
+ P.SourcePath.Add('src/win32',[win32,win64]);
+- P.SourcePath.Add('src/unix',[freebsd,linux]); // Darwin has own.
++ P.SourcePath.Add('src/unix',[dragonfly,freebsd,linux]); // Darwin has own.
+
+ P.IncludePath.Add('src/inc');
+ P.IncludePath.Add('src/go32v2',[go32v2]);
+ P.IncludePath.Add('src/msdos',[msdos]);
+- P.IncludePath.Add('src/unix',[freebsd,linux]); // Darwin has own.
++ P.IncludePath.Add('src/unix',[dragonfly,freebsd,linux]); // Darwin has own.
+ P.IncludePath.Add('src/go32v2',[go32v2]);
+
+- T:=P.Targets.AddUnit('ggigraph.pp',[linux,freebsd]);
++ T:=P.Targets.AddUnit('ggigraph.pp',[linux,dragonfly,freebsd]);
+ with T.Dependencies do
+ begin
+ AddInclude('graphh.inc');
+@@ -76,10 +76,10 @@ begin
+ AddInclude('modes.inc');
+ AddInclude('fills.inc');
+ AddInclude('gtext.inc');
+- AddInclude('graph16.inc',[freebsd,linux]);
++ AddInclude('graph16.inc',[dragonfly,freebsd,linux]);
+ end;
+ // Graph unit other targets
+- T:=P.Targets.AddUnit('graph.pp',[go32v2,amiga,win32,win64,freebsd,msdos]);
++ T:=P.Targets.AddUnit('graph.pp',[go32v2,amiga,win32,win64,dragonfly,freebsd,msdos]);
+ with T.Dependencies do
+ begin
+ AddInclude('graphh.inc');
+@@ -90,12 +90,12 @@ begin
+ AddInclude('modes.inc');
+ AddInclude('fills.inc');
+ AddInclude('gtext.inc');
+- AddInclude('graph16.inc',[freebsd,linux]);
++ AddInclude('graph16.inc',[dragonfly,freebsd,linux]);
+ AddInclude('vesa.inc',[go32v2,msdos]);
+ AddInclude('vesah.inc',[go32v2,msdos]);
+ end;
+
+- T:=P.Targets.AddUnit('src/sdlgraph/sdlgraph.pp',[i386,powerpc],[win32,linux,freebsd,darwin]);
++ T:=P.Targets.AddUnit('src/sdlgraph/sdlgraph.pp',[i386,powerpc],[win32,linux,dragonfly,freebsd,darwin]);
+ with T.Dependencies do
+ begin
+ AddInclude('graphh.inc');
diff --git a/graphics/fpc-graph/pkg-plist b/graphics/fpc-graph/pkg-plist
index b98a7f64be3c..9a8c50420855 100644
--- a/graphics/fpc-graph/pkg-plist
+++ b/graphics/fpc-graph/pkg-plist
@@ -1,10 +1,7 @@
-lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/Package.fpc
-lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/graph.ppu
+lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/graph.fpm
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/ggigraph.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/ggigraph.ppu
-%%FPC_I386%%lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/sdlgraph.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/graph.o
-lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/ggigraph.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/graph.ppu
%%FPC_I386%%lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/sdlgraph.o
-lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/libpgraph.a
-lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/libpggigraph.a
-%%FPC_I386%%lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/libpsdlgraph.a
+%%FPC_I386%%lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/sdlgraph.ppu