aboutsummaryrefslogtreecommitdiff
path: root/graphics/fraqtive
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2005-09-07 21:05:27 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2005-09-07 21:05:27 +0000
commit889ec1900a289f6ab6b3903efaae7f3021391329 (patch)
tree98c1695d633655a2c4b6ac90e9956ad20df89a43 /graphics/fraqtive
parent682f1eab307709da366170a45cbf2bbfeba1a17e (diff)
downloadports-889ec1900a289f6ab6b3903efaae7f3021391329.tar.gz
ports-889ec1900a289f6ab6b3903efaae7f3021391329.zip
Add fraqtive 0.3.1, a program for drawing Mandelbrot and Julia fractals.
It uses a very fast algorithm and generates high quality, smooth images. It is fully interactive, allowing for real-time mouse navigation and dynamic generation of the Julia fractal preview. OpenGL-rendered 3D view of the fractals is also supported. WWW: http://zeus.polsl.gliwice.pl/~mimec/index.php?id=fraqtive
Notes
Notes: svn path=/head/; revision=142188
Diffstat (limited to 'graphics/fraqtive')
-rw-r--r--graphics/fraqtive/Makefile26
-rw-r--r--graphics/fraqtive/distinfo2
-rw-r--r--graphics/fraqtive/pkg-descr7
-rw-r--r--graphics/fraqtive/pkg-plist48
4 files changed, 83 insertions, 0 deletions
diff --git a/graphics/fraqtive/Makefile b/graphics/fraqtive/Makefile
new file mode 100644
index 000000000000..44705971ee6e
--- /dev/null
+++ b/graphics/fraqtive/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: fraqtive
+# Date created: Wed Sep 7 22:29:05 CEST 2005
+# Whom: Markus Brueffer <markus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fraqtive
+PORTVERSION= 0.3.1
+CATEGORIES= graphics kde
+MASTER_SITES= http://zeus.polsl.gliwice.pl/%7Emimec/files/
+
+MAINTAINER= markus@FreeBSD.org
+COMMENT= Draws Mandelbrot and Julia fractals
+
+USE_BZIP2= yes
+USE_KDELIBS_VER=3
+USE_GL= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/graphics/fraqtive/distinfo b/graphics/fraqtive/distinfo
new file mode 100644
index 000000000000..e25660e8bb07
--- /dev/null
+++ b/graphics/fraqtive/distinfo
@@ -0,0 +1,2 @@
+MD5 (fraqtive-0.3.1.tar.bz2) = edc51dfcf61183df9cb3eb1b18a71137
+SIZE (fraqtive-0.3.1.tar.bz2) = 507994
diff --git a/graphics/fraqtive/pkg-descr b/graphics/fraqtive/pkg-descr
new file mode 100644
index 000000000000..5b83438d6e2d
--- /dev/null
+++ b/graphics/fraqtive/pkg-descr
@@ -0,0 +1,7 @@
+Fraqtive is a program for drawing Mandelbrot and Julia fractals. It uses a
+very fast algorithm and generates high quality, smooth images. It is fully
+interactive, allowing for real-time mouse navigation and dynamic generation
+of the Julia fractal preview. OpenGL-rendered 3D view of the fractals is
+also supported.
+
+WWW: http://zeus.polsl.gliwice.pl/~mimec/index.php?id=fraqtive
diff --git a/graphics/fraqtive/pkg-plist b/graphics/fraqtive/pkg-plist
new file mode 100644
index 000000000000..eaeb1dc91dc6
--- /dev/null
+++ b/graphics/fraqtive/pkg-plist
@@ -0,0 +1,48 @@
+bin/fraqtive
+share/applnk/Utilities/fraqtive.desktop
+share/apps/fraqtive/fraqtiveui.rc
+share/apps/fraqtive/icons/hicolor/16x16/actions/frdisplay.png
+share/apps/fraqtive/icons/hicolor/16x16/actions/frgradedit.png
+share/apps/fraqtive/icons/hicolor/16x16/actions/frgradinv.png
+share/apps/fraqtive/icons/hicolor/16x16/actions/frparams.png
+share/apps/fraqtive/icons/hicolor/16x16/actions/frtab2d.png
+share/apps/fraqtive/icons/hicolor/16x16/actions/frtab3d.png
+share/apps/fraqtive/icons/hicolor/22x22/actions/frgradedit.png
+share/apps/fraqtive/icons/hicolor/22x22/actions/frgradinv.png
+share/config/fraqtiverc
+share/doc/HTML/de/fraqtive/common
+share/doc/HTML/de/fraqtive/index.cache.bz2
+share/doc/HTML/de/fraqtive/index.docbook
+share/doc/HTML/en/fraqtive/common
+share/doc/HTML/en/fraqtive/index.cache.bz2
+share/doc/HTML/en/fraqtive/index.docbook
+share/icons/hicolor/16x16/apps/fraqtive.png
+share/icons/hicolor/32x32/apps/fraqtive.png
+share/icons/hicolor/48x48/apps/fraqtive.png
+share/locale/de/LC_MESSAGES/fraqtive.mo
+share/locale/et/LC_MESSAGES/fraqtive.mo
+share/locale/fr/LC_MESSAGES/fraqtive.mo
+share/locale/it/LC_MESSAGES/fraqtive.mo
+share/locale/nl/LC_MESSAGES/fraqtive.mo
+share/locale/pl/LC_MESSAGES/fraqtive.mo
+share/locale/pt/LC_MESSAGES/fraqtive.mo
+share/locale/ru/LC_MESSAGES/fraqtive.mo
+share/locale/sr/LC_MESSAGES/fraqtive.mo
+share/locale/sv/LC_MESSAGES/fraqtive.mo
+share/locale/vi/LC_MESSAGES/fraqtive.mo
+@unexec rmdir %D/share/locale/sr/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/sr 2>/dev/null || true
+@unexec rmdir %D/share/locale/pt/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/pt 2>/dev/null || true
+@unexec rmdir %D/share/locale/pl/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/pl 2>/dev/null || true
+@dirrm share/doc/HTML/en/fraqtive
+@dirrm share/doc/HTML/de/fraqtive
+@unexec rmdir %D/share/config 2>/dev/null || true
+@dirrm share/apps/fraqtive/icons/hicolor/22x22/actions
+@dirrm share/apps/fraqtive/icons/hicolor/22x22
+@dirrm share/apps/fraqtive/icons/hicolor/16x16/actions
+@dirrm share/apps/fraqtive/icons/hicolor/16x16
+@dirrm share/apps/fraqtive/icons/hicolor
+@dirrm share/apps/fraqtive/icons
+@dirrm share/apps/fraqtive