aboutsummaryrefslogtreecommitdiff
path: root/graphics/ftgl
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-07-11 17:55:23 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-07-11 17:55:23 +0000
commit4a0e10141c7cecd269bfc57f4b8099abaeeea7e5 (patch)
treed6148380416b815969e85c862fa2f18cb5fb400e /graphics/ftgl
parent7a292d3664577963c7229b45e2d3fb050b31a38f (diff)
downloadports-4a0e10141c7cecd269bfc57f4b8099abaeeea7e5.tar.gz
ports-4a0e10141c7cecd269bfc57f4b8099abaeeea7e5.zip
- Update ftgl to 2.1.3-rc5 (previous version was either 2.0.5 (from .pc file) or 2.1.2 (from distfile name), not 2.12), take maintainership
- Update dependent port (games/duel) - use LIB_DEPENDS for ftgl and bumb PORTREVISION Approved by: alepulver (games/duel maintainer), miwi (mentor)
Notes
Notes: svn path=/head/; revision=216709
Diffstat (limited to 'graphics/ftgl')
-rw-r--r--graphics/ftgl/Makefile44
-rw-r--r--graphics/ftgl/distinfo6
-rw-r--r--graphics/ftgl/files/makefile.ex30
-rw-r--r--graphics/ftgl/files/patch-include-FTTextureGlyph.h11
-rw-r--r--graphics/ftgl/files/patch-unix_Makefile22
-rw-r--r--graphics/ftgl/pkg-plist84
6 files changed, 24 insertions, 173 deletions
diff --git a/graphics/ftgl/Makefile b/graphics/ftgl/Makefile
index 2158ea4bc0fa..d1d29ab7252b 100644
--- a/graphics/ftgl/Makefile
+++ b/graphics/ftgl/Makefile
@@ -6,47 +6,29 @@
#
PORTNAME= ftgl
-PORTVERSION= 2.12
-PORTREVISION= 2
+DISTVERSION= 2.1.3-rc5
+PORTEPOCH= 1
CATEGORIES= graphics
-MASTER_SITES= http://opengl.geek.nz/ftgl/
-DISTNAME= ${PORTNAME}-${PORTVERSION:C/([[:digit:]])$/.\1/}
+MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= amdmi3@FreeBSD.org
COMMENT= An OpenGL FreeType fonts rendering library
-BUILD_DEPENDS= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
USE_GMAKE= yes
-USE_GL= gl
+USE_GL= gl glu
+USE_XORG= x11 xext xmu
GNU_CONFIGURE= yes
-WRKSRC= ${WRKDIR}/${PORTNAME:U}
-CONFIGURE_WRKSRC= ${WRKSRC}/unix
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-gl-inc=${LOCALBASE}/include --with-gl-lib=${LOCALBASE}/lib
-BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
-INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
-MAKE_ENV= MKDIR="${MKDIR}"
+CONFIGURE_ARGS= --with-gl-inc="${LOCALBASE}/include" \
+ --without-glut-inc
+USE_GNOME= gnomehack
+USE_LDCONFIG= yes
-.ifdef (NOPORTDOCS)
-DO_INSTALL_DOCS=\#
-.endif
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:S/-/~/}
post-patch:
- @${REINPLACE_CMD} -e 's|%%PORTDOCS%%|${DO_INSTALL_DOCS}|' \
- ${BUILD_WRKSRC}/Makefile
-
-post-install:
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/demo/* ${EXAMPLESDIR}
- @${SED} -e 's|%%CC%%|${CC}|g; \
- s|%%CXX%%|${CXX}|g; \
- s|%%RM%%|${RM}|g; \
- s|%%CFLAGS%%|${CFLAGS}|g; \
- s|%%CXXFLAGS%%|${CXXFLAGS}|g; \
- s|%%PREFIX%%|${PREFIX}|g; \
- s|%%LOCALBASE%%|${LOCALBASE}|g' \
- <${FILESDIR}/makefile.ex >${EXAMPLESDIR}/makefile
+ @${REINPLACE_CMD} -e '/SUBDIRS/ s|docs||; /SUBDIRS/ s|demo||' \
+ ${WRKSRC}/Makefile.in
.include <bsd.port.mk>
diff --git a/graphics/ftgl/distinfo b/graphics/ftgl/distinfo
index 17c6e3366d7b..492f4318d001 100644
--- a/graphics/ftgl/distinfo
+++ b/graphics/ftgl/distinfo
@@ -1,3 +1,3 @@
-MD5 (ftgl-2.1.2.tar.gz) = 3eabec9ad37371c4d139408c7ffd2429
-SHA256 (ftgl-2.1.2.tar.gz) = 83bf45ce03495bb0c0159a678144877b0dbc7d2f3d8e9f0aa006e72c5198d15f
-SIZE (ftgl-2.1.2.tar.gz) = 568497
+MD5 (ftgl-2.1.3-rc5.tar.gz) = fcf4d0567b7de9875d4e99a9f7423633
+SHA256 (ftgl-2.1.3-rc5.tar.gz) = 5458d62122454869572d39f8aa85745fc05d5518001bcefa63bd6cbb8d26565b
+SIZE (ftgl-2.1.3-rc5.tar.gz) = 841597
diff --git a/graphics/ftgl/files/makefile.ex b/graphics/ftgl/files/makefile.ex
deleted file mode 100644
index 791f527a0a19..000000000000
--- a/graphics/ftgl/files/makefile.ex
+++ /dev/null
@@ -1,30 +0,0 @@
-# Make sure, that you have graphics/libglut installed
-# in order to build example program
-#
-# $FreeBSD$
-
-CC= %%CC%%
-CXX= %%CXX%%
-RM= %%RM%%
-CFLAGS= %%CFLAGS%% -I. -I%%LOCALBASE%%/include -I%%PREFIX%%/include/FTGL
-CXXFLAGS= %%CXXFLAGS%% -I. -I%%LOCALBASE%%/include -I%%PREFIX%%/include/FTGL
-LDFLAGS= -L%%LOCALBASE%%/lib -L%%LOCALBASE%%/lib -lglut -lftgl
-
-FREETYPE_CFLAGS!=%%LOCALBASE%%/bin/freetype-config --cflags
-FREETYPE_LFLAGS!=%%LOCALBASE%%/bin/freetype-config --libs
-
-CFLAGS+= ${FREETYPE_CFLAGS}
-CXXFLAGS+= ${FREETYPE_CFLAGS}
-LDFLAGS+= ${FREETYPE_LFLAGS}
-
-FTGLDemo: tb.o trackball.o FTGLDemo.o
- ${CXX} $> -o $@ ${LDFLAGS}
-
-.cpp.o:
- ${CXX} -c ${CXXFLAGS} $*.cpp
-
-.c.o:
- ${CC} -c ${CFLAGS} $*.c
-
-clean:
- ${RM} -f FTGLDemo *.o
diff --git a/graphics/ftgl/files/patch-include-FTTextureGlyph.h b/graphics/ftgl/files/patch-include-FTTextureGlyph.h
deleted file mode 100644
index 586fc5c07060..000000000000
--- a/graphics/ftgl/files/patch-include-FTTextureGlyph.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/FTTextureGlyph.h.orig Tue May 29 21:42:13 2007
-+++ include/FTTextureGlyph.h Tue May 29 21:42:51 2007
-@@ -52,7 +52,7 @@
- * Reset the currently active texture to zero to get into a known state before
- * drawing a string. This is to get round possible threading issues.
- */
-- static void FTTextureGlyph::ResetActiveTexture(){ activeTextureID = 0;}
-+ static void ResetActiveTexture(){ activeTextureID = 0;}
-
- private:
- /**
diff --git a/graphics/ftgl/files/patch-unix_Makefile b/graphics/ftgl/files/patch-unix_Makefile
deleted file mode 100644
index f888fcdaac3e..000000000000
--- a/graphics/ftgl/files/patch-unix_Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
---- unix/Makefile.orig Mon Jan 13 00:27:04 2003
-+++ unix/Makefile Thu Jun 17 17:20:29 2004
-@@ -1,7 +1,7 @@
- top_builddir=.
- -include $(top_builddir)/Make.conf
-
--SUBDIRS = src demo docs
-+SUBDIRS = src demo %%PORTDOCS%%docs
-
- AUTOGEN = Make.conf config.log config.status libtool autom4te.cache ftgl.pc
- AUTOGEN_MAINT = aclocal.m4 acinclude.m4 config.guess config.sub configure ltmain.sh install-sh
-@@ -16,8 +16,8 @@
- ./configure
-
- install-local: ftgl.pc
-- $(INSTALL) -d -m 0755 $(libdir)/pkgconfig
-- $(INSTALL) -m 0644 ftgl.pc $(libdir)/pkgconfig/
-+ ${MKDIR} ${PREFIX}/libdata/pkgconfig
-+ $(INSTALL) -m 0644 ftgl.pc ${PREFIX}/libdata/pkgconfig/
-
- maint-clean-local:
- $(RM) $(AUTOGEN_MAINT)
diff --git a/graphics/ftgl/pkg-plist b/graphics/ftgl/pkg-plist
index 5e7ad057a78d..c05968e97184 100644
--- a/graphics/ftgl/pkg-plist
+++ b/graphics/ftgl/pkg-plist
@@ -1,12 +1,10 @@
include/FTGL/FTBBox.h
include/FTGL/FTBitmapGlyph.h
-include/FTGL/FTCharToGlyphIndexMap.h
-include/FTGL/FTCharmap.h
-include/FTGL/FTContour.h
+include/FTGL/FTBuffer.h
+include/FTGL/FTBufferFont.h
+include/FTGL/FTBufferGlyph.h
include/FTGL/FTExtrdGlyph.h
-include/FTGL/FTFace.h
include/FTGL/FTFont.h
-include/FTGL/FTGL.h
include/FTGL/FTGLBitmapFont.h
include/FTGL/FTGLExtrdFont.h
include/FTGL/FTGLOutlineFont.h
@@ -14,83 +12,17 @@ include/FTGL/FTGLPixmapFont.h
include/FTGL/FTGLPolygonFont.h
include/FTGL/FTGLTextureFont.h
include/FTGL/FTGlyph.h
-include/FTGL/FTGlyphContainer.h
-include/FTGL/FTLibrary.h
-include/FTGL/FTList.h
+include/FTGL/FTLayout.h
include/FTGL/FTOutlineGlyph.h
include/FTGL/FTPixmapGlyph.h
include/FTGL/FTPoint.h
include/FTGL/FTPolyGlyph.h
-include/FTGL/FTSize.h
+include/FTGL/FTSimpleLayout.h
include/FTGL/FTTextureGlyph.h
-include/FTGL/FTVector.h
-include/FTGL/FTVectoriser.h
+include/FTGL/ftgl.h
lib/libftgl.a
lib/libftgl.la
+lib/libftgl.so
+lib/libftgl.so.2
libdata/pkgconfig/ftgl.pc
-%%EXAMPLESDIR%%/makefile
-%%EXAMPLESDIR%%/tb.c
-%%EXAMPLESDIR%%/trackball.c
-%%EXAMPLESDIR%%/FTGLDemo.cpp
-%%EXAMPLESDIR%%/tb.h
-%%EXAMPLESDIR%%/trackball.h
-%%EXAMPLESDIR%%/README.txt
-%%PORTDOCS%%%%DOCSDIR%%/html/FTBitmapGlyph_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTBitmapGlyph_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTCharmap_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTCharmap_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTContour_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTContour_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTExtrdGlyph_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTExtrdGlyph_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTFace_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTFace_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTFont_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTFont_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTGLBitmapFont_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTGLBitmapFont_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTGLExtrdFont_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTGLExtrdFont_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTGLOutlineFont_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTGLOutlineFont_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTGLPixmapFont_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTGLPixmapFont_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTGLPolygonFont_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTGLPolygonFont_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTGLTextureFont_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTGLTextureFont_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTGlyphContainer_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTGlyphContainer_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTGlyph_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTGlyph_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTLibrary_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTLibrary_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTOutlineGlyph_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTOutlineGlyph_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTPixmapGlyph_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTPixmapGlyph_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTPoint_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTPoint_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTPolyGlyph_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTPolyGlyph_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTSize_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTSize_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTTextureGlyph_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTTextureGlyph_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTVectoriser_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/FTVectoriser_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.css
-%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.png
-%%PORTDOCS%%%%DOCSDIR%%/html/files.html
-%%PORTDOCS%%%%DOCSDIR%%/html/globals.html
-%%PORTDOCS%%%%DOCSDIR%%/html/globals_func.html
-%%PORTDOCS%%%%DOCSDIR%%/html/globals_vars.html
-%%PORTDOCS%%%%DOCSDIR%%/html/index.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tab_b.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/tab_l.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/tab_r.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/tabs.css
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/FTGL
-@dirrm %%EXAMPLESDIR%%