aboutsummaryrefslogtreecommitdiff
path: root/graphics/ftgl
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-06-20 07:13:50 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-06-20 07:13:50 +0000
commit3fd24b3e84c2b8abdb3c4d69e9497417a613cd05 (patch)
treee0a86b5a68dc3a31b37f9306a12507ac4a08674f /graphics/ftgl
parentbf3fff33fe5b9841b51276c6f7d970866e5e6068 (diff)
downloadports-3fd24b3e84c2b8abdb3c4d69e9497417a613cd05.tar.gz
ports-3fd24b3e84c2b8abdb3c4d69e9497417a613cd05.zip
Update to version 2.0.9
PR: ports/67963 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=111838
Diffstat (limited to 'graphics/ftgl')
-rw-r--r--graphics/ftgl/Makefile50
-rw-r--r--graphics/ftgl/distinfo4
-rw-r--r--graphics/ftgl/files/makefile.ex6
-rw-r--r--graphics/ftgl/files/patch-FTFace.cpp11
-rw-r--r--graphics/ftgl/files/patch-unix_Makefile22
-rw-r--r--graphics/ftgl/files/patch-unix_src_Makefile13
-rw-r--r--graphics/ftgl/pkg-plist118
7 files changed, 147 insertions, 77 deletions
diff --git a/graphics/ftgl/Makefile b/graphics/ftgl/Makefile
index 97e00333ca72..ac0a638a83e8 100644
--- a/graphics/ftgl/Makefile
+++ b/graphics/ftgl/Makefile
@@ -6,53 +6,49 @@
#
PORTNAME= ftgl
-PORTVERSION= 2.07
-PORTREVISION= 1
+PORTVERSION= 2.09
CATEGORIES= graphics
MASTER_SITES= http://homepages.paradise.net.nz/henryj/code/
-DISTNAME= ${PORTNAME:U}
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/([[:digit:]])$/.\1/}
MAINTAINER= tiamat@comset.net
COMMENT= An OpenGL FreeType fonts rendering library
+BUILD_DEPENDS= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
USE_GMAKE= yes
USE_GL= yes
USE_X_PREFIX= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_WRKSRC= ${WRKDIR}/${DISTNAME}/unix
+WRKSRC= ${WRKDIR}/${PORTNAME:U}
+CONFIGURE_WRKSRC= ${WRKSRC}/unix
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-gl-inc=${X11BASE}/include --with-gl-lib=${X11BASE}/lib
BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
-INSTALLS_SHLIB= yes
+MAKE_ENV= MKDIR="${MKDIR}"
-do-install:
- ${INSTALL_DATA} ${INSTALL_WRKSRC}/src/.libs/lib${PORTNAME}.a ${PREFIX}/lib
- ${INSTALL_DATA} ${INSTALL_WRKSRC}/${PORTNAME}.pc ${PREFIX}/libdata/pkgconfig
- @${MKDIR} ${PREFIX}/include/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/include/*.h ${PREFIX}/include/${PORTNAME}
+.ifdef (NOPORTDOCS)
+DO_INSTALL_DOCS=\#
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PORTDOCS%%|${DO_INSTALL_DOCS}|' \
+ ${BUILD_WRKSRC}/Makefile
+post-install:
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/demo/* ${EXAMPLESDIR}
- ${PERL} -pi -e 's|%%CC%%|${CC}|g; \
- s|%%CXX%%|${CXX}|g; \
- s|%%RM%%|${RM}|g; \
- s|%%CFLAGS%%|${CFLAGS}|g; \
- s|%%CXXFLAGS%%|${CXXFLAGS}|g; \
- s|%%PREFIX%%|${PREFIX}|g; \
- s|%%X11BASE%%|${X11BASE}|g; \
- s|%%LOCALBASE%%|${LOCALBASE}|g' \
+ @${SED} -e 's|%%CC%%|${CC}|g; \
+ s|%%CXX%%|${CXX}|g; \
+ s|%%RM%%|${RM}|g; \
+ s|%%CFLAGS%%|${CFLAGS}|g; \
+ s|%%CXXFLAGS%%|${CXXFLAGS}|g; \
+ s|%%PREFIX%%|${PREFIX}|g; \
+ s|%%X11BASE%%|${X11BASE}|g; \
+ s|%%LOCALBASE%%|${LOCALBASE}|g' \
<${FILESDIR}/makefile.ex >${EXAMPLESDIR}/makefile
-.ifndef (NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/FTGL.html ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/FTGL_1_3.gif ${DOCSDIR}
- @${MKDIR} ${DOCSDIR}/images
- ${INSTALL_DATA} ${WRKSRC}/docs/images/* ${DOCSDIR}/images
-.endif
-
.include <bsd.port.mk>
diff --git a/graphics/ftgl/distinfo b/graphics/ftgl/distinfo
index 93127a7ac047..d13508685862 100644
--- a/graphics/ftgl/distinfo
+++ b/graphics/ftgl/distinfo
@@ -1,2 +1,2 @@
-MD5 (FTGL.tar.gz) = 62d363867d4906a428640e661c97f74f
-SIZE (FTGL.tar.gz) = 569505
+MD5 (ftgl-2.0.9.tar.gz) = 2268267277c0655688879d0657b82650
+SIZE (ftgl-2.0.9.tar.gz) = 561543
diff --git a/graphics/ftgl/files/makefile.ex b/graphics/ftgl/files/makefile.ex
index fd5a4f6a4488..87cb60068063 100644
--- a/graphics/ftgl/files/makefile.ex
+++ b/graphics/ftgl/files/makefile.ex
@@ -1,11 +1,13 @@
# Make sure, that you have graphics/libglut installed
# in order to build example program
+#
+# $FreeBSD$
CC= %%CC%%
CXX= %%CXX%%
RM= %%RM%%
-CFLAGS= %%CFLAGS%% -I. -I%%X11BASE%%/include -I%%PREFIX%%/include/ftgl
-CXXFLAGS= %%CXXFLAGS%% -I. -I%%X11BASE%%/include -I%%PREFIX%%/include/ftgl
+CFLAGS= %%CFLAGS%% -I. -I%%X11BASE%%/include -I%%PREFIX%%/include/FTGL
+CXXFLAGS= %%CXXFLAGS%% -I. -I%%X11BASE%%/include -I%%PREFIX%%/include/FTGL
LDFLAGS= -L%%X11BASE%%/lib -L%%PREFIX%%/lib -lglut -lftgl
FREETYPE_CFLAGS!=%%LOCALBASE%%/bin/freetype-config --cflags
diff --git a/graphics/ftgl/files/patch-FTFace.cpp b/graphics/ftgl/files/patch-FTFace.cpp
deleted file mode 100644
index 1fda65627a1d..000000000000
--- a/graphics/ftgl/files/patch-FTFace.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/FTFace.cpp.orig Fri Jan 16 13:23:11 2004
-+++ src/FTFace.cpp Fri Jan 16 13:23:23 2004
-@@ -62,7 +62,7 @@
- {
- FT_Open_Args open;
-
-- open.flags = (FT_Open_Flags)1; // FT_OPEN_MEMORY;
-+ open.flags = /*(FT_Open_Flags)*/1; // FT_OPEN_MEMORY;
- open.memory_base = (FT_Byte *)pBufferBytes;
- open.memory_size = bufferSizeInBytes;
-
diff --git a/graphics/ftgl/files/patch-unix_Makefile b/graphics/ftgl/files/patch-unix_Makefile
new file mode 100644
index 000000000000..f888fcdaac3e
--- /dev/null
+++ b/graphics/ftgl/files/patch-unix_Makefile
@@ -0,0 +1,22 @@
+--- unix/Makefile.orig Mon Jan 13 00:27:04 2003
++++ unix/Makefile Thu Jun 17 17:20:29 2004
+@@ -1,7 +1,7 @@
+ top_builddir=.
+ -include $(top_builddir)/Make.conf
+
+-SUBDIRS = src demo docs
++SUBDIRS = src demo %%PORTDOCS%%docs
+
+ AUTOGEN = Make.conf config.log config.status libtool autom4te.cache ftgl.pc
+ AUTOGEN_MAINT = aclocal.m4 acinclude.m4 config.guess config.sub configure ltmain.sh install-sh
+@@ -16,8 +16,8 @@
+ ./configure
+
+ install-local: ftgl.pc
+- $(INSTALL) -d -m 0755 $(libdir)/pkgconfig
+- $(INSTALL) -m 0644 ftgl.pc $(libdir)/pkgconfig/
++ ${MKDIR} ${PREFIX}/libdata/pkgconfig
++ $(INSTALL) -m 0644 ftgl.pc ${PREFIX}/libdata/pkgconfig/
+
+ maint-clean-local:
+ $(RM) $(AUTOGEN_MAINT)
diff --git a/graphics/ftgl/files/patch-unix_src_Makefile b/graphics/ftgl/files/patch-unix_src_Makefile
new file mode 100644
index 000000000000..68d515eff880
--- /dev/null
+++ b/graphics/ftgl/files/patch-unix_src_Makefile
@@ -0,0 +1,13 @@
+--- unix/src/Makefile.orig Tue Jun 15 11:39:46 2004
++++ unix/src/Makefile Tue Jun 15 11:40:03 2004
+@@ -75,8 +75,8 @@
+ install-local: libftgl.la
+ $(INSTALL) -d -m 0755 $(libdir)
+ $(LIBTOOL) --mode=install $(INSTALL) -m 0644 $(TARGET) $(libdir)
+- $(INSTALL) -d -m 0755 $(includedir)/FTGL
+- $(INSTALL) -m 0644 $(HEADER_FILES) $(includedir)/FTGL
++ $(INSTALL) -d -m 0755 $(includedir)/FTGL
++ $(INSTALL) -m 0644 $(HEADER_FILES) $(includedir)/FTGL
+
+
+ clean-local:
diff --git a/graphics/ftgl/pkg-plist b/graphics/ftgl/pkg-plist
index c2cffc5b5405..5dfcca4da4b7 100644
--- a/graphics/ftgl/pkg-plist
+++ b/graphics/ftgl/pkg-plist
@@ -1,32 +1,32 @@
-include/ftgl/FTBBox.h
-include/ftgl/FTBitmapGlyph.h
-include/ftgl/FTCharToGlyphIndexMap.h
-include/ftgl/FTCharmap.h
-include/ftgl/FTContour.h
-include/ftgl/FTExtrdGlyph.h
-include/ftgl/FTFace.h
-include/ftgl/FTFont.h
-include/ftgl/FTGL.h
-include/ftgl/FTGLBitmapFont.h
-include/ftgl/FTGLExtrdFont.h
-include/ftgl/FTGLOutlineFont.h
-include/ftgl/FTGLPixmapFont.h
-include/ftgl/FTGLPolygonFont.h
-include/ftgl/FTGLTextureFont.h
-include/ftgl/FTGlyph.h
-include/ftgl/FTGlyphContainer.h
-include/ftgl/FTLibrary.h
-include/ftgl/FTList.h
-include/ftgl/FTOutlineGlyph.h
-include/ftgl/FTPixmapGlyph.h
-include/ftgl/FTPoint.h
-include/ftgl/FTPolyGlyph.h
-include/ftgl/FTSize.h
-include/ftgl/FTTextureGlyph.h
-include/ftgl/FTVector.h
-include/ftgl/FTVectoriser.h
-@dirrm include/ftgl
+include/FTGL/FTBBox.h
+include/FTGL/FTBitmapGlyph.h
+include/FTGL/FTCharToGlyphIndexMap.h
+include/FTGL/FTCharmap.h
+include/FTGL/FTContour.h
+include/FTGL/FTExtrdGlyph.h
+include/FTGL/FTFace.h
+include/FTGL/FTFont.h
+include/FTGL/FTGL.h
+include/FTGL/FTGLBitmapFont.h
+include/FTGL/FTGLExtrdFont.h
+include/FTGL/FTGLOutlineFont.h
+include/FTGL/FTGLPixmapFont.h
+include/FTGL/FTGLPolygonFont.h
+include/FTGL/FTGLTextureFont.h
+include/FTGL/FTGlyph.h
+include/FTGL/FTGlyphContainer.h
+include/FTGL/FTLibrary.h
+include/FTGL/FTList.h
+include/FTGL/FTOutlineGlyph.h
+include/FTGL/FTPixmapGlyph.h
+include/FTGL/FTPoint.h
+include/FTGL/FTPolyGlyph.h
+include/FTGL/FTSize.h
+include/FTGL/FTTextureGlyph.h
+include/FTGL/FTVector.h
+include/FTGL/FTVectoriser.h
lib/libftgl.a
+lib/libftgl.la
libdata/pkgconfig/ftgl.pc
%%EXAMPLESDIR%%/makefile
%%EXAMPLESDIR%%/tb.c
@@ -35,11 +35,59 @@ libdata/pkgconfig/ftgl.pc
%%EXAMPLESDIR%%/tb.h
%%EXAMPLESDIR%%/trackball.h
%%EXAMPLESDIR%%/README.txt
-@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%%%DOCSDIR%%/images/ftgldemo.jpg
-%%PORTDOCS%%%%DOCSDIR%%/images/metrics.png
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
-%%PORTDOCS%%%%DOCSDIR%%/FTGL_1_3.gif
-%%PORTDOCS%%%%DOCSDIR%%/FTGL.html
-%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/FTBitmapGlyph_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTBitmapGlyph_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTCharmap_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTCharmap_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTContour_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTContour_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTExtrdGlyph_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTExtrdGlyph_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTFace_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTFace_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTFont_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTFont_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTGLBitmapFont_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTGLBitmapFont_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTGLExtrdFont_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTGLExtrdFont_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTGLOutlineFont_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTGLOutlineFont_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTGLPixmapFont_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTGLPixmapFont_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTGLPolygonFont_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTGLPolygonFont_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTGLTextureFont_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTGLTextureFont_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTGlyphContainer_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTGlyphContainer_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTGlyph_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTGlyph_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTLibrary_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTLibrary_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTOutlineGlyph_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTOutlineGlyph_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTPixmapGlyph_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTPixmapGlyph_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTPoint_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTPoint_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTPolyGlyph_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTPolyGlyph_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTSize_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTSize_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTTextureGlyph_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTTextureGlyph_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTVectoriser_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FTVectoriser_8cpp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.css
+%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.png
+%%PORTDOCS%%%%DOCSDIR%%/html/files.html
+%%PORTDOCS%%%%DOCSDIR%%/html/globals.html
+%%PORTDOCS%%%%DOCSDIR%%/html/globals_func.html
+%%PORTDOCS%%%%DOCSDIR%%/html/globals_vars.html
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@unexec rmdir %D/libdata/pkgconfig 2>/dev/null || true
+@dirrm include/FTGL
+@dirrm %%EXAMPLESDIR%%