aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimp-gmic-plugin
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-06-17 18:02:31 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-06-17 18:02:31 +0000
commit8fe96d89460a1c2298ae4fb6475dfa8b97103ca4 (patch)
tree267f8e57ae6a7d102a39bb4dd6541c28e797f982 /graphics/gimp-gmic-plugin
parent3cb84d5257597bda8977d711080e7c0e7f238e4a (diff)
downloadports-8fe96d89460a1c2298ae4fb6475dfa8b97103ca4.tar.gz
ports-8fe96d89460a1c2298ae4fb6475dfa8b97103ca4.zip
- update to 1.5.1.5
Notes
Notes: svn path=/head/; revision=299468
Diffstat (limited to 'graphics/gimp-gmic-plugin')
-rw-r--r--graphics/gimp-gmic-plugin/Makefile4
-rw-r--r--graphics/gimp-gmic-plugin/distinfo4
-rw-r--r--graphics/gimp-gmic-plugin/files/patch-Makefile34
3 files changed, 10 insertions, 32 deletions
diff --git a/graphics/gimp-gmic-plugin/Makefile b/graphics/gimp-gmic-plugin/Makefile
index dad9a9a4910f..e315f5818fb8 100644
--- a/graphics/gimp-gmic-plugin/Makefile
+++ b/graphics/gimp-gmic-plugin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gmic
-PORTVERSION= 1.5.1.0
-PORTREVISION= 2
+PORTVERSION= 1.5.1.5
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME} \
SF/${PORTNAME}/old
@@ -59,7 +58,6 @@ PLIST_SUB+= BASH="@comment "
post-patch:
@${REINPLACE_CMD} -e 's#/usr/X11R6#${PREFIX}#g' \
- -e 's/-lcv -lhighgui/-lopencv_legacy/g' \
${WRKSRC}/Makefile
do-install:
diff --git a/graphics/gimp-gmic-plugin/distinfo b/graphics/gimp-gmic-plugin/distinfo
index 7db6d2713deb..d91c36d3934d 100644
--- a/graphics/gimp-gmic-plugin/distinfo
+++ b/graphics/gimp-gmic-plugin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gmic_1.5.1.0.tar.gz) = 1622d3d8365e3b8720e13f5fc4eb58dfecb944535f9334255a5ea99e14ba6074
-SIZE (gmic_1.5.1.0.tar.gz) = 1958110
+SHA256 (gmic_1.5.1.5.tar.gz) = 00a914640819ac553b68a0caae822e7bf5e9ae28b15ffeb04b3bb096c08a2e61
+SIZE (gmic_1.5.1.5.tar.gz) = 1945107
diff --git a/graphics/gimp-gmic-plugin/files/patch-Makefile b/graphics/gimp-gmic-plugin/files/patch-Makefile
index 733852f54a83..42d6d8eae6b5 100644
--- a/graphics/gimp-gmic-plugin/files/patch-Makefile
+++ b/graphics/gimp-gmic-plugin/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2012-01-20 17:27:10.000000000 +0400
-+++ Makefile 2012-02-14 22:26:16.000000000 +0400
+--- ./Makefile.orig 2012-06-08 13:20:14.000000000 +0400
++++ ./Makefile 2012-06-17 12:57:52.000000000 +0400
@@ -56,7 +56,7 @@
USR = /opt/local
else
@@ -18,29 +18,9 @@
# Flags to enable image display, using GDI32.
# This requires the presence of the GDI32 include and library files.
-@@ -164,13 +164,13 @@
- # Flags to enable native support of webcams, using the OpenCV library.
- # This requires the presence of the OpenCV include and library files.
- # (package 'libcv3-2-dev' on Debian).
--OPENCV_CFLAGS = -Dcimg_use_opencv -I$(USR)/include/opencv
--ifeq ($(OS),Darwin)
--OPENCV_LDFLAGS = -lopencv_core -lopencv_highgui # Use this for OpenCV 2.2.0 !
--else
--OPENCV_LDFLAGS = -lcv -lhighgui
-+#OPENCV_CFLAGS = -Dcimg_use_opencv -I$(USR)/include/opencv
-+#ifeq ($(OS),Darwin)
-+#OPENCV_LDFLAGS = -lopencv_core -lopencv_highgui # Use this for OpenCV 2.2.0 !
-+#else
-+#OPENCV_LDFLAGS = -lcv -lhighgui
- # OPENCV_LDFLAGS = -lopencv_core -lopencv_highgui # Use this for OpenCV 2.2.0 !
--endif
-+#endif
-
- # Flags to enable native support of most classical image file formats, using the GraphicsMagick++ library.
- # This requires the presence of the GraphicsMagick++ include and library files.
-@@ -271,6 +271,14 @@
- $(MAKE) gimp
+@@ -273,6 +273,14 @@
$(MAKE) lib
+ $(MAKE) zart
else
+ifeq ($(OS),FreeBSD)
+ @echo "**"
@@ -53,7 +33,7 @@
ifeq ($(OS),Darwin)
@echo "**"
@echo "** MacOSX configuration"
-@@ -287,9 +295,10 @@
+@@ -290,9 +298,10 @@
$(MAKE) gimp
endif
endif
@@ -64,8 +44,8 @@
+ $(MAKE) "CFLAGS+=$(STD_GIMP_CFLAGS)" "LDFLAGS+=$(STD_GIMP_LDFLAGS)" "STRIP_EXE=1" gmic_gimp
lib:
- $(MAKE) "CFLAGS=$(STD_LIB_CFLAGS) $(OPT_CFLAGS)" "LDFLAGS+=$(STD_LIB_LDFLAGS)" gmic_lib
-@@ -304,6 +313,9 @@
+ $(MAKE) "CFLAGS=$(STD_LIB_CFLAGS) $(OPT_CFLAGS)" "LDFLAGS+=$(STD_LIB_LDFLAGS) $(OPT_LDFLAGS)" gmic_lib
+@@ -314,6 +323,9 @@
linux:
$(MAKE) "CFLAGS=$(STD_UNIX_CFLAGS) $(OPT_CFLAGS)" "LDFLAGS=$(STD_UNIX_LDFLAGS)" "STRIP_EXE=1" gmic_gmic