aboutsummaryrefslogtreecommitdiff
path: root/graphics/glew/files
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2011-05-09 19:32:30 +0000
committerMarcus von Appen <mva@FreeBSD.org>2011-05-09 19:32:30 +0000
commit0ecda0884419564ff62399aebcbe4265a91d084f (patch)
treedbd57bd8e0c77d7b885754e36dac41466c42577e /graphics/glew/files
parent4cd553a3d8141371c4e13dc1fd799959f32a760e (diff)
downloadports-0ecda0884419564ff62399aebcbe4265a91d084f.tar.gz
ports-0ecda0884419564ff62399aebcbe4265a91d084f.zip
- Update to 1.6.0
Notes
Notes: svn path=/head/; revision=273886
Diffstat (limited to 'graphics/glew/files')
-rw-r--r--graphics/glew/files/patch-config_Makefile.freebsd32
1 files changed, 18 insertions, 14 deletions
diff --git a/graphics/glew/files/patch-config_Makefile.freebsd b/graphics/glew/files/patch-config_Makefile.freebsd
index 263f718789c1..8258f2300278 100644
--- a/graphics/glew/files/patch-config_Makefile.freebsd
+++ b/graphics/glew/files/patch-config_Makefile.freebsd
@@ -1,16 +1,12 @@
---- config/Makefile.freebsd.orig 2008-11-03 07:25:19.000000000 +0100
-+++ config/Makefile.freebsd 2009-05-04 22:03:30.000000000 +0200
-@@ -1,20 +1,20 @@
+--- config/Makefile.freebsd.orig 2011-04-27 18:16:34.000000000 +0200
++++ config/Makefile.freebsd 2011-05-09 19:43:51.000000000 +0200
+@@ -1,22 +1,22 @@
NAME = $(GLEW_NAME)
-CC = cc
-LD = ld
+-LDFLAGS.EXTRA = -L/usr/X11R6/lib
+CC ?= cc
+LD ?= ld
- ifneq (undefined, $(origin GLEW_MX))
- CFLAGS.EXTRA = -DGLEW_MX
- endif
- LDFLAGS.SO = -shared -soname $(LIB.SONAME)
--LDFLAGS.EXTRA = -L/usr/X11R6/lib
+LDFLAGS.EXTRA = -L${LOCALBASE}/lib
LDFLAGS.GL = -lXmu -lXi -lGLU -lGL -lXext -lX11
LDFLAGS.STATIC = -Wl,-Bstatic
@@ -21,9 +17,17 @@
WARN = -Wall -W
POPT = -O2
BIN.SUFFIX =
--LIB.SONAME = lib$(NAME).so.$(SO_MAJOR)
-+LIB.SONAME = lib$(NAME).so.$(GLEW_MAJOR)
- LIB.DEVLNK = lib$(NAME).so
--LIB.SHARED = lib$(NAME).so.$(SO_VERSION)
-+LIB.SHARED = lib$(NAME).so.$(GLEW_VERSION)
- LIB.STATIC = lib$(NAME).a
+-LIB.SONAME = lib$(NAME).so.$(SO_MAJOR)
++LIB.SONAME = lib$(NAME).so.$(GLEW_MAJOR)
+ LIB.DEVLNK = lib$(NAME).so
+-LIB.SHARED = lib$(NAME).so.$(SO_VERSION)
++LIB.SHARED = lib$(NAME).so.$(GLEW_VERSION)
+ LIB.STATIC = lib$(NAME).a
+ LDFLAGS.SO = -shared -soname $(LIB.SONAME)
+-LIB.SONAME.MX = lib$(NAME)mx.so.$(SO_MAJOR)
++LIB.SONAME.MX = lib$(NAME)mx.so.$(GLEW_MAJOR)
+ LIB.DEVLNK.MX = lib$(NAME)mx.so
+-LIB.SHARED.MX = lib$(NAME)mx.so.$(SO_VERSION)
++LIB.SHARED.MX = lib$(NAME)mx.so.$(GLEW_VERSION)
+ LIB.STATIC.MX = lib$(NAME)mx.a
+ LDFLAGS.SO.MX = -shared -soname $(LIB.SONAME.MX)