aboutsummaryrefslogtreecommitdiff
path: root/graphics/gltt
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-11-21 14:56:44 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-11-21 14:56:44 +0000
commit035f39a84a94fb4abff4948e8175cacda58e9afb (patch)
tree5def5fa914f88fd953a6fb8ff494f31dd5b6062c /graphics/gltt
parentf995aa7cbf430a9fea1802a77200ac3d181c7f1d (diff)
downloadports-035f39a84a94fb4abff4948e8175cacda58e9afb.tar.gz
ports-035f39a84a94fb4abff4948e8175cacda58e9afb.zip
- Fix build with gcc 4.2
PR: 118084 Submitted by: Pietro Cerutti <gahr@gahr.ch> Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=202785
Diffstat (limited to 'graphics/gltt')
-rw-r--r--graphics/gltt/Makefile8
-rw-r--r--graphics/gltt/files/patch-GLTTGlyphPolygonizerHandler.h10
2 files changed, 11 insertions, 7 deletions
diff --git a/graphics/gltt/Makefile b/graphics/gltt/Makefile
index 47ff3d3b0082..ae6e297460d1 100644
--- a/graphics/gltt/Makefile
+++ b/graphics/gltt/Makefile
@@ -32,10 +32,4 @@ CONFIGURE_ARGS= --with-ttf-includes=${LOCALBASE}/include/freetype1 \
--with-glut-libraries=${X11BASE}/lib
USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/gltt/files/patch-GLTTGlyphPolygonizerHandler.h b/graphics/gltt/files/patch-GLTTGlyphPolygonizerHandler.h
new file mode 100644
index 000000000000..7b0ec1051f96
--- /dev/null
+++ b/graphics/gltt/files/patch-GLTTGlyphPolygonizerHandler.h
@@ -0,0 +1,10 @@
+--- GLTTGlyphPolygonizerHandler.h.orig 2007-11-16 11:59:00.000000000 +0100
++++ GLTTGlyphPolygonizerHandler.h 2007-11-16 11:59:58.000000000 +0100
+@@ -28,6 +28,7 @@
+ #include "FTGlyphVectorizer.h"
+ #endif
+
++class GLTTGlyphPolygonizer;
+ /////////////////////////////////////////////////////////////////////////////
+
+ // Mmh, this class name is a bit long... /SR