aboutsummaryrefslogtreecommitdiff
path: root/graphics/gnash
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-18 06:11:54 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-18 06:11:54 +0000
commit86b1f2ee439a576e1774e0fc45176a47abc37e2d (patch)
treeb86df756d73f959e904c469395cd7146e4f1c2ca /graphics/gnash
parent94de23caddc010183c9ac06e1672d95ef3462dc4 (diff)
downloadports-86b1f2ee439a576e1774e0fc45176a47abc37e2d.tar.gz
ports-86b1f2ee439a576e1774e0fc45176a47abc37e2d.zip
- fix Unterminated quoted string on FreeBSD 9.x
- fix unexpected operator on FreeBSD 7.x - merge REINPLACE_CMD
Notes
Notes: svn path=/head/; revision=299542
Diffstat (limited to 'graphics/gnash')
-rw-r--r--graphics/gnash/Makefile10
-rw-r--r--graphics/gnash/files/patch-configure33
-rw-r--r--graphics/gnash/pkg-plist1
3 files changed, 35 insertions, 9 deletions
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index 97735424ffe5..27e7b3f7e407 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnash
PORTVERSION= 0.8.10
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= GNU/${PORTNAME}/${PORTVERSION}/
@@ -37,10 +38,9 @@ MAKE_JOBS_SAFE= yes
INSTALLS_ICONS= yes
# jemalloc leads to infinite recursion on FreeBSD
-# --enable-avm2 doesn't build (but consider for future)
CONFIGURE_ARGS= --with-boost-incl="${LOCALBASE}/include" \
--with-boost-lib="${LOCALBASE}/lib" \
- --disable-testsuite --disable-avm2 \
+ --disable-testsuite \
--with-plugins-install=prefix \
--sysconfdir="${WRKDIR}/etc" \
--disable-jemalloc \
@@ -254,13 +254,11 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e '/^PTHREAD_[LC][IF]*=/ d; s|-lpthread|${PTHREAD_LIBS}|' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g; \
+ -e '/KDE4_APPSDATADIR=/ s|share/kde4|share|' \
+ -e 's|/usr/local|${LOCALBASE}|g; \
s|/lib64|/lib|g; \
s|/usr/X11R6|${LOCALBASE}|g' ${WRKSRC}/configure \
${WRKSRC}/macros/libslist ${WRKSRC}/macros/incllist
- @${REINPLACE_CMD} -e '/KDE4_APPSDATADIR=/ s|share/kde4|share|' \
- ${WRKSRC}/configure
@${REINPLACE_CMD} -e '/^pkgconfigdir =/ s|libdir)|exec_prefix)/libdata|' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/^man1dir =/ s|=.*|= ${MAN1PREFIX}/man/man1|' \
diff --git a/graphics/gnash/files/patch-configure b/graphics/gnash/files/patch-configure
index 6e15aee6dc61..a0fdb4e1189a 100644
--- a/graphics/gnash/files/patch-configure
+++ b/graphics/gnash/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2011-03-18 09:50:30.000000000 -0400
-+++ configure 2011-07-23 14:50:23.436294372 -0400
-@@ -27778,6 +27778,11 @@
+--- configure.orig 2012-01-19 20:19:29.000000000 +0100
++++ configure 2012-06-18 07:47:13.000000000 +0200
+@@ -30836,6 +30836,11 @@
esac
fi
@@ -12,3 +12,30 @@
if test x"${with_kde4_plugindir}" != x ; then
KDE4_PLUGINDIR="${with_kde4_plugindir}"
else
+@@ -49394,7 +49399,7 @@
+
+ if test x$build_agg = xyes; then # {
+ echo " AGG Pixel format is: $pixelformat"
+- if test x"$AGG_LIBS" != x -a x"${agg25}" == xyes; then # {
++ if test x"$AGG_LIBS" != x -a x"${agg25}" = xyes; then # {
+ if test x"$AGG_CFLAGS" != x; then # {
+ echo " AGG flags are: $AGG_CFLAGS"
+ else # }{
+@@ -50044,7 +50049,7 @@
+ else
+
+ pkg_out_fd=3
+- echo " ERROR: `echo "No SSL development package is installed, but it's enabled."" | fold -s -w 62 | sed 's/^/ /' | tr '\n' '#' | cut -b 18- | tr '#' '\n'`" >&$pkg_out_fd
++ echo " ERROR: `echo "No SSL development package is installed, but it's enabled." | fold -s -w 62 | sed 's/^/ /' | tr '\n' '#' | cut -b 18- | tr '#' '\n'`" >&$pkg_out_fd
+ deb_dest="$deb_err"
+ rpm_dest="$rpm_err"
+ yast_dest="$yast_err"
+@@ -50063,7 +50068,7 @@
+ else
+
+ pkg_out_fd=3
+- echo " ERROR: `echo "No SSH development package is installed, but it's enabled."" | fold -s -w 62 | sed 's/^/ /' | tr '\n' '#' | cut -b 18- | tr '#' '\n'`" >&$pkg_out_fd
++ echo " ERROR: `echo "No SSH development package is installed, but it's enabled." | fold -s -w 62 | sed 's/^/ /' | tr '\n' '#' | cut -b 18- | tr '#' '\n'`" >&$pkg_out_fd
+ deb_dest="$deb_err"
+ rpm_dest="$rpm_err"
+ yast_dest="$yast_err"
diff --git a/graphics/gnash/pkg-plist b/graphics/gnash/pkg-plist
index 6a14737b0147..e73a7e5db125 100644
--- a/graphics/gnash/pkg-plist
+++ b/graphics/gnash/pkg-plist
@@ -250,6 +250,7 @@ share/locale/zh_TW/LC_MESSAGES/gnash.mo
@dirrmtry share/icons/hicolor/32x32
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
+@dirrm %%DOCSDIR%%/images
@dirrm %%DATADIR%%
@dirrmtry share/applications
@dirrm lib/gnash