aboutsummaryrefslogtreecommitdiff
path: root/graphics/gnash
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-05-08 05:46:58 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-05-08 05:46:58 +0000
commit5ad81fb9c476b68ca033f5ae6d7568006617a9c0 (patch)
tree93da04cc10ee6afdfa9b565a6181dff81b320b82 /graphics/gnash
parenta2aebbb8825a2037d9b6c6f05387688743038015 (diff)
downloadports-5ad81fb9c476b68ca033f5ae6d7568006617a9c0.tar.gz
ports-5ad81fb9c476b68ca033f5ae6d7568006617a9c0.zip
Update to 0.7.1 release.
Approved by: maintainer
Notes
Notes: svn path=/head/; revision=161675
Diffstat (limited to 'graphics/gnash')
-rw-r--r--graphics/gnash/Makefile22
-rw-r--r--graphics/gnash/distinfo6
-rw-r--r--graphics/gnash/files/patch-macros_gtkglext.m411
-rw-r--r--graphics/gnash/files/patch-macros_pango.m429
-rw-r--r--graphics/gnash/files/patch-macros_sdl.m435
5 files changed, 10 insertions, 93 deletions
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index 1ddf6125b196..6256e372f67c 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -6,12 +6,10 @@
#
PORTNAME= gnash
-PORTVERSION= 0.7
-PORTREVISION= 2
+PORTVERSION= 0.7.1
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= ale
-DISTNAME= ${PORTNAME}-20060422
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
MAINTAINER= amdmi3@mail.ru
COMMENT= GNU Flash movie player
@@ -23,14 +21,12 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
USE_BZIP2= yes
USE_GL= yes
USE_GMAKE= yes
+GNU_CONFIGURE= yes
USE_GNOME= gnomehier glib20 pkgconfig libxml2
USE_SDL= sdl mixer
USE_X_PREFIX= yes
USE_GCC= 3.4+
-USE_AUTOTOOLS= aclocal:19 autoheader:259 automake:19 autoconf:259
-ACLOCAL_ARGS= --acdir=${ACLOCAL_DIR} -I ${WRKSRC}/macros
-
PLUGIN_DIR= ${PREFIX}/lib/browser_plugins
CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -Wl,--rpath,${PREFIX}/lib/gnash"
@@ -38,8 +34,6 @@ CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -Wl,--rpath,${PREFIX}/lib/gnash"
CONFIGURE_ARGS= --libdir="${PREFIX}/lib/gnash" \
--with-plugindir=${PLUGIN_DIR}
-WRKSRC= ${WRKDIR}/${PORTNAME}-20060422
-
OPTIONS= PLUGIN "Enable firefox plugin" off
.include <bsd.port.pre.mk>
@@ -54,12 +48,10 @@ PLIST_SUB+= PLUGIN=""
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/macros/*.m4
- @${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/macros/*.m4
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/macros/*.m4
- @${REINPLACE_CMD} -e 's|^AM_LDFLAGS = \\|AM_LDFLAGS = $$(PTHREAD_LIBS) \\|' ${WRKSRC}/utilities/Makefile.am
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g;s|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
.if !defined(WITH_PLUGIN)
- @${REINPLACE_CMD} -e '/STD_DIRS/ s|plugin||' ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -e '/STD_DIRS/ s|plugin||' ${WRKSRC}/Makefile.in
.endif
.include <bsd.port.post.mk>
diff --git a/graphics/gnash/distinfo b/graphics/gnash/distinfo
index 5c88ee6d5292..bd20ce887e05 100644
--- a/graphics/gnash/distinfo
+++ b/graphics/gnash/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnash-20060422.tar.bz2) = d9332c78458a0998a2574385f15f886a
-SHA256 (gnash-20060422.tar.bz2) = 5ea45388159c6a231386b073d72076b5d76dda0319518b5a328ebf6fbbd5fdc2
-SIZE (gnash-20060422.tar.bz2) = 3140402
+MD5 (gnash-0.7.1.tar.bz2) = d860981aeaac0fc941a28abc3c24223c
+SHA256 (gnash-0.7.1.tar.bz2) = 48fcb533e3989757c23af2b9130c8b490a4d40375be4813ce425efea82ae0f62
+SIZE (gnash-0.7.1.tar.bz2) = 1089794
diff --git a/graphics/gnash/files/patch-macros_gtkglext.m4 b/graphics/gnash/files/patch-macros_gtkglext.m4
deleted file mode 100644
index c7a642a15137..000000000000
--- a/graphics/gnash/files/patch-macros_gtkglext.m4
+++ /dev/null
@@ -1,11 +0,0 @@
---- macros/gtkglext.m4.orig Sat Apr 22 11:45:05 2006
-+++ macros/gtkglext.m4 Sat Apr 22 11:38:54 2006
-@@ -132,7 +132,7 @@
- for i in $libslist; do
- if test -f $i/libgtkglext-x11-${version}.a -o -f $i/libgtkglext-x11-${version}.so; then
- if test x"$i" != x"/usr/lib"; then
-- ac_cv_path_glext_lib="$i"
-+ ac_cv_path_glext_lib="-L$i -lgtkglext-x11-${version} -lgdkglext-x11-${version}"
- break
- fi
- else
diff --git a/graphics/gnash/files/patch-macros_pango.m4 b/graphics/gnash/files/patch-macros_pango.m4
deleted file mode 100644
index 5c81a4fff43b..000000000000
--- a/graphics/gnash/files/patch-macros_pango.m4
+++ /dev/null
@@ -1,29 +0,0 @@
---- macros/pango.m4.orig Sat Apr 22 10:10:07 2006
-+++ macros/pango.m4 Sat Apr 22 11:34:01 2006
-@@ -56,7 +56,7 @@
- dnl doesn't seem to get a directory that is unversioned.
- if test x"${ac_cv_path_pango_incl}" = x; then
- AC_MSG_CHECKING([for the Pango Version])
-- pathlist="/sw/include /usr/local/include /home/latest/include /opt/include /usr/include /usr/pkg/include .. ../.."
-+ pathlist="${prefix}/include /sw/include /usr/local/include /home/latest/include /opt/include /usr/include /usr/pkg/include .. ../.."
-
- topdir=""
- version=""
-@@ -82,7 +82,7 @@
- AC_CHECK_HEADERS(pango/pango.h, [ac_cv_path_pango_incl=""],[
- if test x"${ac_cv_path_pango_incl}" = x; then
- AC_MSG_CHECKING([for libpango header])
-- incllist="/sw/include /usr/local/include /home/latest/include /opt/include /usr/include /usr/pkg/include .. ../.."
-+ incllist="${prefix}/include /sw/include /usr/local/include /home/latest/include /opt/include /usr/include /usr/pkg/include .. ../.."
-
- for i in $incllist; do
- if test -f $i/pango/pango.h; then
-@@ -122,7 +122,7 @@
- if test x"${ac_cv_path_pango_incl}" != x; then
- AC_CHECK_LIB(pango-${version}, pango_engine_shape_class_init, [ac_cv_path_pango_lib="-lpango-${version}"],[
- AC_MSG_CHECKING([for libpango library])
-- libslist="/usr/lib64 /usr/lib /sw/lib /usr/local/lib /home/latest/lib /opt/lib /usr/pkg/lib .. ../.."
-+ libslist="${prefix}/lib /usr/lib64 /usr/lib /sw/lib /usr/local/lib /home/latest/lib /opt/lib /usr/pkg/lib .. ../.."
- for i in $libslist; do
- if test -f $i/libpango-${version}.a -o -f $i/libpango-${version}.so; then
- if test x"$i" != x"/usr/lib"; then
diff --git a/graphics/gnash/files/patch-macros_sdl.m4 b/graphics/gnash/files/patch-macros_sdl.m4
deleted file mode 100644
index ce7b199a2fed..000000000000
--- a/graphics/gnash/files/patch-macros_sdl.m4
+++ /dev/null
@@ -1,35 +0,0 @@
---- macros/sdl.m4.orig Sat Apr 22 11:10:23 2006
-+++ macros/sdl.m4 Sat Apr 22 11:03:46 2006
-@@ -59,8 +59,8 @@
- ac_cv_path_sdl_incl=$i/SDL/include
- break
- fi
-- if test -f $i/include/SDL/SDL.h; then
-- ac_cv_path_sdl_incl=$i/include/SDL
-+ if test -f $i/include/SDL11/SDL.h; then
-+ ac_cv_path_sdl_incl=$i/include/SDL11
- break
- fi
- done
-@@ -94,17 +94,17 @@
-
- SDL_LIBS=""
- if test x"${ac_cv_path_sdl_lib}" = x ; then
-- AC_CHECK_LIB(SDL, SDL_Init, [ac_cv_path_sdl_lib="-lSDL"],[
-+ AC_CHECK_LIB(SDL-1.1, SDL_Init, [ac_cv_path_sdl_lib="-lSDL-1.1"],[
- AC_MSG_CHECKING([for SDL library])
- liblist="${prefix}/lib64 ${prefix}/lib /usr/lib64 /usr/lib /usr/pkg/lib /sw/lib /usr/local/lib /home/latest/lib /opt/lib.. ../.."
- for i in $liblist; do
-- if test -f $i/libSDL.a -o -f $i/libSDl.so; then
-+ if test -f $i/libSDL-1.1.a -o -f $i/libSDL-1.1.so; then
- if test x"$i" != x"/usr/lib"; then
-- ac_cv_path_sdl_lib="-L$i -lSDL"
-+ ac_cv_path_sdl_lib="-L$i -lSDL-1.1"
- AC_MSG_RESULT(${ac_cv_path_sdl_lib})
- break
- else
-- ac_cv_path_sdl_lib="-lSDL"
-+ ac_cv_path_sdl_lib="-lSDL-1.1"
- AC_MSG_RESULT([yes])
- has_sdl=yes
- break