aboutsummaryrefslogtreecommitdiff
path: root/graphics/gnofract4d
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2003-05-19 01:07:18 +0000
committerPete Fritchman <petef@FreeBSD.org>2003-05-19 01:07:18 +0000
commit4e367af482e6c367cccbe910a0c82c4802175386 (patch)
treec1af76ea4ea6018d5c90e0fee2dc56aa60ed0c94 /graphics/gnofract4d
parent1954490a5a5f7333b9d6aa13bd6a40cf08b18241 (diff)
downloadports-4e367af482e6c367cccbe910a0c82c4802175386.tar.gz
ports-4e367af482e6c367cccbe910a0c82c4802175386.zip
- respect CXXFLAGS/LDFLAGS
- bump PORTREVISION PR: 52275 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=81315
Diffstat (limited to 'graphics/gnofract4d')
-rw-r--r--graphics/gnofract4d/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/graphics/gnofract4d/Makefile b/graphics/gnofract4d/Makefile
index 3f2187c4e993..6804a89ad31b 100644
--- a/graphics/gnofract4d/Makefile
+++ b/graphics/gnofract4d/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnofract4d
PORTVERSION= 1.7
+PORTREVISION= 1
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,18 +15,19 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Weird GNOME fractal generator
-USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack gnomelibs
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-compile-warnings=no
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name "*Makefile*" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|-g -O2 -Wall -D_REENTRANT|\@CXXFLAGS\@|g ; \
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|^CXXFLAGS =.* -D|CXXFLAGS = @CXXFLAGS@ -D|g ; \
s|gnofract4d_helpdir)/images|gnofract4d_helpdir)|g'
.include <bsd.port.mk>